open lid -> wrong resolution

Bug #40808 reported by Luka Renko on 2006-04-22
8
Affects Status Importance Assigned to Milestone
X.Org X server
Confirmed
Medium
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned

Bug Description

HP nw8240 with ATI FireGL V5000 PCIE card
https://wiki.ubuntu.com/LaptopTestingTeam/HPNW8240/Kubuntu

When I close the lid, the screen goes blank as it should. When I open the lid, I get very strange resolution (I would say 640x480 instead of 1920x1200) as the only thing that can be recognized is mouse pointer which is at least 3x size and streched.
I can get back to normal resolution if I do switch consoles (Ctrl-Alt-F1 followed by Ctrl-Alt-F7). Everything is normal after that.

This has started to occur somewhere around Flight 6 times, but I did not report it as I was not sure if my test powersave/kpowersave packages were causing it.

I have now installed Ubuntu Dapper Beta (from text install CD) and have not performed any update yet from repositories (I have seen there is new ati driver in repo - I may try it to see if it helps).
I plan to also install Kubuntu Dapper Beta on this machine (triple-boot).

Luka Renko (lure) wrote :

Same also on Kubuntu Dapper Beta.

Luka Renko (lure) wrote :

Very similar thing happens when I dock/undock laptop.

Luka Renko (lure) wrote :

Tested again with clean install of 6.06 LTC release (Kubuntu DVD).
This problem is only with Radeon driver, while proprietary fglrx driver does not have this problem.

Luka Renko (lure) wrote :

This is still the case with up-to-date Edgy using ati/radeon driver.

I run X at 1024x768. if I close the lid and open it again, X changes to
640x480 so I can't see most of my desktop anymore.
To restore to correct resolution, I switch to/from another virtual console.

Another workaround is to use vga=791 as a kernel boot parameter.

Created an attachment (id=7281)
my x config

This is on toshiba portege r100
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade XP4m32 (rev
91)

Luka Renko (lure) wrote :

This is still the case with Edgy RC.

Known issue. We need to react to ACPI events to fix it. I'll see what I can do.

Luka Renko (lure) wrote :

This is still the case with Feisty Herd1.

Is this bug supposed to be driver specific?
I have similar issue on Ubuntu with "ati" driver on HP nw8240 with ATI FireGL
V5000 PCIE card. The only difference is that background is unreadable.
More details: https://launchpad.net/bugs/40808

Luka Renko (lure) wrote :

Feisty Herd2: same problem.

Interesting is that if I use 1024x768 (wrong resolution used by wrongly detected screen size - see bug 61390), then after lid open, I can see normal mouse cursor, just the background is black with shades/artifacts. If I use 1920x1200 (which is native resolution of the display), then even mouse cursor is corrupted/black, however I can see where it is moving by artifacts moving around.

Changed in xorg-server:
status: Unknown → Confirmed

Sorry about the phenomenal bug spam, guys. Adding xorg-team@ to the QA contact so bugs don't get lost in future.

Luka Renko (lure) wrote :

Feisty Herd5 + latest xserver-xorg-video-ati version 6.6.3-2ubuntu2

Still the same problem.

Is it appropriate that this is assigned to Driver/Trident, as I see it also on Driver/Radeon?

This is still the case on Ubuntu Gutsy, using latest test packages for xrandr 1.2 branch: 6.7.192-1ubuntu2

Basilio Kublik (sourcercito) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Changed in xserver-xorg-video-ati:
status: New → Incomplete
Luka Renko (lure) wrote :

Yes, this is still the issue with up-to-date gutsy with bundled ati driver (1:6.6.193-1ubuntu1) and with the updated/test driver provided by XOrgOnTheEdge (xrandr 1.2 branch: 1:6.7.192-1ubuntu2).

There is one commit from today, that may be related to this issue, but I need to wait for new packages to try it out:
http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-ati.git;a=commitdiff;h=8ae69c496eba701e744cca0605f73242673f7b3f

Just tried latest version of ATI driver (6.7.193-1ubuntu1) on HP nw8240 with ATI FireGL V5000 PCIE - it does not solve the problem for me (even though the corruption is slightly different - before it was more horizontal, now it is across most of the screen).

Basilio Kublik (sourcercito) wrote :

today's upgrade seems to address this issue, could you please check?.

xserver-xorg-video-ati (1:6.7.193-1) experimental; urgency=low

  * New upstream release candidate.
    + Fix distortion after lid close/reopen, closes: #435114.
    + Stop wrongly detecting the TV-output as connected, closes: #439322.
    + Fix outputs after VT switch, closes: #443151.

 -- Brice Goglin <email address hidden> Thu, 20 Sep 2007 07:34:02 +0200

Luka Renko (lure) wrote :

Just tried latest version (6.7.193-1ubuntu1) on HP nw8240 with ATI FireGL V5000 PCIE - it does not solve the problem for me (even though the corruption is slightly different - before it was more horizontal, now it is across most of the screen).

Luka Renko (lure) wrote :

This is finally fixed for me in current gutsy (package 6.7.195-1ubuntu2)

Changed in xserver-xorg-video-ati:
status: Incomplete → Fix Released

This is fixed for me on HP nw8240 with latest ATI driver in Kubuntu Gutsy (6.7.195-1ubuntu2).

I'm experiencing something similar on an Toshiba R100 with Ubuntu 7.10... power management sends some kind of "Dim screen" signal, that triggers a resolution change. This can be reset by switching virtual console. It is easily triggered by taking out the power-plug.

Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.