hardy, locking assertion failure, xorg/libsdl

Reported by Alexander Rødseth on 2008-01-23
110
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Mobile Edition
Undecided
Unassigned
X.Org X server
Fix Released
Medium
libxcb (Debian)
Fix Released
Unknown
libxcb (Mandriva)
Confirmed
Undecided
Unassigned
libxcb (Ubuntu)
High
Bryce Harrington
Gutsy
Undecided
Unassigned
Hardy
High
Unassigned
Intrepid
High
Bryce Harrington
openoffice.org (Ubuntu)
Undecided
Unassigned
Gutsy
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
pygtk (Ubuntu)
Low
Unassigned
Gutsy
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Low
Unassigned

Bug Description

Binary package hint: xorg

If I run Savage (a 3D non-open source game for Linux, available for download on the internet), I get loads of these messages:

silverback.bin: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb6def767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb6def81e]
#2 /usr/lib/libX11.so.6 [0xb76ca5f8]
#3 /usr/lib/libX11.so.6(XUnmapWindow+0x25) [0xb76c0fb5]
#4 libs/libSDL-1.2.so.0 [0xb7e76f01]
#5 libs/libSDL-1.2.so.0 [0xb7e7840e]
#6 libs/libSDL-1.2.so.0(SDL_VideoQuit+0x52) [0xb7e6e99a]
#7 libs/libSDL-1.2.so.0(SDL_QuitSubSystem+0x8c) [0xb7e50298]
#8 libs/libSDL-1.2.so.0(SDL_Quit+0x20) [0xb7e502ec]
#9 ./silverback.bin [0x80a95d3]
silverback.bin: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb6def767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb6def81e]
#2 /usr/lib/libX11.so.6 [0xb76ca5f8]
#3 /usr/lib/libX11.so.6(XUnmapWindow+0x25) [0xb76c0fb5]
#4 libs/libSDL-1.2.so.0 [0xb7e76f01]
#5 libs/libSDL-1.2.so.0 [0xb7e7840e]
#6 libs/libSDL-1.2.so.0(SDL_VideoQuit+0x52) [0xb7e6e99a]
#7 libs/libSDL-1.2.so.0(SDL_QuitSubSystem+0x8c) [0xb7e50298]
#8 libs/libSDL-1.2.so.0(SDL_Quit+0x20) [0xb7e502ec]
#9 ./silverback.bin [0x80a95d3]
silverback.bin: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.
Locking assertion failure. Backtrace:
Segmentation fault (core dumped)

I searched the web for this error, and it seems like running another 3d game, neverwinter nights, causes the same problem on Hardy.
Here's a link to that:
http://ubuntuforums.org/archive/index.php/t-666726.html

Alexander Rødseth (alexanro) wrote :

Binary package hint: xorg

If I run Savage (a 3D non-open source game for Linux, available for download on the internet), I get loads of these messages:

silverback.bin: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb6def767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb6def81e]
#2 /usr/lib/libX11.so.6 [0xb76ca5f8]
#3 /usr/lib/libX11.so.6(XUnmapWindow+0x25) [0xb76c0fb5]
#4 libs/libSDL-1.2.so.0 [0xb7e76f01]
#5 libs/libSDL-1.2.so.0 [0xb7e7840e]
#6 libs/libSDL-1.2.so.0(SDL_VideoQuit+0x52) [0xb7e6e99a]
#7 libs/libSDL-1.2.so.0(SDL_QuitSubSystem+0x8c) [0xb7e50298]
#8 libs/libSDL-1.2.so.0(SDL_Quit+0x20) [0xb7e502ec]
#9 ./silverback.bin [0x80a95d3]
silverback.bin: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb6def767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb6def81e]
#2 /usr/lib/libX11.so.6 [0xb76ca5f8]
#3 /usr/lib/libX11.so.6(XUnmapWindow+0x25) [0xb76c0fb5]
#4 libs/libSDL-1.2.so.0 [0xb7e76f01]
#5 libs/libSDL-1.2.so.0 [0xb7e7840e]
#6 libs/libSDL-1.2.so.0(SDL_VideoQuit+0x52) [0xb7e6e99a]
#7 libs/libSDL-1.2.so.0(SDL_QuitSubSystem+0x8c) [0xb7e50298]
#8 libs/libSDL-1.2.so.0(SDL_Quit+0x20) [0xb7e502ec]
#9 ./silverback.bin [0x80a95d3]
silverback.bin: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.
Locking assertion failure. Backtrace:
Segmentation fault (core dumped)

I searched the web for this error, and it seems like running another 3d game, neverwinter nights, causes the same problem on Hardy.
Here's a link to that:
http://ubuntuforums.org/archive/index.php/t-666726.html

Alexander Rødseth (alexanro) wrote :
Timo Aaltonen (tjaalton) wrote :

Thanks, I've forwarded this upstream.

Changed in libxcb:
importance: Undecided → High
status: New → Confirmed
Changed in xorg-server:
status: Unknown → Confirmed

Hi!
I have a problem similar to this when I try to run Java based applications in Hardy Heron:
* frostwire
* matlab

"Locking assertion failure."
"java: xcb_xlib.c:82: xcb_xlib_unlock: Assertion `c->xlib.lock' failed."
In attachment, you 'll find complete backtrace of the problem.

Antoine Pairet (b-ly) wrote :
Antoine Pairet (b-ly) wrote :

Is this bug duplicate of: https://bugs.launchpad.net/bugs/86103 ?

Oh, damnit. This isn't a bug at all, it's user error.

I installed the application as root.

I am very sorry for wasting your time, please delete this bug.

Thanks for a great distro!

On Jan 27, 2008 7:25 AM, b_ly <email address hidden> wrote:

> Is this bug duplicate of: https://bugs.launchpad.net/bugs/86103 ?
>
> --
> hardy, locking assertion failure, xorg/libsdl
> https://bugs.launchpad.net/bugs/185311
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Alexander Rødseth (alexanro) wrote :

Nthalk, you're not talking about _this_ bug, right?

I think I am seeing same bug in vmware-server on hardy amd64

----

Locking assertion failure. Backtrace:
#0 /usr/lib32/libxcb-xlib.so.0 [0xf6f81767]
#1 /usr/lib32/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xf6f8181e]
#2 /usr/lib32/libX11.so.6 [0xf7dff5f8]
#3 /usr/lib32/libX11.so.6(XAddExtension+0x2c) [0xf7de2d7c]
#4 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2(_XftDisplayInfoGet+0x77) [0xf7ce5ed7]
#5 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2 [0xf7ce48b1]
#6 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2 [0xf7ce4d39]
#7 /usr/lib/vmware/lib/libXft.so.2/libXft.so.2(XftDrawPicture+0x10) [0xf7ce4ec0]
#8 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0xf7b319b6]
#9 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0xf7b33d75]
#10 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_draw_pixbuf+0x270) [0xf7b03c14]
#11 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0 [0xf7b1024f]
#12 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_draw_pixbuf+0x270) [0xf7b03c14]
#13 /usr/lib/vmware/lib/libgdk-x11-2.0.so.0/libgdk-x11-2.0.so.0(gdk_pixbuf_render_pixmap_and_mask_for_colormap+0x255) [0xf7b0fb34]
#14 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0xf7a14298]
#15 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0xf7a14586]
#16 /usr/lib/vmware/lib/libgtk-x11-2.0.so.0/libgtk-x11-2.0.so.0 [0xf7a1677e]
#17 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_cclosure_marshal_VOID__VOID+0xd1) [0xf7c29459]
#18 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0 [0xf7c113a1]
#19 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0(g_closure_invoke+0x1b1) [0xf7c11076]
vmware: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.

Aymeric PETIT (mulx) wrote :
Download full text (6.4 KiB)

I have the same bug when I want to run any java programs (netbeans 5.5 ; netbeans 6 ; java web start )
I am on hardy upgraded from a feisty. sun-java6 is installed

Runing java web start
petit@petit-laptop-L:~$ /usr/lib/jvm/java-6-sun-1.6.0.04/bin/javaws -verbose -viewer
Java(TM) Web Start 1.6.0_04 Launching: /usr/lib/jvm/java-6-sun-1.6.0.04/jre/bin/java
/usr/lib/jvm/java-6-sun-1.6.0.04/jre/bin/java
 -Xbootclasspath/a:/usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/javaws.jar:/usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/deploy.jar
 -classpath
 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/deploy.jar
 -Djava.security.policy=file:/usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/security/javaws.policy
 -DtrustProxy=true
 -Xverify:remote
 -Djnlpx.home=/usr/lib/jvm/java-6-sun-1.6.0.04/jre/bin
 -Djnlpx.jvm=/usr/lib/jvm/java-6-sun-1.6.0.04/jre/bin/java
 com.sun.javaws.Main
 -viewer

petit@petit-laptop-L:~$ Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb4bc3767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb4bc38b1]
#2 /usr/lib/libX11.so.6(_XReply+0xfd) [0x9068f29d]
#3 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so [0x90a3f8ce]
#4 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so [0x90a1c067]
#5 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so [0x90a1c318]
#6 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x2f) [0x90a1c61f]
#7 [0xb4c943aa]
#8 [0xb4c8cf0d]
#9 [0xb4c8cf0d]
#10 [0xb4c8a249]
#11 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/server/libjvm.so [0x637338d]
#12 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/server/libjvm.so [0x64fd168]
#13 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/server/libjvm.so [0x6373220]
#14 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/server/libjvm.so(JVM_DoPrivileged+0x363) [0x63c90d3]
#15 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xb7ca596d]
#16 [0xb4c943aa]
#17 [0xb4c8cda7]
#18 [0xb4c8a249]
#19 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/server/libjvm.so [0x637338d]
java: xcb_xlib.c:82: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.

petit@petit-laptop-L:~$

Runing netbeans 6 :
petit@petit-laptop-L:~$ /opt/netbeans/netbeans6/bin/netbeans
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb4390767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb43908b1]
#2 /usr/lib/libX11.so.6(_XReply+0xfd) [0xb43e529d]
#3 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so [0xb44e88ce]
#4 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so [0xb44c5067]
#5 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so [0xb44c5318]
#6 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x2f) [0xb44c561f]
#7 [0xb5b5eecd]
#8 [0xb5b57edd]
#9 [0xb5b57edd]
#10 [0xb5b55249]
#11 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/client/libjvm.so [0x621c40d]
#12 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/client/libjvm.so [0x6310378]
#13 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/client/libjvm.so [0x621c2a0]
#14 ...

Read more...

linovski (avelinorego) wrote :

Same bug here
hardy alpha 4
jdk6 / netbeans

linovski (avelinorego) wrote :

for now I solved the problem this way:
http://bugs.archlinux.org/task/8713
(
Try this as root:
sed -i 's/XINERAMA/FAKEEXTN/g' /opt/java/jre/lib/amd64/xawt/libmawt.so

The i686 users should use:
sed -i 's/XINERAMA/FAKEEXTN/g' /opt/java/jre/lib/i386/xawt/libmawt.so

)

linovski (avelinorego) wrote :

by the way, on ubuntu:
 sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so

Torsten Spindler (tspindler) wrote :

The java problem is also discussed here: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373

A work-around seems to exist with
$ export LIBXCB_ALLOW_SLOPPY_LOCK=1

Ferran Rius (frius64) wrote :

$ export LIBXCB_ALLOW_SLOPPY_LOCK=1

Didn't have any effect in my laptop, however,

sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so

solved the problem.

Alexander Rødseth (alexanro) wrote :

export LIBXCB_ALLOW_SLOPPY_LOCK=true works for me. I don't know if "1" and "true" are interchangeable in every shell, though. I use zsh.

Alexander Rødseth (alexanro) wrote :

(only for Java)

John Leach (johnleach) wrote :

Confirmed here too with Netbeans 6. Worked fine with Gutsy.

export LIBXCB_ALLOW_SLOPPY_LOCK=1 fixed the problem for now.

Greg A (etulfetulf) wrote :

"sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so"

This worked for me - geogebra had refused to load.

andrewpmk (andrewpmk) wrote :

Confirmed with JOSM (an editor for openstreetmap.org). The workaround works.

Timo Aaltonen (tjaalton) wrote :

Some of you have issues with java, which means bug 87947. This is about silverback

Jamey and I just announced a set of changes to XCB and Xlib/XCB which, among other things, should address all the outstanding synchronization problems that we know of. Could anyone experiencing this bug please build XCB and Xlib with the patches found at http://lists.freedesktop.org/archives/xcb/2008-March/003347.html and retest?

Jamey Sharp (sharpone) wrote :

Josh and I just announced a set of changes to XCB and Xlib/XCB which, among other things, should address all the outstanding assertion failures that we know of. Could anyone experiencing this bug please build XCB and Xlib with the patches found at http://lists.freedesktop.org/archives/xcb/2008-March/003347.html and retest?

Ryan Novosielski (novosirj) wrote :

I get this also using the UPEK fingerprint X display. I forget the actual name of it, but pam_bioapi brings up a dialog which now crashes (during KDM, it crashes KDM too, generally it just prints an error to the offending console).

fabius (fabio-ballatore) wrote :

I verify the same problem with lotus notes client v.8.0.1 installation, I supose e it's a eclipse problem with java 5 and 6.
I try to set LIBXCB_ALLOW_SLOPPY_LOCK=1 and sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/......... but it didn't
solve the problem
I try to repet the installation with lotus notes 8.0.0. but the result not change.
No problem with ubuntu 7.10
Thanks

joe williams (joetify) wrote :

I am having a similar issue with java applications, export LIBXCB_ALLOW_SLOPPY_LOCK=true seems to work for me.

cherry (dev-caltech) wrote :

sed: can't read /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so: No such file or directory

what to do ????

Slava (slava-slavix) wrote :

same problem ubuntu 7.10, 8.04. tried all proposed workarounds
export LIBXCB_ALLOW_SLOPPY_LOCK=1
export LIBXCB_ALLOW_SLOPPY_LOCK=true
sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun/jre/lib/i386/xawt/libmawt.so

none worked for me. :(

Christian Zeller (chrizel) wrote :

> sed: can't read /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so: No such file or directory
> what to do ????

The directory name changed because of a newer java version on current Hardy systems. So change 04 to 05:

sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/xawt/libmawt.so

Worked for me.

Ryszard Szopa (ryszard-szopa) wrote :

Apparently it has nothing to do with Java. I get the same error when trying to start Emacs. It seems to be related to today's Ubuntu update...

Prophet (prophet005) wrote :

Just for conformance i get the error too. It appears whenever i start a java gui application that uses swing/awt. Applications that uses swt (e.g. eclipse) don't appear to have the error.

Here the error output:

Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb53cb767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb53cb8b1]
#2 /usr/lib/libX11.so.6(_XReply+0xfd) [0xb54151bd]
#3 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/xawt/libmawt.so [0xb54f68ce]
#4 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/xawt/libmawt.so [0xb54d3067]
#5 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/xawt/libmawt.so [0xb54d3318]
#6 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x2f) [0xb54d361f]
#7 [0xb5cc5ecd]
#8 [0xb5cbeedd]
#9 [0xb5cbeedd]
#10 [0xb5cbc249]
#11 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/client/libjvm.so [0x621c40d]
#12 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/client/libjvm.so [0x6310378]
#13 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/client/libjvm.so [0x621c2a0]
#14 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x363) [0x6272153]
#15 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xb7cd796d]
#16 [0xb5cc5ecd]
#17 [0xb5cbed77]
#18 [0xb5cbc249]
#19 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/client/libjvm.so [0x621c40d]
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb53cb767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb53cb81e]
#2 /usr/lib/libX11.so.6 [0xb5414518]
#3 /usr/lib/libX11.so.6(XGetVisualInfo+0x26) [0xb540b0a6]
#4 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/xawt/libmawt.so [0xb54d2319]
#5 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/xawt/libmawt.so [0xb54d2565]
#6 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/xawt/libmawt.so [0xb54d33c9]
#7 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x2f) [0xb54d361f]
#8 [0xb5cc5ecd]
#9 [0xb5cbeedd]
#10 [0xb5cbeedd]
#11 [0xb5cbc249]
#12 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/client/libjvm.so [0x621c40d]
#13 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/client/libjvm.so [0x6310378]
#14 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/client/libjvm.so [0x621c2a0]
#15 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x363) [0x6272153]
#16 /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xb7cd796d]
#17 [0xb5cc5ecd]
#18 [0xb5cbed77]
#19 [0xb5cbc249]

Prophet (prophet005) wrote :

SIDENOTE: Besides the error output i havn't noticed any crashes or something else going wrong within the applications.

fieldyweb (fieldyweb) wrote :

I've had VMware server working previously, and built an FTP Server using a VMWare image, however after updating today, i too am now getting this error on VMWare

vmware: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.

rerunning sudo vmware-config.pl didn't resolve this, but the modules did reload

I tried reinstalling VMware, still not working

8.04 AMD64

fieldyweb (fieldyweb) wrote :

Managed to Fix this, it was the VMware console causing the problem, but running

sudo ln -s /usr/lib32 /usr/l32
sudo sed -i -e 's/usr\/lib/usr\/l32/g' /usr/lib32/gtk-2.0/2.10.0/loader-files.d/libgtk2.0-0.loaders
sudo sed -i -e 's/usr\/lib/usr\/l32/g' /usr/lib32/libgdk_pixbuf-2.0.so.0.1200.9

Kjow (antispammoni) wrote :

Thank you linovski!

Problem fixed with: sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.05/jre/lib/i386/xawt/libmawt.so

:)

Prophet (prophet005) wrote :

Does this have to be done manually or will the updates today/tomorrow fox it? Current update didn't...

zbharucha (zubinb) wrote :

I've tried all the above suggestions and none of them seem to work. This still happens when invoking MATLAB:

Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0x7f5e05bdf97c]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x24) [0x7f5e05bdfa84]
#2 /usr/lib/libX11.so.6(_XReply+0x10f) [0x7f5e06f88f4f]
#3 /opt/matlab74/sys/java/jre/glnxa64/jre1.5.0/lib/amd64/xawt/libmawt.so(XineramaQueryScreens+0xfd) [0x7f5dab402285]
#4 /opt/matlab74/sys/java/jre/glnxa64/jre1.5.0/lib/amd64/xawt/libmawt.so(xineramaInit+0x63) [0x7f5dab3e7e84]
#5 /opt/matlab74/sys/java/jre/glnxa64/jre1.5.0/lib/amd64/xawt/libmawt.so(awt_init_Display+0x159) [0x7f5dab3e80f3]
#6 /opt/matlab74/sys/java/jre/glnxa64/jre1.5.0/lib/amd64/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x1d) [0x7f5dab3e8311]
#7 [0x7f5dbf345f9b]
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0x7f5e05bdf97c]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x15) [0x7f5e05bdfa15]
#2 /usr/lib/libX11.so.6 [0x7f5e06f88323]
#3 /usr/lib/libX11.so.6(XGetVisualInfo+0x2c) [0x7f5e06f7f72c]
#4 /opt/matlab74/sys/java/jre/glnxa64/jre1.5.0/lib/amd64/xawt/libmawt.so [0x7f5dab3e6d05]
#5 /opt/matlab74/sys/java/jre/glnxa64/jre1.5.0/lib/amd64/xawt/libmawt.so [0x7f5dab3e6f93]
#6 /opt/matlab74/sys/java/jre/glnxa64/jre1.5.0/lib/amd64/xawt/libmawt.so(awt_init_Display+0x2b7) [0x7f5dab3e8251]
#7 /opt/matlab74/sys/java/jre/glnxa64/jre1.5.0/lib/amd64/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x1d) [0x7f5dab3e8311]
#8 [0x7f5dbf345f9b]

The MATLAB window comes up but none of the menus are displayed.

Hardy Beta, amd64, java-6-sun-1.6.0.05

sothis (janos-dev) wrote :

This really seems like a libX11 problem, not a specific java one. I am currently developing an opengl application an stumbled on that problem while testing my program on ubuntu hardy amd64. In my case the problem occurs when calling glXSwapBuffers(), but not continuesly. therefore it's hard to track down, but i am on it at the moment. Until i found something specific here's the backtrace of my application so far:

#0 0x00007f48ea83a095 in raise () from /lib/libc.so.6
#1 0x00007f48ea83baf0 in abort () from /lib/libc.so.6
#2 0x00007f48ea8332df in __assert_fail () from /lib/libc.so.6
#3 0x00007f48ea54c17d in _XGetXCBBuffer () from /usr/lib/libX11.so.6
#4 0x00007f48ea54d343 in _XSend () from /usr/lib/libX11.so.6
#5 0x00007f48eb7c9625 in __glXFlushRenderBuffer () from /usr/lib/libGL.so.1
#6 0x00007f48eb7cb35f in __glXSetupForCommand () from /usr/lib/libGL.so.1
#7 0x00007f48eb7c7628 in glXSwapBuffers () from /usr/lib/libGL.so.1
#8 0x0000000000418795 in draw_scene (arg=0x7ffff3e4bfe0)
    at /home/laubej/workspace/pallas/pallas/drawscene.cpp:306
#9 0x00007f48eb30a3f7 in start_thread () from /lib/libpthread.so.0
#10 0x00007f48ea8dfb2d in clone () from /lib/libc.so.6
#11 0x0000000000000000 in ?? ()

Maybe someone else has an idea and can poke me into the right direction. It might be worth to notice that the rendering is done by MESA indirect glx, although i think that's not a problem with MESA at all.

Chris Gregan (cgregan) on 2008-06-09
Changed in ubuntu-mobile:
status: New → Confirmed
GrosBedo (gros-bedo) on 2008-06-16
Changed in libxcb:
status: New → Confirmed
Changed in libxcb:
status: Unknown → Fix Released
Chris Cheney (ccheney) on 2008-06-18
Changed in libxcb:
importance: Undecided → High
status: New → Confirmed
Bryce Harrington (bryce) on 2008-06-18
Changed in libxcb:
status: Confirmed → Fix Released
Bryce Harrington (bryce) on 2008-06-21
Changed in libxcb:
status: Fix Released → Triaged
Nizar Kerkeni (nizarus) on 2008-06-21
Changed in openoffice.org:
status: New → Confirmed
Chris Cheney (ccheney) on 2008-06-28
Changed in openoffice.org:
status: Confirmed → Invalid
status: New → Invalid
Bryce Harrington (bryce) on 2008-07-01
Changed in libxcb:
status: Confirmed → Won't Fix
status: New → Invalid
Changed in openoffice.org:
status: New → Invalid
Bryce Harrington (bryce) on 2008-07-09
Changed in libxcb:
assignee: nobody → bryceharrington
129 comments hidden view all 207 comments
Bryce Harrington (bryce) wrote :

The last several comments is doing nothing at all to help the case of those wishing to revert libx11. Still no data about *specific* apps with *specific* problems (backtraces or at least stderr msgs) are NOT being posted to this bug report. If problems are so pervasive, then I would expect it to be a simple matter to reproduce and post some factual details (screenshots, error logs, *something*). Simply ranting more loudly and being insulting doesn't help - just makes me question all the more if there actually are any facts behind the assertions. I'll give it a few more weeks but without solid evidence will close this as wontfix.

Ripping out xcb-enabled libx11 from hardy would be a HUGE amount of work that will impact a number of people, and not something I'm willing to entertain without unquestionably clear, detailed benefits that I can show to Canonical management and those people who will be affected by this and that will need to sign off on it. Many won't care so much about proprietary software to begin with, so convincing them to make changes simply to improve proprietary software is going to be hard to justify to begin with. Non-CoC comments like "remove the XCB infection!", "Does no one at Canonical CARE?" etc. just serve to harden opinions against making any further changes, and invest any further time beyond the good deal we've put in already.

mosteo (public-mosteo) wrote :

I hit this bug recently using the player/stage robot simulator [1]. Although the main GUI works okay, the amcl driver debug GUI will cause player to crash with the familiar locking assertions. I think that player/stage uses XCD through the C binding.

I know the above description is not totally helpful to someone not familiar with player/stage. I could produce a small testcase configuration after the 15th September if there is interest in reproducing it. For now I just wanted to contribute an actual instance in which this issue has been problematic, and not solvable with the options offered in this thread. In my case, I had to use a Gutsy installation within VirtualBox (which I already had for another regression, this time in kdenlive) to workaround the issue.

I don't really know if the problem is in libxcd or in the use that player makes of it, however.

[1] http://playerstage.sf.net

Bryce Harrington (bryce) wrote :

Btw, this bug is about XCB not XCD.

Rafael Sachetto (rsachetto) wrote :

I'm having this bug while trying to run a small pyqt application that uses threads.

python: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assert `((int) ((xcb_req) - (dpy->request)) >= 0)' failed.

Hello Bryce,

this is (again) the transcript from the proprietary CAD Application I
can not use anymore:

ic: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int)
((xcb_req) - (dpy->request)) >= 0)' failed.
Aborted

Attached is the complete strace -f transcript.

Hope this helps.

Let me know if there is anything else I can do to support you.

Thanks

Christian

Bryce Harrington wrote:
> The last several comments is doing nothing at all to help the case of
> those wishing to revert libx11. Still no data about *specific* apps
> with *specific* problems (backtraces or at least stderr msgs) are NOT
> being posted to this bug report. If problems are so pervasive, then I
> would expect it to be a simple matter to reproduce and post some factual
> details (screenshots, error logs, *something*). Simply ranting more
> loudly and being insulting doesn't help - just makes me question all the
> more if there actually are any facts behind the assertions. I'll give
> it a few more weeks but without solid evidence will close this as
> wontfix.
>
> Ripping out xcb-enabled libx11 from hardy would be a HUGE amount of work
> that will impact a number of people, and not something I'm willing to
> entertain without unquestionably clear, detailed benefits that I can
> show to Canonical management and those people who will be affected by
> this and that will need to sign off on it. Many won't care so much
> about proprietary software to begin with, so convincing them to make
> changes simply to improve proprietary software is going to be hard to
> justify to begin with. Non-CoC comments like "remove the XCB
> infection!", "Does no one at Canonical CARE?" etc. just serve to harden
> opinions against making any further changes, and invest any further time
> beyond the good deal we've put in already.
>
>

mosteo (public-mosteo) wrote :

@Bryce: Of course you're right, the xcd/xcb thing was an unfortunate mental glitch on my part.

thunter (thunter0512) wrote :

Dear Bryce,

Thanks for your hard work and the temporary workaround with the non-xcb libx11.

Unfortunately the problem is real and hurting and needs a proper fix for Hardy. I have come across a number of trusted old applications which fail in a similar way when running with the xcb based libx11 under Hardy.

I have created a minimal X11 program which demonstrates at least one aspect of the problem. It should help you to debug the problem and verify a solution.

I have attached the source, makefile, binary and a sample error log as a gzip-ed tar file.

To run the program from bash:

1) extract the files: tar -xzf x11test.tar.gz
2) build: make
3) run: ./x11test
4) note the error messages (Locking assertion failure ...)

Please note that this program (and the original from which this was cut&pasted from) runs fine on a large number of other OS platforms including earlier versions of Ubuntu, Redhat, FreeBSD, Mac OS X, Solaris etc.

Let me know if you need any more supporting material.

Best regards from Perth/Australia

Tom Hunter

--- On Sun, 7/9/08, Bryce Harrington <email address hidden> wrote:
The last several comments is doing nothing at all to help the case of
those wishing to revert libx11. Still no data about *specific* apps
with *specific* problems (backtraces or at least stderr msgs) are NOT
being posted to this bug report. If problems are so pervasive, then I
would expect it to be a simple matter to reproduce and post some factual
details (screenshots, error logs, *something*).
...

      Win a MacBook Air or iPod touch with Yahoo!7. http://au.docs.yahoo.com/homepageset

Adam Fonseca (adam-fonseca) wrote :

The libx11-noxcb library does fix this problem for vmware. The vmware startup scripts destroy any changes to LD_LIBRARY_PATH though, so it is not sufficient to add the LD_LIBRARY_PATH override to libx11-noxcb. You have to add the path later in the vmware startup scripts. I do it in /usr/lib/vmware/lib/wrapper-gtk24.sh and it works fine.

Colin Watson (cjwatson) wrote :

Could those people reporting problems over the last half-dozen comments or so please confirm whether the workaround Bryce posted works? Many people have not mentioned this at all.

  export LIBXCB_ALLOW_SLOPPY_LOCK=1

(Note that of course this has to be run in a terminal before starting the application in question in the same terminal.)

mosteo (public-mosteo) wrote :

I tried the export LIBXCB_ALLOW_SLOPPY_LOCK=[1|true] thing to no avail, just as some others have reported previously.

As for the -noxcb packages, I got a violation fault with them.

Timo Aaltonen (tjaalton) wrote :

the hardy package already uses sloppy locking by default, so the environment value does nothing.

Alex Demko (ademko) wrote :

Colin, for me, only the non-xcb libx11 packages seemed to help.

MikeMc (mikecmcleod) wrote :

I would like to fix vmware in /usr/lib/vmware/lib/wrapper-gtk24.sh so could Adam Fonseca say what the changes are?

Andy (andy-xillean) wrote :

Here is what I found out that was causing VMWARE console to crash with this bug in Hardy. I had a broken icon set. The default folder icons in gnome had broken links. After fixing the links this bug disappeared. If you run into this bug while starting the VMWARE Console then switch to the default Human theme and try again. If it works then you have a broken link in your custom icon theme that is triggering this bug some how. Here is what was causing this bug for me. In /usr/share/icons/customicons/scalable/places

ls -l
gnome-fs-directory.png -> folder
instead of folder.png

so i fixed the link to
gnome-fs-directory.png -> folder.png

Now vmware console starts up without issues.

MikeMc (mikecmcleod) wrote :

No this is not my problem. I switched to Human with no difference. Also, I do not have custom icons and no directory /usr/share/icons like Andy's.

Andy (andy-xillean) wrote :

I used this to install VMware on a fresh install
http://www.howtoforge.com/installing-vmware-server-on-ubuntu-8.04
When I installed the custom icon set I got the bug starting vmware both on
64bit and 32bit systems. On all the systems when I switch back to human
VMware Console starts up fine. Now that I have fixed the link in my custom icon theme
the VMware Console starts up fine with the custom icons on both 32 and 64bit systems
Not sure why you don't have a /usr/share/icons folder. Are you running Hardy Mike?

thunter (thunter0512) wrote :
Download full text (3.8 KiB)

Hi Colin,

The "export LIBXCB_ALLOW_SLOPPY_LOCK=1" did nothing good (or bad) for me, but the "non-xcb" version of libx11 did fix all problems I have seen. Note that on Sept 9th I have sent Bryce and this list a minimal X11 test program (source & binary) to reproduce the problem. It should help to debug the problem and verify a solution.

Let me know if you haven't received the test program and I will send you a copy.

Regards

Tom

--- On Thu, 11/9/08, Colin Watson <email address hidden> wrote:
From: Colin Watson <email address hidden>
Subject: [Bug 185311] Re: hardy, locking assertion failure, xorg/libsdl
To: <email address hidden>
Received: Thursday, 11 September, 2008, 1:56 AM

Could those people reporting
 problems over the last half-dozen comments
or so please confirm whether the workaround Bryce posted works? Many
people have not mentioned this at all.

  export LIBXCB_ALLOW_SLOPPY_LOCK=1

(Note that of course this has to be run in a terminal before starting
the application in question in the same terminal.)

--
hardy, locking assertion failure, xorg/libsdl
https://bugs.launchpad.net/bugs/185311
You received this bug notification because you are a direct subscriber
of the bug.

Status in Ubuntu Mobile Edition: Confirmed
Status in X.Org X server: Confirmed
Status in “libxcb” source package in Ubuntu: Triaged
Status in “openoffice.org” source package in Ubuntu: Invalid
Status in “pygtk” source package in Ubuntu: New
Status in libxcb in Ubuntu Gutsy: Invalid
Status in openoffice.org in Ubuntu Gutsy: Invalid
Status in pygtk in Ubuntu Gutsy: New
Status in libxcb in Ubuntu
 Hardy: Won't Fix
Status in openoffice.org in Ubuntu Hardy: Invalid
Status in pygtk in Ubuntu Hardy: New
Status in libxcb in Ubuntu Intrepid: Triaged
Status in openoffice.org in Ubuntu Intrepid: Invalid
Status in pygtk in Ubuntu Intrepid: New
Status in “libxcb” source package in Debian: Fix Released
Status in “libxcb” source package in Mandriva: Confirmed

Bug description:
Binary package hint: xorg

If I run Savage (a 3D non-open source game for Linux, available for download on
the internet), I get loads of these messages:

silverback.bin: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int)
((xcb_req) - (dpy->request)) >= 0)' failed.
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb6def767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb6def81e]
#2 /usr/lib/libX11.so.6 [0xb76ca5f8]
#3 /usr/lib/libX11.so.6(XUnmapWindow+0x25) [0xb76c0fb5]
#4
 libs/libSDL-1.2.so.0 [0xb7e76f01]
#5 libs/libSDL-1.2.so.0 [0xb7e7840e]
#6 libs/libSDL-1.2.so.0(SDL_VideoQuit+0x52) [0xb7e6e99a]
#7 libs/libSDL-1.2.so.0(SDL_QuitSubSystem+0x8c) [0xb7e50298]
#8 libs/libSDL-1.2.so.0(SDL_Quit+0x20) [0xb7e502ec]
#9 ./silverback.bin [0x80a95d3]
silverback.bin: ../../src/xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int)
((xcb_req) - (dpy->request)) >= 0)' failed.
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb6def767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb6def81e]
#2 /usr/lib/libX11.so.6 [0xb76ca5f8]
#3 /usr/lib/libX11.so.6(XUnmapWindow+0x25) [0xb76c0fb5]
#4 libs/libSDL-1.2.so.0 [0xb7e76f01]
#5 libs/libSDL-1.2.so.0 [0xb7e7840e]
#6...

Read more...

cparg (cparg) wrote :

Hello,

this setting had no visible influence in my case.
(Hardy, 64 Bit)

Christian

Colin Watson wrote:
> Could those people reporting problems over the last half-dozen comments
> or so please confirm whether the workaround Bryce posted works? Many
> people have not mentioned this at all.
>
> export LIBXCB_ALLOW_SLOPPY_LOCK=1
>
> (Note that of course this has to be run in a terminal before starting
> the application in question in the same terminal.)
>
>

MikeMc (mikecmcleod) wrote :
Download full text (9.2 KiB)

Sorry to add to the confusion Yes I have a /usr/share/icons/ folder but I do not have a /usr/share/icons/customicons folder. I am running Hardy, AMD64.
Setting the export LIBXCB_ALLOW_SLOPPY_LOCK=1
produces:
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/l3232/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module:...

Read more...

Andy (andy-xillean) wrote :

OK that l3232 is a typo. A result of you running the "sed fix" for 64bit. I did not have to run that fix on hardy 64bit fresh install. that l3232 is supposed to be l32 in the "sed fix" so it should be /usr/l32/gtk.....

DanTheta (dr-circlesquares) wrote :

Hiya -

Just to confirm, the noxcb deb files above allowed python-pyxine to work properly on hardy, where previously it had suffered a hard lockup just after creating the display visual object and spawning the X event thread on roughly 95% of attempts. This was tested on machines with Intel and NVidia graphics cards (failing ~95%), but strangely worked almost every time on Via boards (using the openchrome driver).

I would certainly like to have this module working on a long-term support release, but I understand the situation you're in. Thank you for your continuing efforts!

Of course, I realize I'm probably one of relatively few people using pyxine in favour of gstreamer ...

Is anyone else experiencing libxcb related crashes of evolution on x86_64?

See: https://bugs.launchpad.net/ubuntu/+source/libxcb/+bug/259708

Sebastien Bacher (seb128) wrote :

how is this issue a pygtk one?

Changed in pygtk:
importance: Undecided → Low
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We had been anticipating a fix for this issue in time for intrepid from libxcb upstream, but none was forthcoming. We did not have time during intrepid to explore the option of de-enabling xcb in libx11 (it would require changes to compiz and other things that now require it).

This bug has gotten long and difficult to follow, but we finally have some hard data in comments #169, #171, #181 on the remaining issues. It will require some additional analysis to determine if these bugs can be individually addressed or would only be fixed by a libxcb revert. I'll leave this bug open (but the intrepid task closed) in case of the latter, but if the former looks realistic we should break those bugs out into separate bugs so we can close this one.

Changed in libxcb:
status: Triaged → Won't Fix
Changed in pygtk:
status: Incomplete → Invalid
Bryce Harrington (bryce) wrote :

Closing out the pygtk tasks; there was never evidence presented that it has any relation to this bug. If you feel there's an xcb issue in pygtk, please file a new bug.

Changed in pygtk:
status: New → Invalid
status: New → Invalid
charly4711 (karl-h-beckers) wrote :

Bryce,

as far as fixing the applications are concerned, I don't quite follow why applications that used to work need to be fixed because libxcb apparently one way or another changes an API contract that it has no business of changing.

That being said, if somebody claims its the application's fault, I'd really appreciate some information about what I need to fix around somthing that wasn't even apparently broken with Xlib.

I can attach 3 backtraces of various ways xvidcap deadlocks with libxcb (variant 3 resulting in a complete X11 lockup, so I need to ssh into the box and kill xvidcap). The only thing I can see is that in one thread I'm trying to do XShmGetImage on a locked X display while in the other thread GTK does its stuff. Have I been doing this completely wrong for years without noticing? And I've just recorded more than an hour of screencasts without a single hang with your non-xcb libraries.

This issue keeps me from upgrading to intrepid because first I'll have to find a way of compiling the required X11 libs without xcb.

charly4711 (karl-h-beckers) wrote :

xvidcap deadlock backtrace 2

charly4711 (karl-h-beckers) wrote :

xvidcap deadlock backtrace 3

Alex Demko (ademko) wrote :

Ok, it seems the Intrepid upgrade didn't do anything to fix this issue for me.

If I ssh from an Intrepid (32-bit) desktop to an Intrepid server (64-bit) and run Matlab (which utilizes Java), it still runs "slow" (screen drawing is unnaturally sluggish). If I LD_LIBRARY_PATH in the non-xcb libX11 libraries on the server, it works fine.

Am I missing the fixes that where applied?

charly4711 (karl-h-beckers) wrote :

Alex,
can you make an intrepid non-xcb libX11 available somewhere?

Alex Demko (ademko) wrote :

charly4711, I'm just using libX11 I have from a Fedora 3/64-bit install I have on another machine (a machine I'm trying to replace with an Ubuntu one). I've also had success with Bryce's non-x11 .deb files (see my first posts on this bug, and his posts after that).

Alex Demko (ademko) wrote :

The Marble Blast game demo also exhibits this bug. I've only checked this under hardy, however.

The demo can be downloaded from http://www.garagegames.com/products/15/ (you can enter empty strings for the contact info).

Backtrace:

Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb7c93770]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x2d) [0xb7c9389d]
#2 /usr/lib/libX11.so.6(_XReply+0xfc) [0xb7ce345c]
#3 ./lib/libSDL-1.2.so.0(SDL_XF86VidModeQueryVersion+0x8c) [0xb7f7f76c]
#4 ./lib/libSDL-1.2.so.0(X11_GetVideoModes+0x156) [0xb7f7a896]
#5 ./lib/libSDL-1.2.so.0 [0xb7f7c5a9]
#6 ./lib/libSDL-1.2.so.0(SDL_VideoInit+0x24e) [0xb7f71a12]
#7 ./lib/libSDL-1.2.so.0(SDL_InitSubSystem+0x43) [0xb7f529c7]
#8 ./lib/libSDL-1.2.so.0(SDL_Init+0x21) [0xb7f52ad1]
#9 ./marbleblastgolddemo.bin [0x82179ad]
#10 ./marbleblastgolddemo.bin(dlopen+0x41) [0x804cc31]

I want to change the latest edition of libx11-6 with the "non xcb" version (I've the problem of jhyder79 in Pro/Engineer with very slowy slid-up windows). I've downloaded libx11-6_1.1.3-1ubuntu2~noxcb_i386.deb but I don't understand how to make the change with my actual libx11-6 (error: a later version is already installed). I've Intrepid Ibex 8.10 with pre-released and unsupported updates activated.

My actual installed version of libx11-6 is: 2.1.1.5-2ubuntu1.1

Ping? Any new status on this?

Bryce Harrington (bryce) wrote :

I've pinged upstream. Has anyone had a chance to test if this still occurs on Jaunty yet?

Hi Bryce,
ok. I've upgraded to jaunty now (from 8.10 with update-manager -d).

Now in ProE the refresh of windows is more fast that in previous version. There's only a "slight hiccups" initially when i open menu or parameter window, but for the rest it's perfect! Now it's possible to working again with ProE in Ubuntu! :D

In the terminal now i've only this message:

get fences failed: -1
param: 6, val: 0

but i don't know if it's relative to libxcb or to another library.

Bryce Harrington (bryce) wrote :

Thanks, sounds like it's resolved and can be closed for karmic.

Changed in libxcb (Ubuntu):
status: Triaged → Fix Released

The socket handoff patches have been shipping for a while now. This bug shouldn't be relevant any more. Sorry for the lack of feedback in the meantime, though.

Changed in xorg-server:
status: Confirmed → Fix Released
Jake Cobb (error404) wrote :

I just started having this problem in hardy (manifested by Java) after an update today (2009-07-14). The sed/XINERAMA workaround suggested by others earlier worked for now.

Here are the packages I upgraded, it began immediately afterward:

2009-07-14 09:12:52 upgrade libdbus-1-3 1.1.20-1ubuntu3.2 1.1.20-1ubuntu3.3
2009-07-14 09:12:52 upgrade dbus 1.1.20-1ubuntu3.2 1.1.20-1ubuntu3.3
2009-07-14 09:12:52 upgrade dbus-x11 1.1.20-1ubuntu3.2 1.1.20-1ubuntu3.3
2009-07-14 09:12:52 upgrade libtiff4 3.8.2-7ubuntu3.2 3.8.2-7ubuntu3.4
2009-07-14 09:12:52 upgrade libtiff-tools 3.8.2-7ubuntu3.2 3.8.2-7ubuntu3.4

Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
Displaying first 40 and last 40 comments. View all 207 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.