[nvidia-prime]Freeze while using touchpad

Bug #1220426 reported by Loris Zinsou on 2013-09-03
This bug affects 233 people
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Critical
xorg-server (Ubuntu)
Low
Unassigned
Trusty
Undecided
Unassigned

Bug Description

Using Asus N43SL laptop as an example, with nvidia-prime installed, so the dedicated NVIDIA graphics card (GT 540m) is in use, once in a while, my screen will freeze when I use my touchpad.

WORKAROUND: Use USB mouse.

WORKAROUND: Uninstall nvidia-prime and use integrated graphics.

WORKAROUND: Do a VT switch via Ctrl+Alt+F1 then Ctrl+Alt+F7.

In the attached Xorg.0.log, you can see "synaptics: ETPS/2 Elantech Touchpad: touchpad found" each time I did a VT switch and regained control:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1220426/+attachment/3801516/+files/Xorg.0.log

The following upstream report has a patch that addresses this issue:
https://bugs.freedesktop.org/show_bug.cgi?id=86288

Loris Zinsou (nepenthes) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-prime (Ubuntu):
status: New → Confirmed
Erno Kuusela (erno-iki) on 2013-09-24
tags: added: saucy
1 comments hidden view all 320 comments
Alberto Milone (albertomilone) wrote :

Whatever is causing this, it can't possibly be the nvidia-prime package, since it only contains helper scripts.

I'm reassigning this to the nvidia driver.

Changed in nvidia-graphics-drivers-319 (Ubuntu):
status: New → Confirmed
Changed in nvidia-prime (Ubuntu):
status: Confirmed → Invalid

Same here on precise.
Asus K53SV with Nvidia Optimus (GT 540m)

Loris Zinsou (nepenthes) wrote :

Any changes with nvidia 331.20 drivers ?

To me, there are no changes when using 331.20, same issue.

Alberto Milone (albertomilone) wrote :

@Daniel: any ideas?

NOTE: this happens with RandR offloading. (I can't reproduce it though)

Daniel Dadap (ddadap) wrote :

Sorry, I don't have any ideas. I don't think we've seen anything like this either; we'd probably need a machine that uses the same touchpad or touchpad driver.

If the Nouveau driver also supports the RandR 1.4 provider source capability, it might be an interesting experiment to configure PRIME with Nouveau -> modesetting to see if it's a generic interaction between the touchpad driver and RandR 1.4. Alternatively, it might be useful to attempt configuring an X screen on the Intel GPU using the modesetting driver and no offloading, to see if it's a general interaction between the touchpad driver and the modesetting X driver. That should be a lot easier to set up.

Or... another possibility would be to try configuring the offloading with the Intel driver as the provider output instead of the modesetting driver. I can't remember the specific problems we ended up having with the Intel driver that led us to recommend the modesetting driver in the README instead, but if the Intel driver works as an output for you, and the problem is due to an interaction between the modesetting and touchpad drivers, then this may be a way to avoid the problem.

These are all just wild guesses though; I don't have any good ideas as to why this might be happening.

Cieniek (cieniek) wrote :

I have exactly the same problem on Lenovo G700. If using GPU offloading and touch-pad it takes 5 to 120 s to experience a lock-up with that message in X-org log. Unexperienced user (not knowing about VT-switch) would think it's complete system freeze.

I'm having the same issues after upgrading to 13.10 and prime. The system locks most when accessing pull down menus Never happened under bumblebee but then again i was using 304 nvidia drivers. Also does the prime for 13.10 not have the extra menu in nvidia-settings to select PRIME Mode? discrete or Intel?

Changed in nvidia-prime (Ubuntu):
importance: Undecided → Critical
Changed in nvidia-graphics-drivers-319 (Ubuntu):
importance: Undecided → Critical

Same problem on ubuntu 13.10 and nvidia-prime (319 and 319-update).

Screen freeze randomly when using touch pad, and to fast "unfreeze" the screen I've to switch to console terminal (Ctrl+Alt+F1) and back to graphical console (Ctrl+Alt+F7)

Asus K53S with Nvidia Optimus (GT 540m)

Changed in nvidia-prime (Ubuntu):
status: Invalid → Opinion
Dmitry Motitskiy (dmotitskiy) wrote :

Same problem. Ubuntu 12.04 amd64, Elantech Touchpad, nvidia-331.20.

Screen freezes and I have to switch to VT and back.

Asus B400VC, Nvidia Optimus (GT 720M)

anna (annabuttler) wrote :

the same problem here. ubuntu 13.10 with nvidia 331.38 on amd 64 bit (GTX 680)

Corollax (corollax) wrote :

Same problem here.

Running a 64-bit 3.11.0-15-generic kernel on Mint 16 (based on Ubuntu 12.10) and both 319.60 and 331.20 drivers.

/proc/bus/input/devices reports an "ETPS/2 Elantech Touchpad".

Corollax (corollax) wrote :

Sorry, not sure how to edit my last comment: I'm using an GeForce 630M.

Not sure if this helps, but it's strictly a visual freeze. The system will recognize inputs after the "freeze" -- the screen just doesn't update until you switch back and forth from the virtual terminals.

Hopefully that will help you debug the problem.

iuuuuan (ivan-janes) wrote :

Same here on Lenovo G710 on saucy 64bit with Nvidia 319, GeForce 720M and /proc/bus/input/devices reports "ETPS/2 Elantech Touchpad". Freeze behaviour is the same as reported by Corollax.

iuuuuan (ivan-janes) wrote :

I have created file /etc/modprobe.d/psmouse.conf with following entry:

options psmouse proto=imps

I have rebooted the notebook and had to increase pointer speed of trackpad under System settings > Mouse & Touchpad after reboot. So far I don't have any issues with trackpad freezing.

Default parameter proto for psmouse module is set to auto. The current value of the proto paramater of psmouse kernel module can be read from /sys/module/psmouse/parameters/proto file:

cat /sys/module/psmouse/parameters/proto

After creating /etc/modprobe.d/psmouse.conf file parameter is set to ImPS/2.

The idea for changing psmouse proto parameter came from https://answers.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+question/176273.

So the quick fix would be:
1.) Run following command from terminal:
echo "options psmouse proto=imps" | sudo tee /etc/modprobe.d/psmouse.conf >/dev/null

2.) Reboot the system or reload psmouse module from terminal with following commands:
sudo modprobe -r psmouse && sudo modprobe psmouse

3.) Increase the speed of pointer under System settings > Mouse & Touchpad

Can anyone else confirm this fix ?

Evgeniy (ekazak48) wrote :

this bug confirmed not only for 13.10... My laptop Acer Aspire 5750G has this problem too. Ubuntu 14.04 LTS Beta...
Driver for GeForce v331.38

pablo.t89 (pablo.t89) wrote :

This bug is assigned to nvidia-graphics-drivers-319, but it definitely affects (at least) nvidia-graphics-drivers-331 as well.

By the way, should it not be reported upstream? Does such a report exist yet?

Loris Zinsou (nepenthes) wrote :

nvidia has no public bug tracker. They seem to know about this bug though, because this bug report has been reported on their forum, and a support engineer asked for more information (which was provided, but not followed by any other message).

Asad (asadkn) wrote :

Same issue here on Ubuntu 13.10 Nvidia GT 750M using nvidia-331 and nvidia-prime. The same issue doesn't happen when using #18 fix or using an external mouse. I also have a touchscreen (eGalax Inc. eGalaxTouch EXC7910-1023-12.00.00) - I wonder if that can cause the issue.

Regarding #18 fix, any idea if touchpad scrolling can be enabled (using a Synaptics touchpad here)? I would rather have scrolling - sure the freezes are annoying but Ctrl + Shift + F1 and Ctrl + Shift + F7 quickly brings it back - better than having no touchpad scrolling.

pablo.t89 (pablo.t89) wrote :

I believe that so called "#18 fix" is not an actual solution. It disables multitouch features and makes your touchpad recognized as a normal mouse (and since touchpad doesn't come with separate physical scroll wheel, you won't get scrolling while using that option). You keep an ability to move your cursor and click, but that's not what I would call a "usable touchpad".

I wonder whether it's related specifically to the touchpad drivers, or is it just about the amount of cursor-related events which are sent to xorg? While it happens only with nvidia drivers, there migh be a possibility to fix it by pathing the touchpad-related protocols in psmouse kernel module or something in xorg (related to xrandr protocol, possibly?).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: New → Confirmed
Seth Miers (miers-seth) wrote :

I have this problem on my ASUS UX32VD

Has anyone discovered a synaptics fix?

giamma (giamma-t) wrote :

I'm testing the new beta version of the nvidia drivers 337.12 installed via xorg-edgers
Cross your fingers but appereantly seems solved.
I've been testing it for a while, generally the freeze used to happen quickly.

Hope this helps

giamma (giamma-t) wrote :

No luck. It's always the same

tags: added: trusty
Bernardo Botella (contacuo) wrote :

Same here with a GT 780M and Ubuntu 14.04. By the way, if I close the laptop screen, wait until it goes to sleep and then I open the screen again, everything works again.

Timothy Lee (marlboromoo) wrote :

Same here with my ASUS S550C, Ctrl + Shift + F1 and Ctrl + Shift + F7 to bring it back.

Dmitriy Kodanev (dkodanev) wrote :

Asus K55VD, Xubuntu 14.04 LTS
I have swithed from bumblebee to prime and now having this issue.
Ctrl+Shift+FN helps but it's annoying.
I see it is too rather bug. And it is not fixed yet.
So probably I have to switch back to bumblebee...

Dmitriy Kodanev (dkodanev) wrote :

Sorry.
too rather bug -> rather old bug

giamma (giamma-t) wrote :

I switched back to nouveau, hope nvidia fixes this, it's a guilt not being able to use my video card properly

Dmitriy Kodanev (dkodanev) wrote :

It was interesting thing when I tried to switch back to bumblebee from nvidia-prime. I have done these steps:
sudo apt-get purge nvidia-prime
sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install nvidia-331 nvidia-settings
sudo apt-get install bumblebee bumblebee-nvidia primus primus-libs-ia32

But then I started World of Goo (from Steam) using optirun. And when in game startscreen I've pointed to profiles icon - there has been a freeze again!
I removed bumblebee, primus, nvidia-331.
After that I installed nvidia-319-updates, then bumblebee and primus.
And now i have no freeze at all.

So I think the bug is not in nvidia-prime but in nvidia-331driver, because with nvidia-319-updates there's no freeze.

Aziz (azizth) wrote :

Seems a bug with synaptics: ETPS/2 Elantech Touchpad , not Nvidia.
I remove Nvidia drivers and use Xorg default driver. Same problem, randomly system freeze.

A solution will be nice because this problem touch lot of users.

Having what closely looks like this bug with 14.04 LTS and Nvidia 610M+Inter HD4000 combo in a asus K55VD laptop. I can confirm switching VT as a working workaround. Also using an Elantech Touchpad.

Minium (minium) wrote :

I can confirm that since following comment #18, which is around 6 hours of use,
I haven't had any screen freezes anymore. Thanks for that!

pablo.t89 (pablo.t89) wrote :

@up: Definitely, following comment #18 makes the screen freezes stop. So does not touching the touchpad at all. Unluckily, neither of those two options lets you use the actual touchpad features like multitouch gestures (e.g. two-finger scrolling).

Minium (minium) wrote :

Indeed, it renders the touchpad functionality useless. Is there at least a way to disable the touchpad
(now in mouse mode) during typing?

I have the same problem on ubuntu 14.04 with elan touchpad. I use a optimus laptop with nvidia 640m gpu and intel gpu. Using the touchpad causes ubuntu to freeze, and it is possible to unfreeze going to and from a virtual console. I am using nvidia 331 and prime.

Viktor Samoylov (vicyn) wrote :

 same problem, i have Packard Bell EASYNOTE ENTV 11, ubuntu 14.04, ETPS/2 Elantech Touchpad, nvidia-graphics-drivers-331, nvidia-prime

Changed in nvidia-graphics-drivers-331 (Ubuntu):
importance: Undecided → Critical
Changed in nvidia-graphics-drivers-319 (Ubuntu):
status: Confirmed → Triaged
Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: Confirmed → Triaged
Changed in nvidia-prime (Ubuntu):
status: Opinion → Triaged
Changed in nvidia-graphics-drivers-343 (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-343 (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
Joe (j-iacovelli) on 2014-08-31
Changed in nvidia-prime (Ubuntu):
status: Triaged → Fix Released
Andreas Moog (ampelbein) on 2014-09-09
Changed in nvidia-prime (Ubuntu):
status: Fix Released → Triaged
tags: added: utopic
tags: added: patch
Changed in nvidia-graphics-drivers-319 (Ubuntu):
status: Triaged → Invalid
Changed in nvidia-graphics-drivers-331 (Ubuntu):
status: Triaged → Invalid
Changed in nvidia-graphics-drivers-343 (Ubuntu):
status: Triaged → Invalid
Changed in nvidia-prime (Ubuntu):
status: Triaged → Invalid
Changed in xorg-server:
assignee: nobody → Nikhil Mahale (nmahale)
Renji (romd996) on 2014-11-14
Changed in xorg-server:
assignee: Nikhil Mahale (nmahale) → nobody
importance: Undecided → Unknown
status: New → Unknown
Changed in xorg-server:
importance: Unknown → Critical
status: Unknown → Confirmed
bluevector (ballifatih) on 2014-11-26
Changed in nvidia-prime (Ubuntu):
status: Invalid → Confirmed
Changed in nvidia-graphics-drivers-346 (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers-346 (Ubuntu):
status: Confirmed → Invalid
Changed in nvidia-prime (Ubuntu):
status: Confirmed → Invalid
Changed in nvidia-drivers-ubuntu:
status: New → Invalid
no longer affects: nvidia-prime (Ubuntu)
no longer affects: nvidia-graphics-drivers-346 (Ubuntu)
no longer affects: nvidia-graphics-drivers-343 (Ubuntu)
no longer affects: nvidia-graphics-drivers-331 (Ubuntu)
no longer affects: nvidia-graphics-drivers-319 (Ubuntu)
affects: nvidia-drivers-ubuntu → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: Invalid → New
importance: Undecided → Low
status: New → Triaged
description: updated
tags: added: cherry-pick
Changed in xorg-server:
status: Confirmed → Fix Released
tags: added: patch-accepted-upstream pointer vivid
tags: removed: saucy
Timo Aaltonen (tjaalton) on 2015-03-14
Changed in xorg-server (Ubuntu):
status: Triaged → Fix Released
Changed in xorg-server (Ubuntu Trusty):
status: New → Confirmed
Changed in xorg-server (Ubuntu Trusty):
status: Confirmed → Fix Committed
Changed in xorg-server (Ubuntu Trusty):
status: Fix Committed → Fix Released
240 comments hidden view all 320 comments

How can the fix be installed in Ubuntu 14.04?

"Additional Drivers" still only finds version Nvidia version 331.113

Stephane Goldstein (s-n-g) wrote :

Same for Asus K550JK (GTX 850M)
Ubuntu 14.04.2 fresh install.

@ Keith Helms #267
Have you managed to fix it in 14.04.02 ?

1 comments hidden view all 320 comments
Sun Shiranui (happymaskmac) wrote :

I just checked and I'm still having this issue using elementary OS Freya (based on Ubuntu 14.04 LTS).

Ken (kenaycock) wrote :

Same problem, resolved via VT.

Ubuntu 14.04, 640M, 331.20 drivers.

Any chance the patch will get pushed to the official repos soon? (fingers crossed)

1 comments hidden view all 320 comments
Timo Aaltonen (tjaalton) wrote :

no reason to close this for trusty as noone has done the work to backport the commit there..

this is fixed in 15.04 and up, and will be included in the lts-vivid backport stack which is used by default in 14.04.3 installer images

Changed in xorg-server (Ubuntu Trusty):
status: Fix Released → Triaged
Sebastien Bacher (seb128) wrote :

(unsubscribing sponsors, there is nothing left to sponsor)

Kyle (agronick) wrote :

What would happen if I installed this on Freya? Would it break stuff?

1 comments hidden view all 320 comments

Not one single freeze within the last six weeks! Yipieh!

I guess the packages I compiled will work under Ubuntu 14.04(.x) also since MINT 17.1 it's just another layer on top of it.

HP

Kyle (agronick) wrote :

I just wanted to update. Its not fixed on EOS Freya.

The freezes re-appeared about 10-14 days ago. I whent back to standard packages and try https://bugs.launchpad.net/xorg-server/+bug/1220426/comments/18

bob justo (lejustes32) wrote :

Upgrading to xorg-1.16.4, the big disappears!
NO more freeze within 8 days.

Jean Jordaan (jean-jordaan) wrote :

I'm on Asus UX303LB, with NVIDIA GM108M [GeForce 940M], using nvidia-346 version 346.59.
I don't see any correlation with touchpad use.
In my case, window or application switching (alt-tab) is often very unresponsive (e.g. have to hold down alt-tab for 14 seconds before the switcher appears) (about 10 seconds in, a half-faded-in switcher appears).
Also, switching workspaces is often super unresponsive, freezing before jerking to the next workspace, or freezing halfway between workspaces.
In all cases, normal functioning resumes after 5-10 seconds frozen.

Stefan (stefan-luer) wrote :

Solved for my HP Compaq nx6125.
No more freezes since I applied #18.
Thank you very much!!!

Vassil Filipov (vakko-vakko) wrote :

So i just experienced a freeze (I normally use the intel card and a mouse) and i found out about this bug; Why the hell haven't they merged the patch yet???! There's a patch for like 10 months and nothing happens? I just received an xorg update and thought that it would have the fix but NO it doesn't.. building now ... one can only guess how many people suffer from this and they don't even know how to apply a patch :(

I am one of those who does not know how to apply a patch, so often have to get around this bug using Ctrl+Alt+F1 and Ctrl+Alt+F7, or external USB mouse. In general I am very pleased how much faster bugs get fixed in Ubuntu than in commercial operating systems. But this one has continued for over a year.

Alex Fisher (alefisherx) wrote :

#251 worked for me!
ThinkPad T440s/Ubuntu 14.04 LTS/Nvidia Geforce GT 730M/Driver Version: 346.82
#251's link explains how to do if you read if carefully.

1 comments hidden view all 320 comments
Alex Fisher (alefisherx) wrote :

 said in #300 that it has been fixed but still it freezes from time to time, but much better than before.

James (jamesrobertmooney) wrote :

I have the same problem, or, at least, a similar one. My system is: HP Pavilion dm1 / Ubuntu 14.04.3 LTS / Radeon HD 6320 graphics / PS/2 Synaptics TouchPad.

My touchpad stops working periodically. A display swap (CTRL+ALT+f1 etc.) *sometimes* solves the problem, but I'm also finding that sometimes my keyboard stops working at the same time - which of course means that I can't swap displays using the keyboard. The problem does seem to be solved by connecting a USB mouse and a USB keyboard - but as it's a laptop I can't always do that.

I have tried the solution suggested at post #18. This worked very briefly, but before long the touchpad and (non-USB) keyboard stopped working again.

I have briefly looked at the solution suggested at post #251. Pardon my ignorance as a relative novice, but do I need to compile the package at https://launchpad.net/~snafu109/+archive/ubuntu/xorg-server ? I've added the PPA address as instructed, but I'm guessing that's not all I need to do?

If someone could help with this I'd be very grateful.

Chucky (lechuck) wrote :

Bug is still alive in october 2015: it is nearly 25 months old ! The problem still arises with a fully up to date 14.04.

Config here:
Nvidia GTX 950M + Integrated Intel
Asus ROG G551J

Chucky (lechuck) wrote :

Note: Bug is still alive in october 2015 - that is nearly 25 months old !

== My config
Fully up to date 14.04.
Nvidia GTX 950M + Integrated Intel
Asus ROG G551J
Elantech Touchpad

== Elantech Touchpad, the common hardware
After seeking on the net, I've find (here: https://devtalk.nvidia.com/default/topic/766166/elantech-touchpad-related-nvidia-driver-freeze/) that many people who experience the bug have an Elantech Touchpad and are using the synaptics drivers.

To check if you're in the same situation:
$ cat /sys/class/input/mouse0/device/name
->> ETPS/2 Elantech Touchpad

== Proposed workaround

It seems that the following workaround works, although I can't promise anything. We are however all expecting that NVidia developers fix their drivers properly.

    $ sudo apt-get remove xserver-xorg-input-synaptics-{your-flavour}
    $ sudo apt-get install xserver-xorg-input-mtrack-{your-flavour}

Hope you're doing better with that solution ;-)

Diego Martins (dondiego7) wrote :

I tried what @lechuck proposed and stopped the screen freeze, but my touchpad using mtrack didn't work quite well as it work using synaptics. ):

McLoy Loi Ivan (mcloy81) wrote :

sorry for my english , I'm Italian ...
1 year is that living with this bug or something . Continuous freeze random every day . But I do not have the touchpad . it is possible to have the same bug without it ? reading your comments I have tried to remove " xorg - input- synaptics " . it seems that by four days I have not had any freeze ....
linux mint cinnamon 17.2
nvidia gtx 460 Driver 346.87
Ps : is released update nvidia 346.96 has anyone tried it ?

DiegoAlberto (diegoalberto) wrote :

20 November 2015 and this issue persist on Ubuntu 14.04 based distributions.

My Setup:

N551JW
NVIDIA GTX 960m + Integrated Intel

MilkThief (evazzoler) wrote :

Same issue since I installed Ubuntu... Very annoying!
Lenovo T420
Nvidia NVS 4200M

Eldis (eldis.design) wrote :

I'm having this issue since the first boot of my new Dell Inspiron 5558 (with Nvidia GeForce 920M), and that's about 15 days already. Tried like millions of solutions including ones I found here, but nothing worked for me. Reinstalled Ubuntu for 20 times I think, from 14.04 to 15.10, tried UEFI and legacy boot (as someone somewhere suggested this as solution too), modified that one .conf file in modprobe.d as someone else suggested, added xorg-edgers repository and pulled the packages from it... I can't remember anymore what else I tried, but nothing helps.

Touchpad (pointer) freezes randomly without recognizable pattern. Sometimes right after the boot, sometimes 5 minutes after, sometimes one hour after, but eventually it will freeze, sonner or later. Sometimes it does not only freeze, it starts to act weird, opening right click menus while still frozen, like randomly generating all kinds of touchpad inputs. Sometimes it fixes itself after closing/opening laptop screen (going to suspend and waking), but this is not working every time also.

This is driving me insane. I love Ubuntu for years and I love my new DELL Inspiron, but having the laptop with defective touchpad defies its very purpose.

Eldis (eldis.design) wrote :

And one more thing.
In my case, there is NO difference whether proprietary or nouveau drivers are in use, the freeze will happen regardless. I just had to add this clarification, as I see people reporting this issue is happenning only on proprietary drivers, which is not true in my case.

Same problem on Dell 3443-a40 with 820m and Ubuntu 14.04 updated. Using nvidia-352 from ppa:xorg-edgers/ppa.

ohoboho (ohoboho) wrote :

Same on Assus K555L with KDE, the problem stooped or at least occurs rarely when ever you stop the turn of touch pad functionality on key enter form synaptic touch pad set up in System Settings->Input Device->Touchpad->l. Enable/Disable touch.
pad. And remove Disable touch pad when typing .
Hope it helps.

Eldis (eldis.design) wrote :

#313 This doesn't help in my case. Literally whatever I tried did't help till now. I'm testing the Win 10 Pro for the last two days, just to see if the same thing will happen, and yes, it does happen even on Win 10. Freezes occur less frequently, and are easily solvable by right then left button click on touchpad. It freezes whether Nvidia or integrated Intel graphics are in use.
It seems to me that this "elantech" touchpad is one @#&* of a touchpad, or the Nvidia card presence alone is making touchpad acts weird. Because, and I noticed that recently, even while in BIOS or live CD environment, touchpad freezes sometimes.

Minium (minium) wrote :

Hey guys,

since no fix for trusty has been released, I've taken matters into my own hands. My own repository includes the fixed discussed in comment #251. You use it as follows:

# sudo add-apt-repository ppa:minium/xorg-server
# sudo apt-get update && sudo apt-get upgrade

Cheers

Stefan (stefan-luer) wrote :

Said in #297 that it had been fixed but still it freezes from time to time, but much better than before. Applying #18 and #315 were not sufficient to solve it.

Václav Pavlík (pavl-va) wrote :

Same bug on HP Pavilion g6.
BUT I don't even have an Nvidia graphics card.
I have:
xorg and xserver-xorg both in version 1:7.7+1ubuntu8.1
xserver-xorg-input-synaptics 1.7.4-0ubuntu1

Not one of the proposed solutions has been successful for more than a few hours for me. The system also freezes quicker if I am on battery power. I even tried some workarounds to prevent USB powersave (since I thought I was the case), no luck.

Stefan (stefan-luer) wrote :

No freeze now for 9 days since installing nvidia-graphics-drivers-304-updates_304.131

This is bug is still persist in Kubuntu 16.4 LTS. Every time, when my laptop (HP Pavilion 15 Notebook PC) wake up from sleep the point freezes. To get it work again I do:

xinput set-prop 12 "Device Enabled" 1

where 12 in my touch-pad device number. and sometime ctrl+alt+f2 then ctrl+alt+f7 to get the pad accepting the clicking.

This is laptop has dual graphics cards (Nvidia GM108M [GeForce 840M] and intel) with default to Nvidia driver nvidia-361

Minium (minium) wrote :

I also still have it in Xubuntu 14.04.5 LTS with nvidia-355 drivers. I checked the sources of the current xorg-server package and the fix isn't adopted in them. Perhaps we could push somehow for it?

Displaying first 40 and last 40 comments. View all 320 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.