Microblog form error messages unclear

Bug #594759 reported by Matthew Holder on 2010-06-15
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fix Released
Alex Harrington

Bug Description

When adding a region for microblogging leaving either of the text fields empty results in a popup with the following error

"no template selected" or "must select template"

The errors should be made into something more human friendly. Also, does the "Default no content" HAVE to contain data?

I am using server 1.1.1

Related branches

On 1.2.0-rc1 it comes up "You must enter a template". Given that the boxes are labelled "template" then it's hard to see that the message can be significantly clearer.

What would you suggest?

As to whether the default content template must contain something, it could contain a single space character - but yes, the client must have something to show in the absence of any content - in exactly the same way as a text item must contain something, even if it's just a space character.

Also Matt - if you're doing more testing it would be helpful if you could test against 1.2.0-rc1 (or at least what will be that release) as 1.1.1 is released and the whole 1.1 series is now history.

The code is at lp:xibo


Changed in xibo:
status: New → Incomplete
summary: - After adding information in microblogging section it does not save
+ Microblog form error messages unclear
Matthew Holder (matt-mattmole) wrote :

Hi Alex,

I will double check tomorrow, but I thought the "template" error showed, even when the "Default when..." text box is empty. If that is true, then that is what I found confusing.

Could the first text box be called something like, "Microblogging message template".

I will admit that I did miss the title of the text box (I think my brain was working slowly this afternoon), also, the message on the error box made me think that I had forgotten to select a template from somewhere, some option in a pulldown I hadn't selected. I think I was thinking of template in the same way as when creating layouts.

Matt :)

Looking again at 1.2.0-rc1 as I have this evening it looks like we're not requiring the "no content" box to be completed, but that the appropriate xml block is still sent to the client which is fine.

In which case it's just a case of deciding upon a better term for those two boxes and adjusting the form/messages to match.

I like "Microblogging Message Template" however as it's on the microblog form maybe the first word is redundant so perhaps "Message Template" and "Message to show if there are no messages"?

Dan/Matt? What do you think?

Dan Garner (dangarner) wrote :

May not be worth saying this if you have tested but I am surprised that if
the no message box isnt filled in you still get content to the client - I
dont remember implementing a default value for that.

Might be worth leaving this open to remind me/you to check and see how that
is working.

Because the templates are in the raw block, you generate it like:

$raw = "<raw><template>$template</template><nocontent>$nocontent</nocontent></raw>";

So I always get an empty nocontent sent back - which is fine. So long as the nocontent tag is there.

Changed in xibo:
status: Incomplete → Confirmed
importance: Undecided → Low
assignee: nobody → Alex Harrington (alexharrington)
milestone: none → 1.2.0-rc1
Matthew Holder (matt-mattmole) wrote :

I also like Alex's suggested terminology

Changed in xibo:
status: Confirmed → Fix Committed
Changed in xibo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers