Logged in lights still funky in 1.1.1

Bug #588443 reported by Alex Harrington on 2010-06-01
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fix Released
Alex Harrington

Bug Description

I'm logged in to the unittest box and it's showing the logged in light for the Python Client as green but the last access time over 24 hours ago?

Screenshot attached.

Related branches

Changed in xibo:
status: New → Confirmed
importance: Undecided → Low
milestone: none → 1.2.0-rc1

Just checked I get the same output in Chromium.

Changed in xibo:
assignee: nobody → Alex Harrington (alexharrington)

Took a look at this. I found one little thing which isn't major but I think needs fixing.

In lib/pages/display.class.php line 284:

Shouldn't the column be named something unique rather than both L282 and L284 being "AS loggedin"?

CASE WHEN display.inc_schedule = 1 THEN '<img src="img/act.gif">' ELSE '<img src="img/disact.gif">' END AS inc_schedule,

Anyhow the grid that renders the display status seems to be looking at the loggedin column in the DB. I grepped through the code and can find where that's set to 1 but nowhere where it gets set back to 0.

Should this be changed to look at the time differential between display.lastaccessed and now? Is it worth me adding a config setting in the db for that interval too?

Changed in xibo:
status: Confirmed → Triaged
Changed in xibo:
status: Triaged → Fix Committed
Changed in xibo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments