Xibo Open Source Digital Signage

Encoding of RSS incorrectly set when downloading a RSS feed

Reported by Dan Garner on 2009-07-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Xibo
High
Dan Garner

Bug Description

Should use the Encoding value from the WebClient that fetched the feed.

Related branches

lp:~dangarner/xibo/395881
Xibo Maintainters: Pending requested 2009-07-07
Xibo Maintainters: Pending requested 2009-07-07
Dan Garner (dangarner) wrote :

See attached files for Patch to test

Changed in xibo:
assignee: nobody → Dan Garner (dangarner)
importance: Undecided → High
milestone: none → 1.0.3
status: New → In Progress
Dan Garner (dangarner) wrote :

-------- Message original --------

> ** Attachment added: "To replace a 1.0.2 XiboClient.XmlSerializers.dll"
> http://launchpadlibrarian.net/28717610/XiboClient.XmlSerializers.dll
>
hello,
i replace the two files on the xibo client, it's the same.
i had only that to do ?
change those two files ?

thanks

--

---------------------------------------------------------------
Pascal Legrand
*IUT de Chartres* - _Service Informatique_
---------------------------------------------------------------
1, place Roger Joly
28000 Chartres
Tel : 02 37 91 83 36 - Fax: 02 37 91 83 01

Correct, you should only have needed to replace those two files. However it
would also be wise to remove the client library files from the location you
set in "Xibo Options" so that they are re-downloaded from the server.
I'm thinking that maybe the old RSS is cached.

Cheers,
Dan

2009/7/6 Pascal <email address hidden>

>
> -------- Message original --------
>
> > ** Attachment added: "To replace a 1.0.2 XiboClient.XmlSerializers.dll"
> > http://launchpadlibrarian.net/28717610/XiboClient.XmlSerializers.dll
> >
> hello,
> i replace the two files on the xibo client, it's the same.
> i had only that to do ?
> change those two files ?
>
> thanks
>
> --
>
> ---------------------------------------------------------------
> Pascal Legrand
> *IUT de Chartres* - _Service Informatique_
> ---------------------------------------------------------------
> 1, place Roger Joly
> 28000 Chartres
> Tel : 02 37 91 83 36 - Fax: 02 37 91 83 01
>
> --
> Encoding of RSS incorrectly set when downloading a RSS feed
> https://bugs.launchpad.net/bugs/395881
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Xibo Open Source Digital Signage: In Progress
>
> Bug description:
> Should use the Encoding value from the WebClient that fetched the feed.
>

> Correct, you should only have needed to replace those two files. However it
> would also be wise to remove the client library files from the location you
> set in "Xibo Options" so that they are re-downloaded from the server.
> I'm thinking that maybe the old RSS is cached.
>
> Cheers,
> Dan
>

I do what you told me to do :
replace the two files
delete all the files in "C:\Documents and Settings\user\Mes documents\Xibo Library"
i change the rss flux, because the first on e had some problems, i use this one:
http://www.univ-orleans.fr/iut-chartres/actualites/rss.php

the problem is quiet the same

thanks for your help

--

---------------------------------------------------------------
Pascal Legrand
*IUT de Chartres* - _Service Informatique_
---------------------------------------------------------------
1, place Roger Joly
28000 Chartres
Tel : 02 37 91 83 36 - Fax: 02 37 91 83 01

-------- Message original --------

> Hi Pascal,
Hello Dan
>
> You are quite right... it still didn't work... I think I have got it
> fixed now though, could you test with the below patch files?
>
It seems to works now

> Also that feed still contains some invalid characters
> (http://beta.feedvalidator.org/check.cgi?url=http%3A%2F%2Fwww.univ-
> orleans.fr%2Fiut-chartres%2Factualites%2Frss.php) but the others should
> now display.
Some characters are not displayed " ' " and " - "
>
> Thanks,
THanks
> Dan
>

--

---------------------------------------------------------------
Pascal Legrand
*IUT de Chartres* - _Service Informatique_
---------------------------------------------------------------
1, place Roger Joly
28000 Chartres
Tel : 02 37 91 83 36 - Fax: 02 37 91 83 01

Dan Garner (dangarner) wrote :

Confirmed as fixed

Changed in xibo:
status: In Progress → Fix Committed
Dan Garner (dangarner) on 2009-08-09
Changed in xibo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions