Xibo Open Source Digital Signage

Can not change order of display of content when same media is used more than once

Reported by ldsonline on 2009-05-14
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Xibo
Medium
Dan Garner

Bug Description

You can not change the order of display in Layout / Design, Region Option. You can move and save, but the order of display is not changed. The only way to change the order is deleting all contents and entering again. For example., If I have 10 contents in layout and precise change the third , I have to delete the last 8 contents, insert the new content and then reinsert the contents that I deleted.

Thanks,

Lindomar

Related branches

Dan Garner (dangarner) wrote :

When you drag the media are you dropping it on a vertical spacer bar?

This could do with some improvement but basically when dragging your mouse pointer has to be over the vertical spacer for where you want the media to be re-ordered to.

If you are successful you get an "Order changed" message box - and the page will refresh to reflect your changes.

ldsonline (ldsonline) wrote :

I am having great difficulty in making changes. Sometimes I got, but I do not know what I did. You said to move the mouse pointer vertically, not horizontally?? There an absolute position to place the figure? The mouse should be moved only in a straight line? I would be grateful if you could help me.

Cheers.

Lucas (lucasgalodoidobh) wrote :

I'm in trouble too...

I'll admit, there is some room for improvement with this feature!

The each item on the timeline is seperated by a vertical line. To sort
the media how you want click and hold your mouse pointer over the
media and drag it. Release the pointer when it touches the vertical
line you want to move your media too... I hope this is clearer?

On 5/14/09, Lucas <email address hidden> wrote:
> I'm in trouble too...
>
> --
> Can not change order of display of content
> https://bugs.launchpad.net/bugs/376585
> You received this bug notification because you are a member of Xibo
> Maintainters, which is the registrant for Xibo.
>
> Status in Xibo Open Source Digital Signage: New
>
> Bug description:
> You can not change the order of display in Layout / Design, Region Option.
> You can move and save, but the order of display is not changed. The only way
> to change the order is deleting all contents and entering again. For
> example., If I have 10 contents in layout and precise change the third , I
> have to delete the last 8 contents, insert the new content and then reinsert
> the contents that I deleted.
>
> Thanks,
>
> Lindomar
>

--
Sent from my mobile device

Thank you, Dan, now I could do.

I think this is an opportunity for improvement, because the trend is the user drag the media and release it between the vertical space bars, as I was doing. Another possibility for improvement is:

In the box where the content to be inserted in the layout are chosen would be an interesting exist an option to define an order for the content in layout, independent of the order of upload of contents..

Cheers.

Lindomar

Dan Garner (dangarner) wrote :

I have created a blueprint of your suggestions and subscribed you to it. https://blueprints.launchpad.net/xibo/+spec/region-timeline-improvements

Thanks!

Changed in xibo:
assignee: nobody → Dan Garner (dangarner)
status: New → Invalid

I still can't do this. What am I doing wrong?

Dan Garner (dangarner) wrote :

http://wiki.xibo.org.uk/wiki/Manual:Layout:OrderTimeline#Instructions

Hopefully this helps... provided there is no errors on your page this should be quite simple (if a little clumsy)

Pedrito (morenop10) wrote :

Hi everyone,

I am having lots of problems with the software. I am testing it. But I don´t know how the schedule works. I designed the layout I scheduled it but I can´t see the videos and sometimes I can see the pictures but sometimes I can´t. I will appreciate any help from you. Thank you

Hi Pedrito

Firstly I'd suggest you post your questions in Launchpad Answers - https://answers.launchpad.net/xibo Tagging on general requests for help to specific bug reports - and worse closed bug reports - is very unlikely to get you a response.

Very general points like "I have lots of problems" aren't going to enable us to help you sort things out. You need to post specific questions.

Generally, I'd recommend the following:

* Start simple. Make a very simple layout. Incrementally add things until you have a problem. That will help you isolate the issue.

* When you have a problem, create a new layout and try and make the simplest case possible that still gives you the problem. Then post a question describing the problem in detail, and the layout you've designed to illustrate that. You can send screenshots to accompany the information to <email address hidden>

* Make sure you've read the release notes. There are known limitations with Xibo - for example you may not have regions that overlap. Ensure you aren't reporting something we already know!

Michael (michael-snyder) wrote :

I had a very similar issue, except for the fact that I have images between videos to break up the content. If I have the same image in the video multiple times and attempt to move one, it only moves the first image I inserted not subsequent images. Maybe I am just missing something but any help would be appreciated.

Hi Michael

I bumped in to this problem the other day and have mentioned it to Dan but I'm not sure how far he got with it. I'll mark this confirmed - but in the circumstance where you have more than one of the same media item in the timeline.

Alex

Changed in xibo:
status: Invalid → Confirmed
importance: Undecided → Medium
milestone: none → 1.0.6
Dan Garner (dangarner) on 2010-01-16
summary: - Can not change order of display of content
+ Can not change order of display of content when same media is used more
+ than once
Changed in xibo:
status: Confirmed → Fix Committed
Changed in xibo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers