TextMedia items do not display

Bug #334359 reported by Alex Harrington on 2009-02-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Xibo
Fix Released
Medium
Dan Garner

Bug Description

TextMedia items fail to show. Minimal case XLF attached.

Related branches

Changed in xibo:
importance: Undecided → High
milestone: none → 1.0.0-rc2
Dan Garner (dangarner) wrote :

that XLF is invalid...

duration cannot be null

Dan Garner (dangarner) wrote :

I have altered the dotNetClient slighty to cope with a null duration being sent (even though it shouldn't have to). It will now default to 60 seconds.

I don't believe that this is a dotNETclient bug though - it would see that the text module is generating XML without a duration in it - which would point to a bug with that class instead.

I wonder could you confirm whether the form allows you to set a null duration?

In which case the server should not have let me save the media item in that state?

Looks like emails crossed in mid air.

Yes - I can confirm that it's possible to create an XLF from the current server with a TextMedia item of NULL length.

I created a new layout, added a region, added a text media and typed some text in. I didn't even look at duration - because I think on all the other places we have a duration box, it is either required or has a sensible default?

On the textmedia edit form, the duration box is marked with a red asterisk - indicating required - but this is not enforced.

Dan Garner (dangarner) wrote :

I think then that the correct course of action here is to enforce the duration field.
I will do so.

Changed in xibo:
importance: High → Medium
status: New → Confirmed
assignee: nobody → dangarner
Dan Garner (dangarner) on 2009-02-27
Changed in xibo:
status: Confirmed → Fix Committed
Changed in xibo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments