[xfce]Double click title bar actions use different speed than text selection

Bug #393672 reported by positivek
78
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Xfwm4
Confirmed
Unknown
xfwm4 (Ubuntu)
Fix Released
Medium
Lionel Le Folgoc

Bug Description

Binary package hint: xfwm4

I noticed that double-clicking window title bars to (un)maximize them requires a faster double-click speed threshold than is used for other tasks in the system.

For example, try a relatively slow double-click to select a word in text or to open a directory in Thunar. That same slow double-click does not work to maximize or unmaximize windows in Xfce.

For consistency, these threshold for double-click detection should be the same across all parts of the UI.

 ------ additional information follows ------

It does seem, though, that adjusting the double-click time threshold affects both the title bar and the word-selection, but they still use different thresholds.

Also: When I double-click the title bar at the "slow" speed that would be sufficient to select a word, then
 * the selection _within_ the window temporarily blanks out as if the window was being moved.
 * the mouse cursor turns to the "hand" as if I were trying to move the window (click+drag).

I am using a laptop with a touchpad and with an external USB mouse, but the problem occurs using either.

I am using
  xubuntu-desktop 2.82
  xfwm4 4.6.0-1ubuntu3
installed on top of Ubuntu 9.04.

xfwm settings:
Appearance:
 - Style: New Wave Dark Menus
 - Icons: Crux
Window Manager:
 - Theme: Totem
 - Focus: Raise-on-click is turned off
Advanced:
 - Double click action: *any*

Revision history for this message
Rolf Leggewie (r0lf) wrote :

this has been driving me nuts, too. Confirming.

Changed in xfwm4 (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. Since you reported this against a development version of Xubuntu Karmic, Xubuntu 9.10 has had many changes since that time you reported the bug and your problem may have been fixed with some of the updates. Could you verify if this does still exist?

I have tried to reproduce this issue in both Xubuntu 9.10 and Lucid Lynx. I do set my mouse "Behavior, Double-Click time: 1200 milliseconds" .

Changed in xfwm4 (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
positivek (anonyhole) wrote :

Hello,

I am running Xubuntu "Karmic", 9.10 on a laptop with a touchpad.

This problem still exists, as originally reported.

Even when I tried the 1200 double-click timing, I noticed that if I managed to double-click just longer than the time it took to (un)maximize the window, the mouse cursor briefly turned to a hand (as reported). Importantly, the time required to double-click to select a word, for example, was longer than for the title bar (as reported).

I just had a thought: what if there's some code that's also looking out for click+drag from the TOUCHPAD that's being used (poorly) in tandem with detecting normal double clicks?

@Charlie Kravetz: Are you unable to reproduce on a normal desktop machine? Or do you have a laptop? I have a laptop that has a built-in touchpad that's always on, AFAIK. Perhaps the title-bar click+drag detection prempts (with a different threshold?) normal double-click detection when running on a machine with a touchpad. Something of this sort might explain why the cursor turns to a hand when I double-click too long for the title-bar, but _probably_ still within the normal double-click speed.

Revision history for this message
positivek (anonyhole) wrote :

Note also: The same (bug) behavior occurs when I ALT+<double-click> a window. It seems that it's supposed to act as if I am clicking the title bar, and therefore inherits this bug with the title bar. That is, the ALT+<double-click> time required is faster than a normal, text-selection double-click time required.

Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Thank you for the additional information and testing. I have reported the issue upstream and it can be tracked at: http://bugzilla.xfce.org/show_bug.cgi?id=6334

Changed in xfwm4 (Ubuntu):
status: Incomplete → Triaged
Changed in xfwm4:
status: Unknown → Confirmed
Revision history for this message
Juan Rodriguez (juanirodriguez85) wrote :

I have exactly the same problem.

Using xubuntu-desktop 2.112 and xfwm4 4.6.1-1ubuntu2 on top of Ubuntu 10.04.1 LTS

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Should be fixed in natty (xfwm4 4.7.4).

Changed in xfwm4 (Ubuntu):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: Triaged → Fix Released
Revision history for this message
Aldin K (aldin) wrote :

Hi, btw. tried xfwm4 from natty repos (on maverick) - didn't work

solution:

XFCEMenu -> Setting -> Settings Editor

Sections:

xfwm4

double_click_time = 400 and dbl_click_time = 400

xsettings -> Net

DoubleClickTime = 400

ps:
after changing 1. it didnt work, but 1. + 2. did work for me, so perhaps 1. is sufficient

Revision history for this message
Aldin K (aldin) wrote :

Forgot to say, perhaps xfwm4 from natty would work but it might have been pulled old xfwm4 .config... however that ^ is quick fix

Revision history for this message
Shimi Chen (shimi-chen) wrote :

Not fixed in oneiric.

Can confirm workaround in comment #8

Revision history for this message
linuxar (linuxar) wrote :

I just have the same problem in Xubuntu Precise.

Revision history for this message
Dmitry G. (hint) wrote :

Confirm problem in Xubuntu 12.04 Precise. And workaround from #8 is great.

Revision history for this message
Shimi Chen (shimi-chen) wrote :

Still an issue in 12.10. Workaround in #8 still works.

Revision history for this message
linuxar (linuxar) wrote :

Still an issue in 13.10 (quantal updated to ringtail). Workaround in #8 still works.

Revision history for this message
linuxar (linuxar) wrote :

Sorry, I meant in 13.4 (Raring).

Revision history for this message
Michael Lueck (mlueck) wrote :

I adjusted the speed to 400 per suggestion here:

http://ubuntuforums.org/showthread.php?t=2118805&p=12540305#post12540305

Then came to report success. It appears I am not alone in this change request. Please get this one in, should be simple / safe enough, and well enough community tested.

Revision history for this message
Jack Foxxx (rclemley) wrote :

I also confirm the issue with 13.04 raring. As with #8, changing only xfwm4:double_click_time = 400 did not work. I added the other two configs and it worked. I then removed xfwm4:dbl_click_time and the fix continued to work.

So, I'd say don't bother adding the xfwm4->dbl_click_time.

Thanks to everyone for the good info.

I think these settings should be the default.

Revision history for this message
flg (flg) wrote :

Still present in Xubuntu 14.04.

xsettings -> Net -> DoubleClickTime = 400 still works

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.