[UX] User is not able to go back to current/initial configuration

Bug #1555265 reported by Sorinello on 2016-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Xfce4 Panel Profiles
Fix Released
Undecided
Unassigned

Bug Description

Steps to reproduce:

1) Start XFCE Panel Switch
2) By default, the Current Configuration is selected
3) Select another configuration and apply it
4) Select back the Current Configuration and Apply it
5) You see that nothing happens.
6) You have to re-create your custom configuration

The user is mislead because he/she thinks that the Default Configuration is somehow saved/preserved, and when he/she wants to go back to own configuration, it cannot.

I cannot suggest a technical solution since I am not familiar with Linux programming, but maybe a temporary backup of the Current Configuration when starting application should prevent user frustration.

From this, I have learned to backup/export my Current Configuration before switching to another Config :)

Using Xubuntu 15.10 with latest updates, XFCE Panel Switch version: 1.0.3-0ubuntu1

I am also a regular on #xubuntu-devel and #xubuntu if you have questions or want to discuss this further.

Tags: ux Edit Tag help
Sorinello (sorinello) on 2016-03-09
description: updated
description: updated
Revision history for this message
Sean Davis (bluesabre) wrote :
Changed in xfpanel-switch:
status: New → Fix Committed
Sean Davis (bluesabre) on 2018-03-27
Changed in xfpanel-switch:
milestone: none → 1.0.5
Sean Davis (bluesabre) on 2018-03-27
Changed in xfpanel-switch:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers