Quit-button in desktop menu in Xfce does not always work

Bug #65720 reported by Bensin on 2006-10-12
22
Affects Status Importance Assigned to Milestone
xfdesktop
Confirmed
Unknown
xfce4-session (Debian)
Fix Released
Unknown
xfdesktop4 (Ubuntu)
Medium
Unassigned

Bug Description

Sometimes nothing happens when right-clicking on the desktop in Xfce and choosing "Quit" in the menu that appears.

When repeating this procedure it always works, and the "End session" dialogue appears as it should.

The problem is not entirely unlike Bug #51150. Sometimes it happens, and sometimes it don't.

I can confirm this. I think it might have to do with a dbus lag or something similar to Bug #551150.

Changed in xfce4:
status: Unconfirmed → Confirmed
Gauvain Pocentek (gpocentek) wrote :

On which version of Xubuntu does this happen?
I've never seen this in dapper nor in edgy...

Changed in xfce4:
status: Confirmed → Needs Info

It is occuring in Dapper.

It's still in Feisty.

Howdy125 (roger125) wrote :

Happens to me also in Feisty

Kari Aliranta (kpaliran) wrote :

Same problem here...

The bug to keep an eye on in the Xfce bugtracker is probably this (the initial report doesn't sound alike to this, but see comment #2):

http://bugzilla.xfce.org/show_bug.cgi?id=1109

Changed in xfdesktop:
status: Unknown → Confirmed
Kari Aliranta (kpaliran) wrote :

 A thing to check to narrow the bug down:

in my system, this bug *never* occurs if I use the keyboard shortcut (alt-F4) to initiate the Quit dialog. Does this prove to be the case with you, too?

Kari Aliranta (kpaliran) wrote :

 More info...I'm into audio editing, so I installed a real-time kernel, the one told about here:

https://wiki.ubuntu.com/RealTime/Feisty

When using RT-kernel, this bug occurs almost never (about 1 time in 30; vs. nearly every time, and often several times in a row, when I try to to quit when using normal kernel).

And Cody: what did you mean with "Bug #551150" ? There is no such bug...

Changed in xfdesktop4:
importance: Undecided → Medium
Changed in xfdesktop4:
status: Incomplete → Triaged

This appears to be no longer an issue in Xubuntu 7.10 (Gutsy). Thank you for your bug report. If you encounter this bug again in Xubuntu 7.10 (Gutsy), please feel free to reopen this bug.

Changed in xfdesktop4:
status: Triaged → Fix Released

I still have it!

Changed in xfdesktop4:
status: Fix Released → Confirmed

Yeah, I encounter this too sometimes. It sometimes will take two or three
clicks of the quit button to take effect. I thought I was just crazy :)

On Nov 6, 2007 4:14 PM, Radomir Dopieralski <email address hidden> wrote:

> ** Changed in: xfdesktop4 (Ubuntu)
> Status: Fix Released => Confirmed
>
> --
> Quit-button in desktop menu in Xfce does not always work
> https://bugs.launchpad.net/bugs/65720
> You received this bug notification because you are a member of Xubuntu
> Team, which is a bug contact for xfdesktop4 in ubuntu.
>

--
Mario Limonciello
<email address hidden>

Changed in xfdesktop4:
status: Confirmed → Triaged
Lionel Le Folgoc (mrpouit) wrote :

This is probably not the same bug, but there was also an issue with the menus and gtk+ in gutsy/hardy (fixed in xfdesktop4 4.4.2-2ubuntu2).

I haven't encountered this bug in Hardy since at least a month.

Changed in xfce4-session:
status: Unknown → Fix Released
Robert (robrwo) wrote :

I confirm this bug in Gutsy. Also have had it occur in Fesity.

Lionel Le Folgoc (mrpouit) wrote :

It seems to be fixed in hardy.

Changed in xfdesktop4:
status: Triaged → Fix Released
Robert (robrwo) wrote :

I think it's too soon to say fix released. The Xfce bug is still open.

Robert (robrwo) wrote :

This appears to be fixed in Hardy.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.