Volume and mute keys have no effect, but notification box does appear

Bug #970009 reported by polyvisual on 2012-03-31
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
xfce4-volumed
Undecided
Unassigned
xfce4-volumed (Debian)
New
Undecided
Unassigned
xfce4-volumed (Ubuntu)
Undecided
Unassigned

Bug Description

The volume and mute keys on my Lenovo G550 laptop running Xubuntu Precise Beta 2 don't have any effect on the volume or mute status.

The notification box does pop up showing the volume increasing / decreasing /muting as the buttons are pressed.

There is no change to the speaker icon in the top panel as the buttons are pressed.

---------------------------------------------------------------------------------------

Workaround from comment #11 by Neil Bryant:
"Go to the Xfconf Settings (in my XFCE, Applications Menu | Settings | Settings Editor) or run xfce4-settings-editor

go to xfce4-mixer

the active-card property sets what the volume keys target. In my case, sound-card is set to what the mixer is set to, but active-card is set to my HDMI card.

I copied the value from 'sound-card' to 'active-card', and the volume keys started working instantly."

polyvisual (matt-polyvisual) wrote :
description: updated
description: updated
polyvisual (matt-polyvisual) wrote :

After powercycling my laptop, the volume and mute keys now work fine.

I'm not sure where to go with this now.

Mustafa Khan (mustafaupk) wrote :

Same issue on the Xubuntu 12.04 beta. On Xubuntu 11.10 I can't change volume at all using the function keys.

Mustafa Khan (mustafaupk) wrote :

edit: Forgot to add, this is also on a Lenovo B575 laptop.

polyvisual (matt-polyvisual) wrote :

I'll boot from a live usb later and see if the same thing happens.

Steve Dodier-Lazaro (sidi) wrote :

Are the keys properly recognized by the system? Can you bind these volume keys to a command in the keyboard shortcuts app, for instance?

Changed in xfce4-volumed:
status: New → Incomplete
Jules Winnfield (voltarro) wrote :

I have the same problem on Lenovo G570.

Onkoistudios (onkoistudios) wrote :

I have the same problem on a Dell Optiplex 980. I can change the volume level of the indicator with the hardware keys (volume controls on my keyboard) but they do not actually effect the volume playing on my USB headset. When I open the sound settings and go to the Output Devices tab, it shows that the built in analog sound level is changing, but my headset is the currently active sound device.

Nyx Hysteria (nyx-hysteria) wrote :

Same problem on Toshiba Satellite L755, either on Xubuntu 12.04 or Debian Wheezy.
Everything works well with xfce4-mixer, alsamixer ou amixer command, but it looks like xfce4-volumed ignores the output selected in mixer : it keeps changing the HDMI output volume.
I tried setting keyboard shorcuts (with fn keys and amixer), they are well recognized when I create them, but when I want to use them xfce4-volumed is used (so HDMI volume changed). It looks like the deamon takes over the hotkeys I've set.

I've found a workaround : setting new hotkeys with amixer. Instead of fn+" and fn+' I use super+" and super+'
Commands are :
amixer sset Master 5-
to decrease volume and
amixer sset Master 5-
to increase it.

It works well as xfce4-volumed deamon doesn't recognize them as volume control, but it's quite disturbing at the beginning. ;)

affects: debian → xfce4-volumed (Debian)

Same problem seen on a Lenovo W520. It was working fine for several weeks, from a fresh Xubuntu 12.04 installation, then suddenly the volume buttons and notifications seem to be decoupled from actual sound volume (both audibly and in terms of the sound status icon and mixer level)

neil bryant (neil-bryant) wrote :

Same trouble: here's how I fixed it.

Note, I had already opened the mixer, and set it to the proper card. The mixer controls work for the volume, just fine; only the keyboard keys don't.

Go to the Xfconf Settings (in my XFCE, Applications Menu | Settings | Settings Editor) or run xfce4-settings-editor

go to xfce4-mixer

the active-card property sets what the volume keys target. In my case, sound-card is set to what the mixer is set to, but active-card is set to my HDMI card.

I copied the value from 'sound-card' to 'active-card', and the volume keys started working instantly.

What I *think* might have caused this, is that the active-card is set to the first card in the list (as shown in the mixer). This is a new install; at first the mixer didn't work, either, as it was also pointed to the first entry (HDMI). When I went to set the card in there, I would expect it to set the active card, but it doesn't seem to have.

Shimi Chen (shimi-chen) wrote :

I am experiencing this bug in Xubuntu 12.10(fully updated).
The volume keys are mapped correctly and work in other desktop environments(such as Unity&MATE).
I can confirm workaround in #11, thank you Neil!

Changed in xfce4-volumed:
status: Incomplete → Confirmed
tags: added: workaround
description: updated
Shimi Chen (shimi-chen) on 2012-11-06
Changed in xfce4-volumed (Ubuntu):
status: New → Confirmed
Mike Mogenson (jmogens) wrote :

In xfce4-mixer I do not have a property for sound-card. How can I create one?

Floriel (floriel) wrote :

I can confirm this bug for Lenovo Thinkpad E135 with Xubuntu 12.04
OSD reacts on Fn keys, but mixer ignores them.
Workaround doesn't work for me: sound-card property doesn't exist and creating it doesn't help either.

neil bryant (neil-bryant) wrote :

Floriel: did you try the 'active-card' property? That's the one that works for me.

Floriel (floriel) wrote :

Yes, I tried that. 'active-card' was set to
PlaybackEingebautesAudioDigitalStereoHDMIPulseAudioMixer
(witch it didn't affect) and I set it to
PlaybackEingebautesAudioAnalogStereoPulseAudioMixer
witch didn't work either.

gotya (d-info-s) wrote :

I can confirm this bug for Xubuntu 12.10 on Lenovo Thinkpad T410.

The entry ´sound card´ does not exist in my xfce4-mixer. Did anybody found already a way to find the correct string for ´active card´?

gotya (d-info-s) wrote :

After searching a bit further, I found the following instructions to create the correct String:

* Open "Sound Settings" (Alt+F2 and type: pavucontrol).
* Select the "Output Devices" Tab.
* Annotate the device's name, leaving out spaces and all characters from this list: ()[]-/
* Now add "Playback" to the beginning and "PulseAudioMixer" to the end of name annotated in the previous step. For me the correct value is: PlaybackBuiltinAudioAnalogStereoPulseAudioMixer

The instructions were taken from here:
  http://xubuntugeek.blogspot.ch/2012/05/fix-adjust-sound-with-multimedia-keys.html

So it did work finally work for me, by following the instructions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-volumed - 0.2.0-0ubuntu1

---------------
xfce4-volumed (0.2.0-0ubuntu1) raring; urgency=low

  * New upstream release (FFe lp: #1153378) with pulseaudio support.
    lp: #883485, #970009, #990562
  * debian/patches/xubuntu_preselect-pulseaudio.patch: dropped, unneeded.
  * debian/rules:
    - disable silent rules
    - keep the program named xfce4-volumed so the change is invisible to the
      users.
  * Add a manpage. lp: #428023
  * debian/control:
    - build-depends on libpulse-dev instead of libgstreamer0.10-dev and
      libgstreamer-plugins-base0.10-dev.
    - recommends pulseaudio instead of gstreamer.
 -- Lionel Le Folgoc <email address hidden> Thu, 14 Mar 2013 22:39:32 +0100

Changed in xfce4-volumed (Ubuntu):
status: Confirmed → Fix Released
Kalsan (info-kalsan) wrote :

gotya, in #18, you wrote that one should copy the value from pavucontrol. Do you know how to retrieve the value on a system with german translation?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments