volume buttons control wrong sound output device

Bug #901338 reported by udude on 2011-12-07
40
This bug affects 9 people
Affects Status Importance Assigned to Milestone
xfce4-volumed
High
Unassigned

Bug Description

With xfce4-volumed running, I am unable to control the output volume of a usb headset (logitech G930) using volume buttons. This is despite it being selected (in sound settings -> 'output' tab ).
I notice that the buttons are in fact controlling the output volume of the internal sound device, but unable to change.

Stopping xfce4-volumed and starting gnome-settings-daemon is a workaround to this problem.
With gnome-settings-daemon, the volume buttons can control the headset output (if it is selected).

udude (igal) wrote :
udude (igal) wrote :

btw, running Xubuntu 11.10

Adam Bolte (boltronics) wrote :

I had the same issue with my Logitech G35 headset (with internal USB sound card) volume controls actually adjusting the motherboard soundcard volume instead, but worked around the problem with these instructions:

http://ulno.net/2011/04/16/mixer-control-with-multimedia-keys-und-multiple-soundcards-in-xfce4-on-debian-or-ubuntu/

Probably nicer than using gnome-settings-daemon.

Adam Bolte (boltronics) wrote :

I should add that this only works if the headset is actually plugged in while xfce4-volumed is started *after* the USB headset is connected, so manually killing the process and launching it again is often necessary.

To save me from regularly doing this, I've mapped spare buttons on the headset as follows:

"amixer -- sset Master playback 10%-" to XF86AudioPrev
"amixer -- sset Master playback 10%+" to XF86AudioNext
"amixer -- sset Master toggle" to XF86AudioPlay

Definitely not as nice as using the volume scroll wheel, but it works. Perhaps a script to restart the xfce4-volumed process could have been triggered via Udev to provide a nicer looking work-around, but I didn't spend any more time on it.

Ingo Ruhnke (grumbel) wrote :

Same/similar problem here. Volumed by default ends up controlling the wrong sound-card. Instead of using PulseAudio it uses the actual soundcard, which then makes some buttons missbehave, i.e. I can mute with the multimedia-keys, but I can't unmute with them. I currently fix that with:

xfconf-query -v -c xfce4-mixer -l
killall xfce4-volumed
xfconf-query -v -c xfce4-mixer -p /active-card -s PlaybackBuiltinAudioAnalogStereoPulseAudioMixer

As there isn't an option in the GUI to do that (killing volumed is needed as otherwise the setting won't stick).

Steve Dodier-Lazaro (sidi) wrote :

Hey there,

The issue with merging xfce4-mixer and xfce4-volumed (and I did have a patch last year that allowed a second setting for controlling the active track in the mixer GUI) is that the maintainer of xfce4-mixer is looking for somebody else to replace him, and that I'm waiting for that somebody else to be officially designed to propose that s/he takes ownership of xfce4-volumed too and merges both applications once and for all.

In the meanwhile, the above hacks may help prevent you users from banging your heads on the nearest wall out of desperation as such simple features aren't implemented!

Changed in xfce4-volumed:
importance: Undecided → High
status: New → Confirmed
Nichita Uțiu (nikita.utiu) wrote :

The idea is that if pullseaudio is used, xfce4-volumed should control the default(fallback) output not the one in the xconf settings.

MercuryCC (mercurycc) wrote :

The workaround by Ingo worked for me.

Please still implement the fix. I have the same problem in Xubuntu 12.04.

Christiaan (anotherhero) wrote :

Thanks Ingo for the workaround this fixed it for me as well.

This problem still persists in Xubuntu 12.10 freshly installed today.

Oliver Etchebarne (drmad) wrote :

For choose the mixer device:

pactl list | grep -i description

(Si tu Linux es en español como el mío, debes de escribir "descripción" ;-) )

Grab your device name, and remove all the non-english-alphabetic characteres (like spaces, brackets, accented vowels, etc.). E.g: This device name:

 RS880 HDMI Audio [Radeon HD 4200 Series] Estéreo Digital (HDMI)

becomes:

 RS880HDMIAudioRadeonHD4200SeriesEstreoDigitalHDMI

Let's call it "{STRIPPED_DEVICE_NAME}". And then run:

killall xfce4-volumed
xfconf-query -v -c xfce4-mixer -p /active-card -s Playback{STRIPPED_DEVICE_NAME}PulseAudioMixer
xfce4-volumed

In my case, the internal audio device is called "Audio Interno Estéreo analógico", so set the active card to "PlaybackAudioInternoEstreoanalgicoPulseAudioMixer" did the trick :)

YMMV

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments