xvd_calculate_avg_volume: Process /usr/bin/xfce4-volumed was killed by signal 8

Bug #727047 reported by Christoph Wickert on 2011-03-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xfce4-volumed
Medium
Steve Dodier-Lazaro
xfce4-volumed (Fedora)
Fix Released
Undecided

Bug Description

abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 23093 bytes
cmdline: xfce4-volumed
comment: nothing else
component: xfce4-volumed
Attached file: coredump, 64020480 bytes
crash_function: xvd_calculate_avg_volume
executable: /usr/bin/xfce4-volumed
kernel: 2.6.38-0.rc5.git7.1.fc15.x86_64
package: xfce4-volumed-0.1.11-2.fc15
rating: 4
reason: Process /usr/bin/xfce4-volumed was killed by signal 8 (SIGFPE)
release: Fedora release 15 (Lovelock)
time: 1298548072
uid: 500

How to reproduce
-----
1.starting xfce
2.autostart xfce4-volumed
3.

Yes, everytime if i start the desktop.
So i've disable it in autostart

In a terminal

[rave@mother ~]$ xfce4-volumed

** (xfce4-volumed:12126): WARNING **: Binding 'XF86AudioRaiseVolume' failed!

** (xfce4-volumed:12126): WARNING **: Binding 'XF86AudioLowerVolume' failed!

** (xfce4-volumed:12126): WARNING **: Binding 'XF86AudioMute' failed!
** (xfce4-volumed:12126): DEBUG: The card HDANVidiaAlsamixer was found and set
as the current card.

** (xfce4-volumed:12126): DEBUG: There is no track label stored in xfconf

** (xfce4-volumed:12126): DEBUG: The wanted track could not be found, using the
first one instead.

** (xfce4-volumed:12126): DEBUG: Current track has no volume channels,
defaulting volume to 0.

Gleitkomma-Ausnahme (Speicherabzug geschrieben)

abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 23093 bytes
cmdline: xfce4-volumed
comment: nothing else
component: xfce4-volumed
Attached file: coredump, 64020480 bytes
crash_function: xvd_calculate_avg_volume
executable: /usr/bin/xfce4-volumed
kernel: 2.6.38-0.rc5.git7.1.fc15.x86_64
package: xfce4-volumed-0.1.11-2.fc15
rating: 4
reason: Process /usr/bin/xfce4-volumed was killed by signal 8 (SIGFPE)
release: Fedora release 15 (Lovelock)
time: 1298548072
uid: 500

How to reproduce
-----
1.starting the xfce-desktop
2.
3.

Created attachment 480730
File: backtrace

Does the application crash every time you start Xfce or only sometimes?

Package: xfce4-volumed-0.1.11-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

How to reproduce
-----
1.starting xfce
2.autostart xfce4-volumed
3.

Yes, everytime if i start the desktop.
So i've disable it in autostart

In a terminal

[rave@mother ~]$ xfce4-volumed

** (xfce4-volumed:12126): WARNING **: Binding 'XF86AudioRaiseVolume' failed!

** (xfce4-volumed:12126): WARNING **: Binding 'XF86AudioLowerVolume' failed!

** (xfce4-volumed:12126): WARNING **: Binding 'XF86AudioMute' failed!
** (xfce4-volumed:12126): DEBUG: The card HDANVidiaAlsamixer was found and set as the current card.

** (xfce4-volumed:12126): DEBUG: There is no track label stored in xfconf

** (xfce4-volumed:12126): DEBUG: The wanted track could not be found, using the first one instead.

** (xfce4-volumed:12126): DEBUG: Current track has no volume channels, defaulting volume to 0.

Gleitkomma-Ausnahme (Speicherabzug geschrieben)

Thanks for the feedback. Please attach your ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-mixer.xml to this bug report.

And please tell me what version ox xfce4-mixer you are using.

Created attachment 481561
xfce4-mixer.xml

[rave@mother ~]$ rpm -qa xfce4-mixer
xfce4-mixer-4.8.0-1.fc15.x86_64

I'm a litlle bit confused because xfce4-mixer.xml says that HDANVidiaAlsamixer is my active audio-card! That'wrong because it's the hdmi-output from my graphic-card and i don't used it.

Which card are you using then? Does xfce4-volumed still crash if you select the correct card?

Christoph Wickert (cwickert) wrote :
Christoph Wickert (cwickert) wrote :

$ rpm -qa xfce4-mixer
xfce4-mixer-4.8.0-1.fc15.x86_64

I'm a little bit confused because xfce4-mixer.xml says that HDANVidiaAlsamixer is my active audio-card! That'wrong because it's the hdmi-output from my graphic-card and i don't used it.

I have forwarded your bug to the developer of xfce4-volumed at
https://bugs.launchpad.net/fedora/+source/xfce4-volumed/+bug/727047

My default sound-card is a asus xonar XD.

But i 've found the problem. :)
After changing the line
<property name="active-card" type="string" value="HDANVidiaAlsamixer"/>
in
<property name="active-card" type="string" value="XonarDXAlsamixer"/>
in ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-mixer.xml, xfce4-volumed starts well.

[rave@mother ~]$ xfce4-volumed

** (xfce4-volumed:13510): WARNING **: Binding 'XF86AudioRaiseVolume' failed!

** (xfce4-volumed:13510): WARNING **: Binding 'XF86AudioLowerVolume' failed!

** (xfce4-volumed:13510): WARNING **: Binding 'XF86AudioMute' failed!
** (xfce4-volumed:13510): DEBUG: The card XonarDXAlsamixer was found and set as the current card.

** (xfce4-volumed:13510): DEBUG: There is no track label stored in xfconf

** (xfce4-volumed:13510): DEBUG: The wanted track could not be found, using the first one instead.

** (xfce4-volumed:13510): DEBUG: Xfconf volume step: 5

I put xfce4-volumed back in autostart and after a new login i found it the taskmanager and i've no abrt-alarm.

I don't know what's 'xfce4-volumed:13510): DEBUG: There is no track label stored in xfconf' does mean, but xfce4-volumed is working.
But i don't know what xfce4-volumed really do, because i'am using the xfce-desktop the first time (running away from gnome).

Should i give this info's to https://bugs.launchpad.net/fedora/+source/xfce4-volumed/+bug/727047, or is this issue really a bug?

Thanks for helping.

(In reply to comment #11)

> But i don't know what xfce4-volumed really do, because i'am using the
> xfce-desktop the first time (running away from gnome).

xfce4-volumed is responsible for making the XF86Audio* keys work. They work fine without the volumed because we have bound them to amixer (as you can see in Preferences -> Keyboard -> Shortcuts), but the advantage of xfce4-volumed is that it displays notifications and reads the xfce4-mixer configuration.

> Should i give this info's to
> https://bugs.launchpad.net/fedora/+source/xfce4-volumed/+bug/727047, or is this
> issue really a bug?

Yes please, if you have a launchpad account, please report this, otherwise I'll forward your information. This is a bug, regardless of the configuration of the mixer he volumed should not crash.

> Thanks for helping.

You are welcome. We are trying to make a good Xfce 4.8 release for Fedora 15 in order to give all the gnome-shell refugees a new home. You can help us by reporting bugs, testing updates and giving feedback at https://admin.fedoraproject.org/updates or in the wiki at
https://fedoraproject.org/wiki/Test_Day:2011-02-17_Xfce

If you like Xfce subscribe to the Xfce mailing list at
https://admin.fedoraproject.org/mailman/listinfo/xfce
or join the SIG at https://fedoraproject.org/wiki/SIGs/Xfce

Last but not least you can visit us at Chemnitzer Linuxtage, there will many Fedora contributors working at the Xfce booth.

raveit65 (raveit65) wrote :

My answer from rehat bugreport:

My default sound-card is a asus xonar XD.

But i 've found the problem. :)
After changing the line
<property name="active-card" type="string" value="HDANVidiaAlsamixer"/>
in
<property name="active-card" type="string" value="XonarDXAlsamixer"/>
in ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-mixer.xml, xfce4-volumed
starts well.

[rave@mother ~]$ xfce4-volumed

** (xfce4-volumed:13510): WARNING **: Binding 'XF86AudioRaiseVolume' failed!

** (xfce4-volumed:13510): WARNING **: Binding 'XF86AudioLowerVolume' failed!

** (xfce4-volumed:13510): WARNING **: Binding 'XF86AudioMute' failed!
** (xfce4-volumed:13510): DEBUG: The card XonarDXAlsamixer was found and set as
the current card.

** (xfce4-volumed:13510): DEBUG: There is no track label stored in xfconf

** (xfce4-volumed:13510): DEBUG: The wanted track could not be found, using the
first one instead.

** (xfce4-volumed:13510): DEBUG: Xfconf volume step: 5

I put xfce4-volumed back in autostart and after a new login i found it the
taskmanager and i've no abrt-alarm.

I don't know what's 'xfce4-volumed:13510): DEBUG: There is no track label
stored in xfconf' does mean, but xfce4-volumed is working.
But i don't know what xfce4-volumed really do, because i'am using the
xfce-desktop the first time (running away from gnome).

Should i give this info's to
https://bugs.launchpad.net/fedora/+source/xfce4-volumed/+bug/727047, or is this
issue really a bug?

Thanks for helping.

Steve Dodier-Lazaro (sidi) wrote :

Hello,

Xfce4-mixer / Xfce4-volumed pick the first card they can find when the system first starts, so if it's an invalid card there is not much to do except changing the default card in xfconf. I'd written a patch to unify the GUI for changing these settings but I'm not sure it was included in xfce4-mixer-preferences.

Regarding your crash, it indeed is a case I forgot to manage, despite having added protections against other causes of SIGFPE. I'm commiting a patch for it right now. Thanks for this report and for your useful debugging information.

FYI, Xfce4-volumed binds your volume keys so that they work and so that volume can be changed in real time by a dedicated daemon.

Changed in xfce4-volumed:
assignee: nobody → Steve Dodier (sidi)
importance: Undecided → Medium
status: New → In Progress
Steve Dodier-Lazaro (sidi) wrote :

Fixed in version 0.1.12.

Changed in xfce4-volumed:
status: In Progress → Fix Released

xfce4-volumed-0.1.12-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xfce4-volumed-0.1.12-1.fc14

xfce4-volumed-0.1.12-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xfce4-volumed-0.1.12-1.fc15

xfce4-volumed-0.1.12-1.fc15 has been pushed to the Fedora 15 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update xfce4-volumed'. You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xfce4-volumed-0.1.12-1.fc15

xfce4-volumed-0.1.12-1.fc15 has been pushed to the Fedora 15 stable repository. If problems still persist, please make note of it in this bug report.

xfce4-volumed-0.1.12-1.fc14 has been pushed to the Fedora 14 stable repository. If problems still persist, please make note of it in this bug report.

I can confirm that the update fixed the issue.

THX

Changed in xfce4-volumed (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.