[x86_64] trap divide error, rev. 1.8, 1.9, git

Bug #667617 reported by zbito on 2010-10-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xfce4-volumed
High
Steve Dodier-Lazaro

Bug Description

Running xfce4-volumed on my x64 Arch system.
AUR repo provides me with rev. 1.8 but when I try to start it I get:
xfce4-volumed[6437] trap divide error ip:4033cb sp:7fff2881d130
error:0 in xfce4-volumed[400000+6000]
kernel errors.

I've also build latest git with debug output. Running this one I end with:

--------------------
** (xfce4-volumed:28405): DEBUG: The card HDAATIHDMIAlsamixer was
found and set as the current card.

** (xfce4-volumed:28405): DEBUG: There is no track label stored in xfconf

** (xfce4-volumed:28405): DEBUG: The wanted track could not be found,
using the first one instead.

** (xfce4-volumed:28405): CRITICAL **: gst_mixer_get_volume: assertion
`volumes != NULL' failed
Error in float calculations
--------------------
on console output, and
xfce4-volumed[28422] trap divide error ip:402b72 sp:7fffbc0f3e18
error:0 in xfce4-volumed[400000+5000]
on kernel.

I can provide You with any additional information needed on request.
I hope we will be able to solve this problem.

PS. Same problem with rev. 1.9 and git.
I've not been using xfce4-mixer, only pulseaudio gnome's mixer.
But after installing xfce4-mixer same problem still exists.
I've tried three sound cards available from list:
- HDA ATI HDMI (Alsa mixer)
- XONAR D2X (Alsa mixer)
- Playback: CMI8788 [Oxygen HD Audio] Analog Surround 7.1 (PulseAudio
mixer) <----- which is my normal primary output

all produce same error.

Steve Dodier-Lazaro (sidi) wrote :

Sorry for taking so long to answer, this email got lost, and thanks for your report!

If you open xfce4-mixer's preferences window, how many tracks do you see for each card? I assume you see 0 tracks for the first card at least. I'll go through the code and add a check to prevent this scenario from causing a crash of the daemon asap.

Changed in xfce4-volumed:
assignee: nobody → Steve Dodier (sidi)
importance: Undecided → High
status: New → Confirmed
Changed in xfce4-volumed:
status: Confirmed → Fix Committed
Steve Dodier-Lazaro (sidi) wrote :

Fixed in 0.1.11

Changed in xfce4-volumed:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers