Multimedia keys not handled when numlock or caplock is on

Bug #665146 reported by Etienne Monette on 2010-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xfce4-volumed
Low
Steve Dodier-Lazaro

Bug Description

The daemon will not process multimedia keys when the state of the Keypress event is different from 0x0. Volume up or down is ignored by the deamon if numlock is on (state is 0x10) or if caplock is on (state is 0x2) or even if shift is on (state is 0x1).

Changed in xfce4-volumed:
assignee: nobody → Steve Dodier (sidi)
importance: Undecided → Low
status: New → Confirmed
Etienne Monette (emonette123) wrote :

I solved the problem.

The idea is to perform xcb_grab_key_checked for more than mod = 0x0. You need to perform the call 4 times, with mod equal to:

0x00 (no modifiers)
0x02 (Cap Lock)
0x10 (Num Lock)
0x12 (Cap Lock and Num Lock)

Modified the code from lp:~xubuntu-dev/xfce4-volumed/lucid branch, recompiled... Works like a charm.

I fixed the problem, posted a comment on the bug report. Would you need help to fix or distribute the fix. I saw many posts on the internet about that, but none really answered.
Thanks,Etienne

> Date: Fri, 22 Oct 2010 16:10:05 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 665146] Re: Multimedia keys not handled when numlock or caplock is on
>
> ** Changed in: xfce4-volumed
> Importance: Undecided => Low
>
> ** Changed in: xfce4-volumed
> Status: New => Confirmed
>
> ** Changed in: xfce4-volumed
> Assignee: (unassigned) => Steve Dodier (sidi)
>
> --
> Multimedia keys not handled when numlock or caplock is on
> https://bugs.launchpad.net/bugs/665146
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Volume management daemon for XFCE 4: Confirmed
>
> Bug description:
> The daemon will not process multimedia keys when the state of the Keypress event is different from 0x0. Volume up or down is ignored by the deamon if numlock is on (state is 0x10) or if caplock is on (state is 0x2) or even if shift is on (state is 0x1).
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/xfce4-volumed/+bug/665146/+subscribe

Steve Dodier-Lazaro (sidi) wrote :

Hello Etienne,

Thanks for your comment, it's highly appreciated.

However, the latest version of xfce4-volumed does not use libxcb anymore (keybinder, instead), but yet has the same problem. I've got to take the time to check how to tell keybinder_bind that I want to ignore key modifiers, but I've got plenty of work for at least the next two weeks, so it will have to wait a little.

Steve Dodier-Lazaro (sidi) wrote :

The up-to-date code can be found at http://git.xfce.org/apps/xfce4-volumed/, by the way. I'm not sure I took the time to update the Launchpad branch...

Changed in xfce4-volumed:
status: Confirmed → In Progress
Steve Dodier-Lazaro (sidi) wrote :

Fixed in 0.1.10

Changed in xfce4-volumed:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers