Some keyboard shortcut combinations do not work

Bug #454337 reported by Richard Griswold on 2009-10-18
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xfce4-settings
Confirmed
Unknown
xfce4-settings (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xfce4-settings

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu.

"lsb_release -rd" output:

Description: Ubuntu 9.04
Release: 9.04

(This is Xubuntu)

2) The version of the package you are using, via 'apt-cache policy packagename' or by checking in Synaptic.

"apt-cache policy" output:

xfce4-settings:
  Installed: 4.6.0-1ubuntu2
  Candidate: 4.6.0-1ubuntu2
  Version table:
 *** 4.6.0-1ubuntu2 0
        500 http://us.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

3) What you expected to happen

1. Open keyboard configuration (Applications→Settings→Keyboard or "xfce4-keyboard-settings" from terminal).
2. Switch to "Application Shortcuts" tab
3. Click "Add" button
4. Enter command in "Shortcut Command" dialog and click "OK" button
5. Press Super_L (left "Windows" key) and Space (or Super_L and Esc) in "Command Shortcut" dialog
6. Command shortcut dialog closes
7. New command shows up in shortcut list with shortcut set to "<Super>Space" or "<Super>Esc"

4) What happened instead

After command shortcut dialog closes, the new command does not show up in the shortcut list. If the shortcut already exists and I try changing the shortcut to <Super>Space or <Super>Esc, the shortcut key combo does not change. I can use Super with all other keys I've tested, such as letters, numbers, arrows, symbols, modifiers (shift, control, alt, etc.), print screen, pause, etc. If these two key combinations cannot be used for some reason, the application should display a notice when I try using them instead of silently failing.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
Package: xfce4-settings 4.6.0-1ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=zsh
SourcePackage: xfce4-settings
Uname: Linux 2.6.28-15-generic x86_64

Richard Griswold (richgriswold) wrote :
Richard Griswold (richgriswold) wrote :

Tested it in Xubuntu 9.10, and still have the same problem. The version of xfce4-settings is 4.6.3-1ubuntu1.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

This bug has been reported to the developers of the software. You can track it and make comments at:
http://bugzilla.xfce.org/show_bug.cgi?id=4972

Thanks for taking the time to make Ubuntu better!

Changed in xfce4-settings (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in xfce4-settings:
status: Unknown → Confirmed
Lionel Le Folgoc (mrpouit) wrote :

I guess that was fixed in Xfce 4.8 (not reproducible on precise at least).

Changed in xfce4-settings (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.