XFCE Keyboard Repeat Delay Setting Has No Effect

Bug #362455 reported by Rob McAuley on 2009-04-16
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xfce4-settings
Confirmed
Unknown
xfce4-settings (Ubuntu)
Medium
Lionel Le Folgoc

Bug Description

Binary package hint: xfce4-settings

OS: Xubuntu 9.04 fully updated as of April 16th, 2009
Suspected package:
xfce4-settings:
  Installed: 4.6.0-1ubuntu2
  Candidate: 4.6.0-1ubuntu2
  Version table:
 *** 4.6.0-1ubuntu2 0
        500 http://ubuntu.mirror.rafal.ca jaunty/universe Packages
        100 /var/lib/dpkg/status

Problem:
Changing repeat delay settings under Keyboard settings in XFCE Settings Manager has no effect.

To reproduce:
1. Open Keyboard settings
2. Test repeat delay using test box at bottom
3. Change repeat delay setting to 0
4. Test repeat delay using test box at bottom

Expected:
No repeat delay.

Got Result:
Default repeat delay.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

I can confirm that on a fresh installation of Jaunty using the Release Candidate image, "Repeat delay" has no effect. "Repeat speed" does work.

Thanks for taking the time to make Ubuntu better!

Changed in xfce4-settings (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
ByronBates (byronimo) wrote :

Although this bug might appear very non-critical to users of aa cable attached keyboard, somme people with wirreeless keyboards might suffer froomm duplicated keypresses due to a tiny key repeat rate.

That cann alsooo be very disturbing whenn using hotkeys to control windows or delete files as too many windows or files will be affected.

This text has beenn written under the aforementioned conditions, duplicate letters were the result.

ByronBates (byronimo) wrote :

An improvement to the duplicate key presses appears to be the following:

# force a different rate using an xserver command, setting the rate to 25 characters per time unit, starting to repeat after 300 milliseconds
sudo kbdrate -r 25 -d 300

This will only work for your current login. Also it appeared to either take some internal defaults ignoring the settings you provide, or it only changes the settings once - every additional change has no effect, although it claims to have changed the values accordingly.

If the xfce ( I am using this window manager ) repeat speed settings are adjusted once more, the configuration changees back to a small repeat delay. If thhe aforementioned command is runn again, it has no efffect.

I was using a relatted bug description to try to figure out a workaround:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/264196

ByronBates (byronimo) wrote :

Referring to my previous post: Actually the command

xset r rate 500 25
# prints on my computer with a dual screen setup: Xlib: extension "XFree86-Misc" missing on display ":0.0".

Will have the desired effect - I issued it before the kbdrate command, but it complained, hence I tried the kbdrate command and assumed it had an effect.

Using xset r rate 500 25 on can actually workaround this issue for now as it allows to properly set the desired repeat rate and repeat delay.

Changed in xfce4-settings:
status: Unknown → Confirmed
Dominic Sacré (dooooomi) wrote :

There's a trivial fix for this annoying bug:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=527238

Lionel Le Folgoc (mrpouit) wrote :

Sync requested in karmic, Bug #388318.

Changed in xfce4-settings (Ubuntu):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: Triaged → In Progress
Changed in xfce4-settings (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.