Workrave applet appears badly in system tray

Bug #370100 reported by fluffy on 2009-04-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Xfce panel
Confirmed
Unknown
xfce4-panel (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xfce4-panel

Workrave is a gnome app which provides a system tray applet, which is my preferred mode of display. However, this applet is flexibly-sized but xfce4-panel (as of Jaunty) no longer allows applets to take up more than one icon's worth of space. As a result, the timers are basically unusable.

The workaround is to use the floating-window timer display instead, but I'd much rather have it integrated into my xfce panel instead.

Oddly enough, when I take a screenshot with 'import,' the timer ends up leaking out of its constrained window and clobbering a bunch of other stuff on the panel (and still being unusable), but on my actual screen it's constrained to a tiny icon-sized area.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: xfce4-panel 4.6.0-1ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-panel
Uname: Linux 2.6.28-11-generic i686

fluffy (fluffy) wrote :
fluffy (fluffy) wrote :

With respect, this is NOT a duplicate of that bug - the issue with this bug is that some panel applets want to draw to a region that is non-square. The "artifacts" only appear when I try to take a screenshot, and if they have anything to do with the video driver it is only ancillary to the bug.

Please, run Workrave under gnome for a bit, and then again under xfce. Workrave wants to draw to a rectangular region (I'm not sure of the exact metrics but it's about a 4:1 aspect ratio) while the Xfce panel ends up cropping it to a 1:1 aspect.

Thank you.

Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

I can confirm this issue still exists in Lucid Lynx. Using xfce4-xfapplet-plugin version 0.1.0-3ubuntu4, the applet still does not display correctly when placed between existing icons.

This bug has been reported to the developers of the software. You can track it and make comments at: http://bugzilla.xfce.org/show_bug.cgi?id=6293

Thanks for taking the time to make Ubuntu better!

Changed in xfce4-panel (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in xfce4-panel:
status: Unknown → Confirmed
Lionel Le Folgoc (mrpouit) wrote :

Fixed in natty.

Changed in xfce4-panel (Ubuntu):
status: Triaged → Fix Released
Andreas Jonsson (sonofjon) wrote :

Still present in oneiric, and in precise beta 2.

Andreas Jonsson (sonofjon) wrote :

Sorry, my mistake. My comment was regarding Gnome, not XFCE.

fluffy (fluffy) wrote :

Yeah, this has been fixed in xfce for quite some time. :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.