xfce4-mixer mutes left channel (m-audio revolution)

Bug #135133 reported by mvoncken on 2007-08-27
2
Affects Status Importance Assigned to Milestone
xfce4-mixer
Confirmed
Unknown
xfce4-mixer (Ubuntu)
Low
Lionel Le Folgoc

Bug Description

Binary package hint: xfce4-mixer

Soundcard : m-audio Revolution 5.1 (Envy24HT)
Distribution:xubuntu feisty.

xfce4-mixer resets the "H/W" setting from "PCM out" to "H/W in 1" every ~15
seconds

The xfce4-mixer is out of sync with alsamixer.
Alsamixer shows the actual state of "H/W" while xfce4-mixer keeps resetting to
"H/W in 1" , but xfce4-mixer does not reflect that change in the gui and says
it's still "PCM out".

Actions on my pc:
Start playing a music file.
-no sound on left channel
start alsa-mixer: change "H/W" to PCM-out.
sound on left channel (for 15 seconds), gets reset to "H/W in 1"
-repeat the steps above as many times as you like.
kill xfce4-mixer
-problem solved.
start xfce4-mixer from terminal
-15 seconds later : no sound on left chan.
-alsamixer displays "H/W" is "HW in 1"
-xfce4-mixer displays "H/W" is "PCM out"
set "H/W" on xfce4-mixer to something else and set it back to "PCM out"
-no result
close xfce4-mixer gui
start xfce4-mixer from term
-xfce4-mixer still displays "H/W" is "PCM out"
-alsamixer still displays "H/W" is "HW in 1"
kill all xfce4-mixer processes, set H/W back using alsa mixer
-problem solved

---
Possibly totally unrelated , but there are more problems with the left channel
on this card.
But that is fixed by changing the volume once.
And it's not recurring every xx seconds like my problem.

http://www.google.nl/search?&q=m-audio+revolution+%22left+channel%22+muted+alsa&btnG=hi

---
registered this bug on xfce-bugzilla : http://bugzilla.xfce.org/show_bug.cgi?id=3503

Lionel Le Folgoc (mrpouit) wrote :

Thanks for your but report (but you don't have to report it systematically to ubuntu if you reported it upstream first :)

Changed in xfce4-mixer:
importance: Undecided → Low
status: New → Triaged
Changed in xfce4-mixer:
status: Unknown → Confirmed
Lionel Le Folgoc (mrpouit) wrote :

Hi,

If you are still using Xubuntu, could you retry with a newer version (released Xubuntu 9.04 or development snapshot of Xubuntu 9.10)? This issue may have already been fixed with the new xfce4-mixer.
Thanks!

Changed in xfce4-mixer (Ubuntu):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: Triaged → Incomplete
mvoncken (mvoncken) wrote :

solved in karmic, maybe earlier.

Changed in xfce4-mixer (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.