Clipboard history plugin for the Xfce4 panel

xfce4-clipman crashed with SIGSEGV in g_cclosure_marshal_VOID__BOXED() ... on logout

Reported by miegiel on 2010-03-05
132
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Xfce4-clipman-plugin
Confirmed
Unknown
xfce4-clipman-plugin (Ubuntu)
Medium
Lionel Le Folgoc

Bug Description

Binary package hint: xfce4-clipman-plugin

It's just a feeling, but I think xfce4-clipman needs more time to exit when logging off.

Description: Ubuntu lucid (development branch) Release: 10.04
(Xubuntu really)

xfce4-clipman:
  Installed: 2:1.1.3-1
  Candidate: 2:1.1.3-1
  Version table:
 *** 2:1.1.3-1 0
        500 http://nl.archive.ubuntu.com lucid/universe Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Fri Mar 5 11:10:07 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/xfce4-clipman
InstallationMedia: Xubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
Package: xfce4-clipman 2:1.1.3-1
ProcCmdline: xfce4-clipman
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic-pae
SegvAnalysis:
 Segfault happened at: 0x8050336: mov 0x4(%esi),%ecx
 PC (0x08050336) ok
 source "0x4(%esi)" (0x00000004) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: xfce4-clipman-plugin
StacktraceTop:
 ?? ()
 g_cclosure_marshal_VOID__BOXED ()
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
Title: xfce4-clipman crashed with SIGSEGV in g_cclosure_marshal_VOID__BOXED()
Uname: Linux 2.6.32-15-generic-pae i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (polkit-gnome-authentication-agent-1:7013): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (tomboy:6997): Gtk-WARNING **: Inserting action group 'Notebooks' into UI manager which already has a group with this name

miegiel (nix-miegiel) wrote :

StacktraceTop:
 default_clipboard_owner_change (manager=0x9edc450, event=0x9eb6950)
 g_cclosure_marshal_VOID__BOXED ()
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0

Changed in xfce4-clipman-plugin (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

This bug has been reported to the developers of the software. You can track it and make comments at: http://bugzilla.xfce.org/show_bug.cgi?id=6280

Thanks for taking the time to make Ubuntu better!

Changed in xfce4-clipman-plugin (Ubuntu):
status: New → Triaged
valdur55 (valdur55) wrote :

This bug causes random crash. System tray app and panel element crash.
Workaround: Use parcellite

Changed in xfce4-clipman-plugin (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Lionel Le Folgoc (mrpouit)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-clipman-plugin - 2:1.1.3-2ubuntu1

---------------
xfce4-clipman-plugin (2:1.1.3-2ubuntu1) lucid; urgency=low

  * (Fake-)sync 2:1.1.3-2 from testing to fix FTBFS.
  * debian/patches/0001-daemon-Fix-possible-NULL-values-bug-6119-6120.patch:
    fix crash on logout. lp: #532537
  * debian/rules: include simple-patchsys.mk.

xfce4-clipman-plugin (2:1.1.3-2) unstable; urgency=low

  * debian/rules:
    - drop useless removal of config.status, fix ftbfs closes: #564398
  * debian/control:
    - use << instead of < in conflicts/replaces.
 -- Lionel Le Folgoc <email address hidden> Sat, 27 Mar 2010 11:16:57 +0100

Changed in xfce4-clipman-plugin (Ubuntu):
status: In Progress → Fix Released
Changed in xfce4-clipman-plugin:
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.