Clipboard manager in xfce4 does not handle some objects used in openoffice.org

Bug #114125 reported by Olivier Robert on 2007-05-11
4
Affects Status Importance Assigned to Milestone
Xfce4-clipman-plugin
Confirmed
Unknown
xfce4-clipman-plugin (Ubuntu)
Low
Lionel Le Folgoc

Bug Description

This bug appeared to me as I used openoffice draw under xubuntu 7.04.

When I want to clone an object within ooo draw, I utilize the copy/paste function.

But it doesn't work as expected! The pasted object has nothing to do with the original.

Other users reported a similar problem with other apps from the openoffice suite.

I suspect a conflict/interference with the clipboard manager featured with xubuntu, namely "xfce4-clipaman-plugin" :

If I disable this plugin, the copy/paste function works again. I do so for now but it's not a very convenient way to solve the problem, a clipboard manager is very useful for me.

Using glipper instead of clipman bring to the same problem. It's not a solution.

I think these clipboard managers can't handle the special metadata of the objects used in ooo.

description: updated
description: updated
description: updated
Olivier Robert (olivierr) wrote :

I discovered a very similar bug with glipper as the cause of the problem.
bug n°104432
https://bugs.launchpad.net/ubuntu/+source/glipper/+bug/104432

description: updated
Olivier Robert (olivierr) wrote :

Sorry, the bug 104432 is not really the same.

Olivier Robert (olivierr) wrote :

I think this bug is caused by the clipboard manager "xfce4-clipman-plugin" that comes with the xfce desktop.
The problem is visible in openoffice draw but is not directly related to a bug in oOo.

Jesus Gamio (jgamio) wrote :

I test this behaviour.

Xubuntu 7.04
xfce4-clipaman-plugin

Don't just to the openoffice.org-draw the same to openoffice.org-impress, openoffice.org-calc, openoffice.org-writer, Gnumeric

but dont to abiword or inkscape or Gimp

I think the problem come in from the copy because:

if you take a object from abiword to openoffice.org-writer works fine
If you have a text in the clipboard then copy from openoffice.org-writer the paste this paste the text before

Changed in xfce4-clipman-plugin:
status: Unconfirmed → Confirmed
description: updated
description: updated
description: updated
Jesus Gamio (jgamio) wrote :

I test it in some application but the problem is just with openoffice

Changed in xfce4-clipman-plugin:
status: Confirmed → Unconfirmed
Changed in openoffice.org:
status: Unconfirmed → Confirmed
Changed in xfce4-clipman-plugin:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in xfce4-clipman-plugin:
status: Unknown → Confirmed
Lionel Le Folgoc (mrpouit) wrote :

Works for me, at least in karmic, but it has probably been fixed sooner.

Changed in xfce4-clipman-plugin (Ubuntu):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.