PM alert remains in indicator if sender changes his nickname

Bug #587902 reported by Y.Z. on 2010-05-31
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
XChat Indicator
Undecided
Unassigned
xchat-indicator (Ubuntu)
Undecided
Unassigned
Precise
Low
Unassigned

Bug Description

when someone sends me a private message (alert in indicator applet appears) and then the sender alters his nick the alert in applet remains regardless of my actions. Closing XChat doesnt helps, only "killall xchat" resets it.

Y.Z. (y-zinch) on 2010-05-31
summary: - PM alert remains in indicator if sender chenges his nickname
+ PM alert remains in indicator if sender changes his nickname
description: updated
rbleeker (rbleeker) wrote :

In my case closing Xchat does help to clear the status of xchat-indicator (Ubuntu Lucid 10.04 LTS)

Sandeep Kamath (sandeepkamath) wrote :

it also remains if the person quits before you have looked at the PM

Scott Moser (smoser) wrote :

Marking confirmed, as I and others have seen this. As recently as precise version:
xchat-indicator 0.3.10-0ubuntu2

Changed in xchat-indicator:
status: New → Confirmed
Ken VanDine (ken-vandine) wrote :

Unfortunately xchat-indicator can't really handle the case of nick changing very well, not via the xchat plugin interface. Clearing the indicators is done with string matching. IIRC the plugin interface wouldn't give me a reference to the channel, so all i could map to was the string representation.

Changed in xchat-indicator:
assignee: nobody → Ken VanDine (ken-vandine)
Jeremy Kerr (jk-ozlabs) wrote :

The linked branch (lp:~jk-ozlabs/+junk/xchat-indicator-nick-change) fixes the issue for me. The pointers xchat-indicator was using for hash table keys were non-constant, making lookups difficult. Once this was fixed, we can hook up the nick-change callback.

Changed in xchat-indicator:
assignee: Ken VanDine (ken-vandine) → nobody
milestone: none → 0.3.11
status: Confirmed → Fix Released
Changed in xchat-indicator (Ubuntu):
status: New → Fix Released
Changed in xchat-indicator (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Low
Ken VanDine (ken-vandine) wrote :

Steps to verify:

  1) have someone send you a private message
  2) you should see the messaging indicator turn blue, before responding to it have the sender change the IRC nick
  3) after they change their nick, click on the indicator
  4) you should be switched to the PM from that sender with the new nick

Regression potential is low, the old code was checking for the channel in the hash table and it would never match because it was a pointer.

Hello Y.Z., or anyone else affected,

Accepted xchat-indicator into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xchat-indicator/0.3.10-0ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xchat-indicator (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed

Performed test case pre installing proposed package to see issue and can confirm it.

Intsalled proposed package and ran test case again and issue is resolved.

tags: added: verification-done-precise
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xchat-indicator - 0.3.10-0ubuntu4.1

---------------
xchat-indicator (0.3.10-0ubuntu4.1) precise-proposed; urgency=low

  * debian/patches/lp_587902.patch
    - fixed pointers used in the hash table which fixes handling of
      nick changes (LP: #587902)
 -- Ken VanDine <email address hidden> Thu, 17 Jan 2013 16:04:39 -0500

Changed in xchat-indicator (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers