wxbanker Segmentation Fault on start with appmenu gtk

Bug #617385 reported by Lucas David-Roesler on 2010-08-13
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
AppMenu GTK+
Invalid
Low
Unassigned
wxBanker
Medium
Michael Rooney
gtk+2.0 (Ubuntu)
Undecided
Cody Russell

Bug Description

I currently have version 0.8.0~ppa1~10.04 installed on Ubuntu 10.04. Every time I try to start the program I get a segmentation fault.

Related branches

Paul Dirksen (pidikun) wrote :

Me too. Same version.

Michael Rooney (mrooney) wrote :

Thanks for the report! So nothing ever appears? There is bug https://bugs.launchpad.net/wxbanker/+bug/617361 which occurs when clicking on the summary tab, but I assume that is different?

Could either (or both!) of you attach/comment with the output of running 'env' from a terminal? It will hopefully help with debugging to see if it is an environmental issue. Thanks so much, hopefully I can figure out what is happening!

Changed in wxbanker:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Michael Rooney (mrooney)
Lucas David-Roesler (theaxer) wrote :

I have attahed the output of 'env' as the text file env-lucas.txt

Lucas David-Roesler (theaxer) wrote :

Whoops, I do so much stuff in TeX that I didn't name the file correctly, sorry. I promise it is just a text file :)

Michael Rooney (mrooney) wrote :

Interesting, thanks! Not a locale issue it appears. I see you are perhaps using the global menu option? If so, I wonder if that could be it. Could you let me know how you installed that so I can attempt to reproduce it, and if so, maybe try without that to confirm if that's it.

pidilein, would you happen to be using a global menu bar?

Ed Coles (edicoles) wrote :

I'm using the global menu bar

Lucas David-Roesler (theaxer) wrote :

Good catch. I am using testing version of the new ubuntu appmenu applet. When I removed the applet wxBanker started right up. I installed the applet from the ppa at : https://launchpad.net/~canonical-dx-team/+archive/une

Michael Rooney (mrooney) on 2010-08-13
summary: - Segmentation Fault on start
+ Segmentation Fault on start with global menu bar

Awesome, sounds like that is it! I will install the applet and see if I can't fix/workaround it and release 0.8.1 this weekend.

Michael Rooney (mrooney) on 2010-08-13
Changed in wxbanker:
milestone: none → 0.8.1

I've got Global Menu with Lucid and wxbanker is working fine!

Karel Kolman (kolmis) wrote :

I also failed to simulate the segfault with global menu from ppa http://ppa.launchpad.net/globalmenu-team/ppa/ubuntu

Michael Rooney (mrooney) wrote :

I suspect from the data it is a difference between Canonical's appmenu-gtk implementation vs the upstream globalmenu project. Karel and Tiago seem to imply upstream globalmenu works, while Lucas appears to be using Canonical's appmenu-gtk. To anyone else seeing or not seeing, can you confirm if it isn't working you are using appmenu-gtk but if it is working you are using globalmenu?

Michael Rooney (mrooney) wrote :

I'll open up a confirmed AppMenu GTK+ task based on the input here as I can confirm it as well, in hopes they can provide some feedback.

As a workaround I'll look for a way to disable the global menu for wxBanker. I thought I might be able to override UBUNTU_MENUPROXY and/or GTK_MENUPROXY which is defined in Maverick and might fix the problem, but in Lucid it doesn't seem to use env variables and I can't find a way to disable this so that it starts up.

summary: - Segmentation Fault on start with global menu bar
+ wxbanker Segmentation Fault on start with appmenu gtk
Changed in appmenu-gtk:
status: New → Confirmed
Michael Rooney (mrooney) wrote :

I confirmed that I can work around it in Maverick with a patch that disables menu redirection menu unsetting the environment variables before doing anything with wxPython, though I'm still not sure if I can fix it for Lucid users of the PPA.

I'll probably release this for 0.8.1 and then see if I can reproduce it with a trivial wxPython app (maybe the demo) and file a wx bug as well and hopefully figure out where the problem is.

Michael Rooney (mrooney) wrote :

Okay, I filed https://bugs.launchpad.net/wxbanker/+bug/618440 for the work-around env issue in Maverick as that is "fixed".

I'd still love to hear something from the Canonical DX team about if this is expected/known and if there is anything I can do!

Changed in wxbanker:
importance: High → Medium
milestone: 0.8.1 → future
Alexander Skiba (ghostlyrics) wrote :

So basically there's no way to use wxbanker together with appmenu in Lucid?

Lucas David-Roesler (theaxer) wrote :

@Alexander -- well just not with the appmenu indicator applet. You can still use it with the global-menu-applet or if you don't mess with the menu bar.

Alexander Skiba (ghostlyrics) wrote :

The problem here is that since a few days ago my global-menu-applet has an enormous memory leak though I don't remember making any changes. (i.e. goes up to 700mb and is painfully slow)

David Barth (dbarth) wrote :

I can confirm the crash with wxbanker. Setting UBUNTU_MENUPROXY= lets it start without crashing.

Changed in appmenu-gtk:
assignee: nobody → Cody Russell (bratsche)
importance: Undecided → Medium
milestone: none → ubuntu-10.10-beta
Cody Russell (bratsche) wrote :

I'm getting a crash whether I run with appmenu-gtk or not.

Changed in appmenu-gtk:
importance: Medium → Low
status: Confirmed → Incomplete
Alexander Skiba (ghostlyrics) wrote :

That is because of a package in the canonical-dx-team/une PPA. I don't know which package though. As soon as I ppa-purged the thing everything was working.

Cody Russell (bratsche) on 2010-08-24
Changed in appmenu-gtk:
status: Incomplete → Invalid
Changed in gtk+2.0 (Ubuntu):
assignee: nobody → Cody Russell (bratsche)
Changed in wxbanker:
status: Confirmed → Invalid
Cody Russell (bratsche) on 2010-08-24
Changed in gtk+2.0 (Ubuntu):
status: New → Fix Committed
Michael Rooney (mrooney) wrote :

Thanks so much for looking into this Cody/David, it is really appreciated!

Sebastien Bacher (seb128) wrote :

the fix has been uploaded

Changed in gtk+2.0 (Ubuntu):
status: Fix Committed → Fix Released
Cody Russell (bratsche) on 2010-08-25
Changed in appmenu-gtk:
assignee: Cody Russell (bratsche) → nobody
Alexander Skiba (ghostlyrics) wrote :

Does this require a fix in appmenu-gtk too? Since it still segfaults...

Michael Rooney (mrooney) wrote :

Alexander, I'll see if I can confirm that today in Maverick, that wouldn't be so good.

David Barth (dbarth) on 2010-08-30
Changed in appmenu-gtk:
milestone: ubuntu-10.10-beta → none
Michael Rooney (mrooney) wrote :

Alexander, are you still seeing problems? I upgraded my Maverick install and see no more segfault and the menu is correctly displayed in gnome-panel (wxbanker 0.8). Using 0.8.1 from the PPA, the menu is displayed as normal because of the env workaround. I'll undo this work-around in 0.8.2 since this bug is fixed, and get that uploaded.

Alexander Skiba (ghostlyrics) wrote :

nope, in Maverick it's working fine. The "still-segfault" was about Lucid, since the UNE PPA is a bit behind. Keep up the good work and thanks for your time.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments