ntfs5 don't find wubildr

Bug #961707 reported by Fabio Marconi on 2012-03-21
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

Shown at boot time [copied from attached video]:
Try (hd0,0): NTFS5: No wubildr
Try (hd0,1): NTFS5: 0
Try (hd0,2): invalid or null
Try (hd0,3): invalid or null
Error: Cannot find GRLDR in all devices. Press Ctrl+Alt+Del to restart.

- Start an Ubuntu live session
- In teminal type sudo fdisk -l
- Search for the filesystems HPFS/NTFS/exFat (normally are two and one is tagged with *)
- Generally they are named /dev/sda1 (with the * sign) and /dev/sda2
- Ever in terminal type
- sudo mount /dev/sda1 /mnt
- mkdir /mnt/a
- sudo mount /dev/sda2 /mnt/a
- mv /mnt/a/wubildr /mnt
- mv /mnt/a/wubildr.mbr /mnt
- sudo umount /mnt/a
- sudo umount /mnt/
- sudo reboot
- Select Ubuntu from the bootloader, ignore prefix error, wait the boot screen

Booted Wubi under win 8 cust prew and selected help me.....
everythings ok till the reboot, right selection screen but it cannot find wubildr
See attached screencast

Fabio Marconi (fabiomarconi) wrote :
tags: added: precise screencast window8
summary: - Win8 don't find
+ ntfs5 don't find wubildr
tags: added: windows8
removed: window8
description: updated

No work has been done on making Wubi work under the new Windows 8 boot
loader arrangements, and it is unlikely that this will happen for 12.04.

bcbc (bcbc) wrote :

I don't think it's a win8 problem. At least it worked flawlessly when I tried it (Win 8 in virtual box). The output of bcdedit matched what I see on Win 7, and the boot mechanism worked the same. Besides, wubildr.mbr seems to be running fine, just can't find the wubildr.

The usual causes for your problem are:
1. no C:\wubildr
2. old bios and wubildr is > 137GB from start of drive
3. apparently severe fragmentation (?)

There are a few posts about win8 and wubi on ubuntuforums.org but they don't seem different from the usual wubi issues.

Fabio Marconi (fabiomarconi) wrote :

I've reproduced again, with today's build and in real hardware, the problem, so i'll mark as confirmed.
The strange things is that it don't find wubildr in the hd0,1 (dev/sda2) where they are, but is also true that this is the 'work' directory of windows and not flagged as HPFS/NTFS bootable.
Then if I copy the two files, wubildr and wubildr.mbr to the windows bootable directory (/dev/sda1 in my case) it works as expected.

description: updated
tags: added: workaround
Changed in wubi:
status: New → Confirmed
Fabio Marconi (fabiomarconi) wrote :

In tyhis way we can start a live session of Ubuntu, but not to choose to install it because it don't see windows partitions

description: updated
tags: removed: workaround
description: updated
tags: added: workaround
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing
bcbc (bcbc) wrote :

When you boot a live CD, does it see your partitions correctly? Does the output of 'fdisk -l' or 'parted -l' indicate any errors?

Fabio Marconi (fabiomarconi) wrote :

Hello bcbc
Please look at bug 962972

description: updated
Changed in wubi:
importance: Undecided → Medium
bcbc (bcbc) on 2012-05-19
description: updated
Fabio Marconi (fabiomarconi) wrote :

This what actually happens, the loader works only with windows, ubuntu isn't loaded whit the above error.
see attached screenshot

tags: added: quantal
Fabio Marconi (fabiomarconi) wrote :

Interesting to note that the normal alongside installation of precise 12.04.1 (and w8) works as expected

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers