Offline Wubi install no longer works in Oneiric Wubi.exe rev225

Bug #842397 reported by bcbc on 2011-09-06
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Wubi
High
Evan

Bug Description

I normally run Wubi.exe without being connected to the internet (especially in development so it doesn't always download a new image as they change so frequently). In this case I want to test Oneiric beta1 so I have the ISO in the same directory as wubi.exe. This is how I nearly always install as is mentioned in the Wubi Guide as a valid install method where there is no internet connection.

However, wubi.exe rev225 doesn't even check for a local ISO anymore:
09-06 00:00 DEBUG downloader: downloading http://cdimage.ubuntu.com/wubi/current/amd64.tar.xz > C:\ubuntu\disks\amd64.tar.xz
09-06 00:00 ERROR TaskList: [Errno 4] IOError: <urlopen error (7, 'getaddrinfo failed')>
Traceback (most recent call last):
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\common\downloader.py", line 78, in download
  File "\lib\urlgrabber\grabber.py", line 927, in urlgrab
  File "\lib\urlgrabber\grabber.py", line 845, in _retry
  File "\lib\urlgrabber\grabber.py", line 913, in retryfunc
  File "\lib\urlgrabber\grabber.py", line 1001, in __init__
  File "\lib\urlgrabber\grabber.py", line 1072, in _do_open
  File "\lib\urlgrabber\grabber.py", line 1188, in _make_request
URLGrabError: [Errno 4] IOError: <urlopen error (7, 'getaddrinfo failed')>
09-06 00:00 DEBUG TaskList: # Cancelling tasklist
09-06 00:00 DEBUG TaskList: ## Finished download_diskimage
09-06 00:00 ERROR root: [Errno 4] IOError: <urlopen error (7, 'getaddrinfo failed')>
Traceback (most recent call last):
  File "\lib\wubi\application.py", line 57, in run
  File "\lib\wubi\application.py", line 131, in select_task
  File "\lib\wubi\application.py", line 157, in run_installer
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\common\downloader.py", line 78, in download
  File "\lib\urlgrabber\grabber.py", line 927, in urlgrab
  File "\lib\urlgrabber\grabber.py", line 845, in _retry
  File "\lib\urlgrabber\grabber.py", line 913, in retryfunc
  File "\lib\urlgrabber\grabber.py", line 1001, in __init__
  File "\lib\urlgrabber\grabber.py", line 1072, in _do_open
  File "\lib\urlgrabber\grabber.py", line 1188, in _make_request
URLGrabError: [Errno 4] IOError: <urlopen error (7, 'getaddrinfo failed')>
09-06 00:00 DEBUG TaskList: # Finished tasklist

Compare this to the the 10.10 version of Wubi Rev 197 that will find the oneric beta ISO and check the .disk info before rejecting:
09-06 00:14 DEBUG CommonBackend: Searching for local ISO
09-06 00:14 DEBUG Distro: checking Ubuntu ISO C:\Users\bcbc\Downloads\ubuntu-11.10-beta1-desktop-amd64.iso
09-06 00:14 DEBUG WindowsBackend: extracting .disk\info from C:\Users\bcbc\Downloads\ubuntu-11.10-beta1-desktop-amd64.iso
09-06 00:14 DEBUG Distro: parsing info from str=Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
09-06 00:14 DEBUG Distro: parsed info={'name': 'Ubuntu', 'subversion': 'Beta', 'version': '11.10', 'build': '20110901', 'codename': 'Oneiric Ocelot', 'arch': 'amd64'}
09-06 00:14 DEBUG Distro: wrong version: 11.10 != 10.10
09-06 00:14 DEBUG CommonBackend: Could not find any ISO or CD, downloading one now

Related branches

bcbc (bcbc) wrote :
summary: - Offline Wubi install no longer works in Onerici Wubi.exe rev225
+ Offline Wubi install no longer works in Oneiric Wubi.exe rev225
Colin Watson (cjwatson) wrote :

Evan, could you have a look at this? We do still need a functional offline story.

Changed in wubi:
assignee: nobody → Evan Dandrea (ev)
importance: Undecided → High
status: New → Confirmed
bcbc (bcbc) wrote :
Download full text (4.2 KiB)

I decided to rerun after moving the ISO to C:\ as I've noticed that wubi will find ISO's in the root of drives.

However, Wubi died without presenting any meaningful message:

09-06 15:24 INFO root: === wubi 11.10 rev225 ===
09-06 15:24 DEBUG root: Logfile is c:\users\bcbc\appdata\local\temp\wubi-11.10-rev225.log
09-06 15:24 DEBUG root: sys.argv = ['main.pyo', '--exefile="C:\\Users\\bcbc\\Downloads\\wubi-r225.exe"']
09-06 15:24 DEBUG CommonBackend: data_dir=C:\Users\bcbc\AppData\Local\Temp\pyl302C.tmp\data
09-06 15:24 DEBUG WindowsBackend: 7z=C:\Users\bcbc\AppData\Local\Temp\pyl302C.tmp\bin\7z.exe
09-06 15:24 DEBUG WindowsBackend: startup_folder=C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
09-06 15:24 DEBUG CommonBackend: Fetching basic info...
09-06 15:24 DEBUG CommonBackend: original_exe=C:\Users\bcbc\Downloads\wubi-r225.exe
09-06 15:24 DEBUG CommonBackend: platform=win32
09-06 15:24 DEBUG CommonBackend: osname=nt
09-06 15:24 DEBUG CommonBackend: language=en_CA
09-06 15:24 DEBUG CommonBackend: encoding=cp1252
09-06 15:24 DEBUG WindowsBackend: arch=amd64
09-06 15:24 DEBUG CommonBackend: Parsing isolist=C:\Users\bcbc\AppData\Local\Temp\pyl302C.tmp\data\isolist.ini
09-06 15:24 DEBUG CommonBackend: Adding distro Xubuntu-i386
09-06 15:24 DEBUG CommonBackend: Adding distro Xubuntu-amd64
09-06 15:24 DEBUG CommonBackend: Adding distro Kubuntu-amd64
09-06 15:24 DEBUG CommonBackend: Adding distro Mythbuntu-i386
09-06 15:24 DEBUG CommonBackend: Adding distro Ubuntu-amd64
09-06 15:24 DEBUG CommonBackend: Adding distro Ubuntu-i386
09-06 15:24 DEBUG CommonBackend: Adding distro Mythbuntu-amd64
09-06 15:24 DEBUG CommonBackend: Adding distro Kubuntu-i386
09-06 15:24 DEBUG WindowsBackend: Fetching host info...
09-06 15:24 DEBUG WindowsBackend: registry_key=Software\Microsoft\Windows\CurrentVersion\Uninstall\Wubi
09-06 15:24 DEBUG WindowsBackend: windows version=vista
09-06 15:24 DEBUG WindowsBackend: windows_version2=Windows 7 Home Premium
09-06 15:24 DEBUG WindowsBackend: windows_sp=None
09-06 15:24 DEBUG WindowsBackend: windows_build=7601
09-06 15:24 DEBUG WindowsBackend: gmt=-8
09-06 15:24 DEBUG WindowsBackend: country=CA
09-06 15:24 DEBUG WindowsBackend: timezone=America/Vancouver
09-06 15:24 DEBUG WindowsBackend: windows_username=bcbc
09-06 15:24 DEBUG WindowsBackend: user_full_name=bcbc
09-06 15:24 DEBUG WindowsBackend: user_directory=C:\Users\bcbc
09-06 15:24 DEBUG WindowsBackend: windows_language_code=1033
09-06 15:24 DEBUG WindowsBackend: windows_language=English
09-06 15:24 DEBUG WindowsBackend: processor_name=Intel(R) Core(TM) i3 CPU M 380 @ 2.53GHz
09-06 15:24 DEBUG WindowsBackend: bootloader=vista
09-06 15:24 DEBUG WindowsBackend: system_drive=Drive(C: hd 238977.449219 mb free ntfs)
09-06 15:24 DEBUG WindowsBackend: drive=Drive(C: hd 238977.449219 mb free ntfs)
09-06 15:24 DEBUG WindowsBackend: drive=Drive(D: cd 0.0 mb free )
09-06 15:24 DEBUG WindowsBackend: drive=Drive(F: hd 12360.4726563 mb free ntfs)
09-06 15:24 DEBUG WindowsBackend: drive=Drive(Q: hd 0.0 mb free )
09-06 15:24 DEBUG WindowsBackend: uninstaller_path=C:\ubuntu\uninstall-wubi.exe
09-06 15:24 D...

Read more...

bcbc (bcbc) wrote :

I meant to say: "Wubi died without presenting any message at all" in the previous comment.

(I said "without presenting any meaningful message" but that is misleading).

Shahed Faisal (mushaf) wrote :

I second this bug. I had this same problem while installing Ubuntu 11.10 beta offline via wubi.

Shahed Faisal (mushaf) wrote :
Musarraf (musarraf172) wrote :

I am also facing the same problem with ubuntu 11.10 latest august build ...

bcbc (bcbc) wrote :

The offline install is working again - using wubi-r234.exe with the current daily-live CD. So I guess you can mark this bug as fixed.

bcbc (bcbc) wrote :

Sorry I spoke too soon. When I tested the offline install I had the ISO on my E:\ drive so wubi.exe believes it is a CD drive(?) When I run wubi.exe with the ISO in the same folder (not on the root of a partition) - it ignores it and downloads the i386.tar.xz. So this bug still exists.

PS I noticed that the preinstalled i386.tar.xz has an ext3 file system, whereas with the CD install it creates the ext4 standard (same as it has since 9.10). Is there any particular reason for the switch to ext3 on the preinstalled image?

Evan (ev) wrote :

The next CD spin will have the fixed Wubi. For the impatient:
http://people.canonical.com/~evand/wubi/oneiric/wubi-r236.exe

Changed in wubi:
status: Confirmed → Fix Released
Evan (ev) wrote :

I've filed bug https://bugs.launchpad.net/wubi/+bug/859552 for the ext3/ext4 issue.

bcbc (bcbc) wrote :

I ran the offline install with r236 and the current daily-live up to date, iso in same directory. The windows phase worked successfully.

However the 2nd phase failed. I captured the logs. Looks like it might just be something in the current daily-live that failed:
Sep 26 21:05:30 ubuntu ubiquity[4472]: log-output -t ubiquity laptop-detect
Sep 26 21:05:30 ubuntu ubiquity[4472]: Exception in GTK frontend (invoking crash handler):
Sep 26 21:05:30 ubuntu ubiquity[4472]: Traceback (most recent call last):
Sep 26 21:05:30 ubuntu ubiquity[4472]: File "/usr/lib/ubiquity/ubiquity/gtkwidgets.py", line 215, in do_set_property
Sep 26 21:05:30 ubuntu ubiquity[4472]: self.extra.set_markup('<small>%s</small>' %
Sep 26 21:05:30 ubuntu ubiquity[4472]: AttributeError: 'PartitionBox' object has no attribute 'extra'

Ubiquity 2.7.35

(ubiquity:4472): Pango-WARNING **: error opening config file '/root/.pangorc': Permission denied

Exception in GTK frontend (invoking crash handler):
Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/gtkwidgets.py", line 215, in do_set_property
    self.extra.set_markup('<small>%s</small>' %
AttributeError: 'PartitionBox' object has no attribute 'extra'

Note also that the failure-command.sh doesn't seem to work. I captured the logs manually.
Sep 26 21:05:30 ubuntu ubiquity: sh: /custom-installation/hooks/failure-command.sh: not found
Sep 26 21:05:30 ubuntu ubiquity[4472]: log-output -t ubiquity sh -c [ -x /custom-installation/hooks/failure-command.sh ] && /custom-installation/hooks/failure-command.sh

bcbc (bcbc) wrote :

This worked fine on today's build using r236.

The problem still persists for me. I have downloaded latest Wubi and ubuntu-11.10-wubi-amd64.tar.xz, placed them in the same folder, but the installer still tries to download it from the internet. I have placed them in root folder of all three partitions one at a time and tried installing. Doesnt work. Any way out?

Tried to install using WUBI, no luck. Created a USB Bootable drive using universal usb installer 1.8.7.0.e. No luck. Well f*ck Ubuntu. Will stick with Windows.

You need to download the desktop CD ISO, not the wubi tar.xz image when
installing in offline mode.

You cannot install Wubi from a USB due to a silly size check that is
supposed to exclude DVD ISOs. If the partition is > ~850 MB it will fail
because wubi copies the entire USB partition as a single ISO before running
the size check (could be a 4GB or 16GB file).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers