Wubi, Windows Ubuntu Installer

Oneiric Alpha3 - Wubi grub menu not hidden

Reported by bcbc on 2011-08-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Wubi
Undecided
Unassigned
grub2 (Ubuntu)
Medium
Colin Watson

Bug Description

New feature of Wubi in Oneiric is supposed to suppress display of grub menu. In my test it did not. (This computer has a dell recovery partition, as well as another Ubuntu install - so this may be the cause). I've attached the debug output of 30_os-prober

bcbc (bcbc) wrote :
tags: added: oneiric
bcbc (bcbc) wrote :

I ran a test on a different machine with Win7 only. This still didn't hide the Wubi grub menu, just the Windows entries (and memtest). So all that showed was the two entries for the linux kernel (normal and recovery). This test was on the 64bit alpha3 ISO - can't confirm that it was alpha3 right now - I can run it again to confirm if nec.

PS the second phase booted straight into Ubuntu - no Windows boot manager prompt, so that new feature worked well. The other test was on XP so couldn't check this.

Colin Watson (cjwatson) wrote :

I didn't promise that the menu would always be hidden (though somebody may have interpreted it that way). I merely arranged for the Windows entries to be hidden.

Colin Watson (cjwatson) wrote :

Though admittedly the test you ran on the second machine ought to have hidden the menu. Are you happy for me to address this bug by just fixing that part?

Colin Watson (cjwatson) on 2011-08-15
Changed in grub2 (Ubuntu):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Colin Watson (cjwatson)
bcbc (bcbc) wrote :

I don't have a personal preference on whether the grub menu should be hidden or not (in a way it's good to familiarize windows users with what it will look like when they switch to a normal dual boot; on the other hand, it can irritate users having two boot menus and that drives them to mess about and break things).

That was just my interpretation of the one-line entry in the blueprint - so that was why I filed the bug. So... I guess it should do whatever you intended it to do :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.99-12ubuntu1

---------------
grub2 (1.99-12ubuntu1) oneiric; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Adjust for default Ubuntu boot options ("quiet splash").
    - Default to hiding the menu; holding down Shift at boot will show it.
    - Set a monochromatic theme and an appropriate background for Ubuntu.
    - Apply Ubuntu GRUB Legacy changes to legacy update-grub script.
    - Fix backslash-escaping in merge_debconf_into_conf.
    - Remove "GNU/Linux" from default distributor string.
    - Add crashkernel option.
    - Bypass menu unless other OSes are installed or Shift is pressed.
    - Allow Shift to interrupt 'sleep --interruptible'.
    - Reduce visual clutter in normal mode.
    - Remove verbose messages printed before reading configuration.
    - Suppress kernel/initrd progress messages, except in recovery mode.
    - Show the boot menu if the previous boot failed.
    - Don't generate device.map during grub-install or grub-mkconfig.
    - Adjust upgrade version checks for Ubuntu.
    - Suppress "GRUB loading" message unless Shift is held down.
    - Adjust versions of grub-doc and grub-legacy-doc conflicts.
    - Fix LVM/RAID probing in the absence of /boot/grub/device.map.
    - Look for .mo files in /usr/share/locale-langpack first.
    - Build-depend on qemu-kvm rather than qemu-system for grub-pc tests.
    - Check hardware support before using gfxpayload=keep.
    - Put second and subsequent Linux menu entries in a submenu.
    - Preferred resolution detection for VBE.
    - Set vt.handoff=7 for smooth handoff to kernel graphical mode.
    - Update default/grub.md5sum to include maverick's default md5sum.
    - Add nomodeset to Linux kernel arguments in recovery mode.
    - Skip Windows os-prober entries on Wubi systems.
  * Suppress the menu by default on Wubi systems with no other-OS entries
    apart from Windows (LP: #826378).
  * Always store hostdisk drive names in canonical form, fixing 'grub-probe
    --target=drive' output when device.map is absent (LP: #820500).

grub2 (1.99-12) unstable; urgency=low

  [ Robert Millan ]
  * Fix grub-probe detection for LSI MegaRAID SAS devices on kFreeBSD.
    - kfreebsd_mfi_devices.patch

  [ Colin Watson ]
  * Backport from upstream:
    - Canonicalise the path argument to grub-probe (closes: #637768).
    - Skip */README* as well as README* (LP: #537123).
 -- Colin Watson <email address hidden> Mon, 05 Sep 2011 16:12:50 +0100

Changed in grub2 (Ubuntu):
status: Fix Committed → Fix Released
Evan Dandrea (ev) on 2011-09-22
Changed in wubi:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers