New wubi 10.04.1 boot failure after grub update

Bug #682337 reported by profesorluis on 2010-11-28
76
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Wubi
Undecided
Unassigned
lupin
New
Undecided
Unassigned
lupin (Ubuntu)
Undecided
Unassigned

Bug Description

Wubi 10.04.1 install fails to boot after applying grub update.
This problem occurs on any Wubi 10.04 Ubuntu install where the root.disk is on the same drive as Windows e.g. /host/wubildr exists. Even a fresh 10.04.1 install will fail to boot after applying this update.

The problem was caused by the fix for bug 581760.

UPDATE: this problem can effect Wubi installs on a different partition/drive than windows as well. see note.
============================

Original comment:
Yesterday, I installed Ubuntu updates in wubi, I did not notice that the grub was updated in this update (I did wrong), from here, I can't boot wubi.

Now, what happens is:
Try (hd0,0): NTFS5: No wubildr
Try (hd0,1): NTFS5: No wubildr
Try (hd0,2): NTFS5: (here, reboot pc)

bcbc (bcbc) wrote :

What release? What were the symptoms before copying over that wubildr which is for 9.10 release?

Changed in wubi:
status: New → Incomplete

The release is 10.04

After install grub updates in wubi...don't work

and what happens is:

Try (hd0,0): NTFS5: No wubildr
Try (hd0,1): NTFS5: No wubildr
Try (hd0,2): NTFS5:

here, reboot pc
I can't boot wubi

bcbc (bcbc) wrote :

OK, if you're still not fixed up, here is the fix: http://ubuntuforums.org/showthread.php?t=1639198
See Problem #2, Solution #1. Then after you get Ubuntu booting, apply the Permanent Fix.

You may have to update your wubildr too since you copied the 9.10 version. If you have any issues with that, I recommend posting on the above thread in ubuntuforums, not here.

bcbc (bcbc) on 2010-12-10
description: updated
Changed in wubi:
status: Incomplete → Confirmed
bcbc (bcbc) wrote :

This problem is similar in nature and most likely identical to bug 653134. The fix was documented in that bug.

Summary:
When updating package grub-pc, it attempts to update the wubildr on /host. It calls grub-install to do this. For Wubi installs grub-install is modified in package lupin-support, and it calls grub-install.real (the actual grub-install script for normal installs). Grub-install also copies all the grub .img, .lst, .o etc. files into the /boot/grub directory. These do not normally exist for Wubi installs, and result in a grub.cfg file being created that is incompatible with wubildr (for unknown reasons).

The fix is to remove all these files from /boot/grub leaving just grub.cfg and grubenv. However, you need to manually modify the grub.cfg to get it to boot first.

The potential fix:
Modify lupin-support's grub-install to clean up the /boot/grub directory.

bcbc (bcbc) on 2010-12-13
affects: wubi → lupin
affects: lupin → wubi
bcbc (bcbc) on 2010-12-20
summary: - New wubi boot failure after grub update
+ New wubi 10.04.1 boot failure after grub update
bcbc (bcbc) wrote :

Normally this problem is only associated with wubi installs on the same partition as windows. However, on wubi installs to a different partition/drive, they are susceptible to overwriting their MBR (bug 610898). If this happens, and they repair it, then they are susceptible to this same problem as this bug, after a subsequent "update-grub" e.g. from a kernel update.
The after the fact fix is the same as described above - boot ubuntu through manual grub.cfg workaround and then clean up /boot/grub and regenerate update-grub.

description: updated
bcbc (bcbc) wrote :

I've been doing some paperwork today - linking Questions from answers.launchpad.net to the relevant bug. For those people that are receiving emails today many of whom solved the problems a month ago - please ignore - bugs are treated as higher priority when more people are affected so this is an attempt to get the problem fixed.

bcbc (bcbc) wrote :

Just a note - some users report having installed 10.10 when in fact they have installed 10.04.1. This is because when you go to download Ubuntu 10.10 from http://www.ubuntu.com/desktop/get-ubuntu/download and then click the "Windows installer" tab, it takes you to http://www.ubuntu.com/desktop/get-ubuntu/windows-installer which downloads the 10.04.1 version of wubi.exe (without any mention of the release).

This results in some new users mistakenly thinking they are on 10.10 (which at the time of writing does not have any grub-pc updates). Wubi does in fact report the version when you install at the top centre.

It would be helpful to have this web page updated to notify the following:
1. 10.04.1 will be installed
2. 10.04.1 Wubi does not support Netbook-edition or Xubuntu
3. Grub updates will result in failure to boot Ubuntu and/or your computer failing to boot.

Willye (wall-545) wrote :

i had ubuntu 10.04
the lastest software installed was compiz-extra, suddenly when i powered on the system appeared the next message: error: not such device: /ubuntu/disks/root.disk
grub>

i was trying to recover the system, but i discovered that rook.disk and swap.disk did not exist in folder "c:\ubuntu", the thing is why those files dissapeared misteriously, if the last system executed was ubuntu .............

bcbc (bcbc) wrote :

Fyi in recent days the version of Wubi.exe on http://www.ubuntu.com/desktop/get-ubuntu/windows-installer has quietly been changed to 10.10.
I reported on the 14th Jan that it was 10.04.1 so I wanted to correct that for anyone reading this now.

Also, I just want to add that the Wubi Megathread on ubuntuforums.org which shows how to fix this bug (and the other major grub Wubi issue - bug 610898) has had over 23000 hits in 2 months. Just to give an idea of the scale of this bug - despite the low "This bug affects # people" counter.

If any developer is able to fix this it would be appreciated. From what I can determine - the fix would be to change script grub-install in package lupin-support to clean up the /boot/grub directory after calling grub-install.real (which is the real grub-install script in Grub2 package). The fix is a couple of lines, and I've informally tested it on 10.04.1 and it worked - so it shouldn't take a developer a long time to package. I would be happy to assist in testing.

To post a comment you must log in.