Wubi, Windows Ubuntu Installer

Installer drops into grub shell after rebooting from Windows

Reported by Dave Morley on 2010-07-01
78
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Wubi
Critical
Colin Watson

Bug Description

After rebooting from the Windows portion of the Wubi install, I select Ubuntu from the boot menu and then it immediately drops in grub shell.

Steps to reproduce:
1. start Windows
2. insert CD and select install inside windows option
3. wait while the system installs the windows side of the product
4. click on reboot now
5. from the boot menu select Ubuntu
6. drops into grub shell

Related branches

tags: added: iso-testing
Mark (umberstark) wrote :

Just confirming this problem. Happens to me with the latest daily build (10th July).

Mark (umberstark) wrote :

Still happening with the 32bit (at least) daily build for 22nd July.

Any more news on this?

Martin Pitt (pitti) wrote :

Does it say any error message? Perhaps "boot configuration store could not be opened"? There is a similar report in bug 613288 with a log file attached. Can you please attach wubi-10.10-rev*.log?

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :

Martin that's the wubi log from windows.

Evan Dandrea (ev) wrote :

Can you go back into windows, edit the grub config under C:\Ubuntu to have 'set debug=all' at the top, then reboot?

This should give you verbose grub logs on the screen. Have a camera ready ;).

Thanks!

Changed in wubi:
status: New → Incomplete
Dave Morley (davmor2) wrote :

Evan

Nope straight into Grub shell again as before.

No text anywhere.

papukaija (papukaija) on 2010-08-05
tags: added: maverick
nomadz (escmail) wrote :

i have had the same problem previously, also taken down the path of trying all kinds of different fixes, none worked expect for following the instructions shown on the link below, the instructions are dated, i have had 100% success with all versions of Ubuntu up to Maverick,
http://sourceforge.net/apps/mediawiki/bootinfoscript/index.php?title=Boot_Problems:Wubi_9.10

linex83 (linex83) wrote :

Confirming the problem when installing the ISO to a USB stick.

cpatrick08 (cpatrick08) wrote :

i does not work with kubuntu 10.10 alpha 3 64bit

description: updated
summary: - installer drops into grub shell after rebooting from windows.
+ Installer drops into grub shell after rebooting from Windows
linex83 (linex83) wrote :

I think this bug is quite critical since it prevents users from installing and testers from testing.

bcbc (bcbc) wrote :

I got wubi alpha3 to install by entering
    "configfile (hd0,msdos2)/ubuntu/winboot/wubildr.cfg"
at the grub prompt. It then completes the install. The installer is pretty ugly with - all text, and repeated lines with percentages up and down the chart from 0% to over 1200%.

After installation I had to manually load wubildr.cfg to get in as well. I tried "sudo update-grub" and "sudo grub-install /dev/sda2" to see if that would fix the issue but it didn't. Still need the configfile line to get in.

PS running the i386 ubuntu desktop version.

bcbc (bcbc) wrote :

Just tried installing with the lastest daily maverick-desktop-i386 and it still drops me at the grub prompt. No error text. Same workaround (configfile) gets it to install and boot after installing.

So everything is working except for the link between wubildr and wubildr.cfg?

Is this bug still incomplete? What more do you need?

i have the same problem - however instead of msdos2, I had to use msdos3 to point to the configfile.

Brandon (thesoul-reaper) wrote :

I also have that same problem, come on devs I wanted to give unity a whirl but I have no cds or usbs that I can use. Its driving me insane! Some reason pointing to the configfile didn't work for me.

bcbc (bcbc) wrote :

Evan Dandrea wrote: "Can you go back into windows, edit the grub config under C:\Ubuntu to have 'set debug=all' at the top, then reboot?"

I assume when you say "to the config file under c:\Ubuntu" you actually mean the wubildr.cfg file under c:\ubuntu\winboot? This is the same file that my workaround is manually loading? Which indicates that the debug=all is unlikely to provide any useful information, rather the error is establishing a link to it from the wubildr/wubildr.mbr?

I've just rerun the install from the daily live image and edited the wubildr.cfg as you suggested. No difference. Therefore I believe this bug is complete. If you have any other suggestions or require additional information, please advise.

PS Once I run my workaround, I do indeed get a LOT of debug info that runs by too fast for even a video camera (unless you had one of those high speed ones). So I don't believe it's of any use. And it's certainly too late in the game to provide useful information on this particular problem.

Changed in wubi:
status: Incomplete → Confirmed
wobblybob (martincooper9) wrote :

Maverick beta iso testing ubuntu 64 Case ID: wdi-004 followed by wdi-002 latest stable Wubi installs ok then on the reboot and selecting ubuntu from the menu the process then goes to the Grub menu with the >GRUB option.

Colin Watson (cjwatson) wrote :

This is happening because wubildr.cfg is being parsed using grub's rescue parser, which is too stupid to understand conditionals, rather than its normal parser. I've sent a suggested patch to Evan which may deal with this.

Colin Watson (cjwatson) wrote :

revno: 193
fixes bug(s): https://launchpad.net/bugs/600578
committer: Colin Watson <email address hidden>
branch nick: trunk
timestamp: Wed 2010-09-01 12:59:32 +0100
message:
  wubildr.cfg needs to be run using GRUB's normal parser rather than its
  rescue parser. Rather than embedding it directly as a configuration
  file, embed it as a memdisk and add wubildr-bootstrap.cfg which invokes
  it using normal mode (LP: #600578).

Changed in wubi:
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Critical
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

This is on the Ubuntu and Xubuntu desktop images that were just re-posted for beta, and will trickle into other images if and when we rebuild them.

Changed in wubi:
status: Fix Committed → Fix Released
perezcuesta (perezcuesta) wrote :

I upgrade from Ubuntu 10.04 to Ubuntu 10.10. After installation, I reboot the machine but it is not possible run Ubuntu. The notice is: "It is not the file". It is a very hard problem for me. What is the solution?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers