Wubi can't download metalink because URL is incorrect

Bug #496957 reported by John M Anderson on 2009-12-15
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Wubi
Critical
Unassigned
Nominated for Trunk by TJ

Bug Description

For ubuntu-netbook-remix and kubuntu-netbook (didn't try other distributions), Wubi attempts to download the metalink from http://releases.ubuntu.com but the metalink file is missing. It then tries to download the metalink from cdimage.ubuntu.com, but "karmic" is now "lucid" in that directory structure and it fails.

The errors are the same with Wubi 160 and 168.

Logfile is attached.

Related branches

John M Anderson (bassooner) wrote :
alin1990 (alin1990) wrote :

How to solve the problems?

TJ (tj) on 2012-08-15
Changed in wubi:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → TJ (tj)
TJ (tj) wrote :

The problem affects Precise and will affect Quantal.

It is caused because the URLs listed in 'data/isolist.ini' are result in HTTP 404 Not Found errors.

Changed in wubi:
assignee: TJ (tj) → nobody
status: Confirmed → Triaged
Evan (ev) wrote :

Neither ubuntu-netbook-remix or kubuntu-netbook exist anymore. They're most certainly not referred to by the precise or quantal isolist.ini files.

TJ, I suspect your bug is separate. Please file a new one.

Changed in wubi:
status: Triaged → Fix Released

On 15/08/12 18:16, Evan Dandrea wrote:
> Neither ubuntu-netbook-remix or kubuntu-netbook exist anymore. They're
> most certainly not referred to by the precise or quantal isolist.ini
> files.
>
> TJ, I suspect your bug is separate. Please file a new one.

I dealt with the bug after a report on IRC #ubuntu from a user who has downloaded
the wubu installer for Precise and hit the same problem with one of the URLs.

Aug 15 13:22:10 <Netham45> 08-15 06:21 ERROR CommonBackend: Cannot download metalink file http://releases.ubuntu.com/kubuntu/12.04/kubuntu-12.04-desktop-amd64.metalink err=[Errno 14] HTTP Error
404: Not Found
Aug 15 13:22:18 <Netham45> ^ Getting that for Kubuntu in WUBI on Win 8
Aug 15 13:23:26 <Netham45> Standard ubuntu seems to work, though

Dimitri John Ledkov (xnox) wrote :

Correct link for Kubuntu is now:
http://cdimages.ubuntu.com/kubuntu/releases/12.04/release/kubuntu-12.04-desktop-amd64.metalink

Which is very different from ubuntu and the current ubuntu. Did the images got moved?

Dimitri John Ledkov (xnox) wrote :

releases:
 - all ubuntu
 - Kubuntu <= 11.10
 - Edubuntu 8.04

cdimages:
 - ubuntu alternatives / less used images
 - all current&old derivatives & flavours, including 12.04 Kubuntu/Edubuntu etc

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers