No wubildr error on 9.10 first restart when installing on windows 7

Bug #478717 reported by o0-leo on 2009-11-08
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Wubi
Undecided
Unassigned

Bug Description

I'm using windows 7 RC, and when I try to clean-install ubuntu 9.10 with wubi, after the first restart, i get an error massege that says wubildr cann't be found on each partition it tries to find it, Though i can see the wubildr.mbr and wubildr files in the c: drive, under my windows installation. (Ubuntu is shown up in the bootloader, selecting it causes the messages to show up..).

the messages:

 Try (hd0,0): NTFS5: No wubildr
 Try (hd0,1): NTFS5: 0
 Try (hd0,2): invalid or null
 Try (hd0,3): invalid or null
 Try (fd0): invalid or null
 Error: Cannot find GRLDR in all devices. Press Ctrl+Alt+Del to restart.

I've searched the net and found a few unanswered topics with the same problem..

the original post on ubuntu-forums:
http://ubuntuforums.org/showthread.php?p=8273895

o0-leo (weee2003) on 2009-11-08
summary: - No wubildr error on 9.10 first restart when istalling on windows 7
+ No wubildr error on 9.10 first restart when installing on windows 7
o0-leo (weee2003) on 2009-11-08
description: updated
Agostino Russo (ago) wrote :

Anything peculiar about your set-up? Do you use raid or encrypted disks for instance?

o0-leo (weee2003) wrote :

I really don't think so, but i can't be sure because i don't know what those are.

i dont have multipal hard disks so i guess raid is off the hook...
i get that encrypted disks is software related... and my win 7 installation is regular.

thtitus (thtitus) wrote :

I can confirm this problem. A fresh install of karmic via wubi, reboot, and it finishes setup, then reboots again, and I get the same result as the poster of this bug.

Agostino Russo (ago) wrote :

oOleo what parition is wubi in?
thtitus, can you post the grub messages and mark in which partition wubi is installed?

o0-leo (weee2003) wrote :

I have only C: partition... (and reserved to OS hidden partition that I think windows 7 creates.)
and wubi is installed on C: ...
My situation, though, is different then thtitus one, the error comes right after the in-windows installation restart.

Agostino Russo (ago) wrote :

oO-leo there are 4 partitions listed in your bug report, although some of those might not have a filesystem

Agostino Russo (ago) wrote :

Well they are all tagged as ntfs5...

o0-leo (weee2003) wrote :

It might be just a copy mistake.. I'll check it when i'll get to my computer...
However, Windows 7 disk manager shows only the 2 partitions I listed...

o0-leo (weee2003) wrote :

Yep. Copy mistake.. Real messages:

 Try (hd0,0): NTFS5: No wubildr
 Try (hd0,1): NTFS5: 0
 Try (hd0,2): invalid or null
 Try (hd0,3): invalid or null
 Try (fd0): invalid or null

description: updated
o0-leo (weee2003) wrote :

Any progress?

Are there any records of wubi works smooth with 9.10 clean install on any other windows 7 (RC or not..) version?

buurd (roland-javalia) wrote :

My Wubi has worked for a couple of month now when this suddenly happend. I had some Windows Updates a couple of days ago but I have run Wubi after so I don't think that is the problem. Had some updates for Ubuntu yesterday so they might be involved.

buurd (roland-javalia) wrote :

Ok, got some help. I had deleted C:\wubildr when cleaning out some old files.

Perhaps a better errormessage could be deviced to advice the user a little more?

o0-leo (weee2003) wrote :

I think this has no relation to the bug...
But, are you using windows 7?

thtitus (thtitus) wrote :
o0-leo (weee2003) wrote :

I'm experiencing the exect same bug with ubuntu 10.04 .
Why this bug isn't getting any attention latly?

HorseDung (horse-dung) wrote :

I had the same problem using 10.04.

After running wubi-r187.exe I reboot and get "Try (hd0,0): NTFS5: No wubildr".
Sometimes it immediately reboots, but mostly it just hangs.

Hardware is: Asus eeePC 901 with 2Gb RAM.
OS: Windows 7 Professional 32-bit.
Disk 0: ASUS-Phison SSD 3.76Gb
Disk 1: RunCore 128G-C SSD 120Gb

Disk 0 has one EFI boot partition and rest is free space
Disk 1 has two Partitions (system reserved 100Mb NTFS and 120Gb C: NTFS)
Disk 1 is setup to appear to be (hd0) in BIOS.

After much, much, much hacking around... I finally got it to work by assigning a drive letter to the system reserved partition (100Mb) partition and copying the wubi boot files there. On reboot I had to hit ESC and choose ACPI workarounds and then it installed perfectly. Unassign the drive letter for the system reserved partition is fine after Ubuntu has been installed...

I assume its supposed to move on to scanning additional hard disk partiitons looking for wubildr but something about the Windows System Reserved partition is causing it to crash...??? If you'd like any additional info, please email...

tak (tak) wrote :

Confirmed, i have the wubildir file, on windows7 installing karmic through wubi, tried with kubuntu, and ubuntu, tried reinstalling several times, it will not work anymore.

PresuntoRJ (fabio-tleitao) wrote :

does not work with me neither... windows 7 with wubi 10.04.... one C: partition plus a small hidden on a Asus eee 1005

it does work quite well on a HP with windows 7 but without the hidden partition...

do not know why there is one in one computer and not in the other but it seems relevant for the issue

hstejas (tejashs) wrote :

i also am experiencing the same problem
and i am using asus M2N68 - AM SE2 motherboard

i have also seen that my windows 7 installation has 2 primary partitions C: and D: and 2 logical ones
and i have installed ubuntu in D: drive

Same situation with my laptop. Here are the specs:

1) Wubi 10.10 (Ubuntu Netbook)
2) Dell Mini
3) Was working smooth right from the beginning (one month approx), but got the same error displayed by oO-leo
4) Uninstalled Wubi & reinstalled. Now the same error immediately after rebooting windows (tried both Wubi 10.10 and 10.04i)

tags: added: iso-testing
bcbc (bcbc) wrote :

The file wubildr must exist in the root of one of those partitions. e.g. /dev/sda1/wubildr or if you're looking on your windows drive C:\wubildr

If the file doesn't exist then you should copy it from the \ubuntu\winboot\ directory to C:\

If your drive is severely fragmented or depending on the physical position of the file (some bioses can't read beyond 137GB) it may not work. Try defragmenting in this case.

o0-leo (weee2003) wrote :

Hello...
I know this is an old bug witch probebly won't get any attention..
But I find it frustrating that with ubuntu 11.04, I still can't use wubi...

I have taken an image of the partitions on my drive from the windows management tools,
I think the problem is related to 100mb system reserved partition windows 7 creates in some cases...

Please, take a look.

bcbc (bcbc) wrote :

Create a new bug, describe what symptoms you get, attach the log file from the %temp% directory (wubi-11.04-rev211.log)... or better yet, create a question in https://answers.launchpad.net/wubi/+addquestion so we can figure out whether it's a bug.
This is unlikely a problem with the 100MB boot partition.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers