crash when user name has Japanese-Katakana characters

Bug #472591 reported by Nobuto Murata on 2009-11-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Wubi
Medium
Agostino Russo

Bug Description

When user name of Windows has Japanese Katakana Characters,
Wubi crashes immediately without any log files.

http://en.wikipedia.org/wiki/Katakana
Windows version: Windows 7 Home Premium (Japanese)

How to reproduce:
1. Boot Windows with a user name has Japanese Katakana Characters.
2. Insert Ubuntu 9.10 CD.
3. Execute Wubi
4. Wubi crashes

Expected result:
4. Wubi launch and success install.

How to avoid this issue temporarily:
1. Make "temp" folder beneath C: drive.
2. Execute Wubi.
3. Success install.
4. You get a log file in C:\temp.

Nobuto Murata (nobuto) wrote :
Nobuto Murata (nobuto) wrote :

Above is the log with user name "テストアカウント" after making C:\temp folder.

Agostino Russo (ago) wrote :

I do not see any error in the log above, it seems like the installation was completed.

I think the problem is not about Katakana characters but that you didn't have ANY temp directory.
Wubi extracts its files to the temp directory, which in this case becomes impossible.

summary: - crash when user name has Japanese-Katakana characters
+ crash when there is no temp directory
Changed in wubi:
status: New → Won't Fix

The vast majority of windows users should have a temp directory available by default (user or system), we could extract files to memory but that is a bit invasive and I do not feel we need to change things unless there are more user cases. Also because the workaround (creating a temp directory) should be fairly straightforward.

Nobuto Murata (nobuto) wrote :

> it seems like the installation was completed.
Yes it's the log file when installation complete.
Making C:\temp works fine.
But usually we don't have C:\temp folder.

> I think the problem is not about Katakana characters but that you didn't have ANY temp directory.
Temp directory exists as "C:\Users\テスト~1\AppData\Local\Temp\".
This directory is used by Wubi like "C:\Users\テスト~1\AppData\Local\Temp\pyl435B.tmp\data".
I think the log file shows this fact.
But only log file is stored like c:\temp\wubi-9.10ubuntu1-rev160.log.

Agostino Russo (ago) wrote :

I see,

I think the c++ side has problems accessing the user temp directory, so it fails if there is no system temp directory.

Changed in wubi:
status: Won't Fix → Confirmed
importance: Undecided → Medium
assignee: nobody → Agostino Russo (ago)
Agostino Russo (ago) wrote :

Without c:\temp, what is the output of

echo %temp%

? Does it point to your user temp dir?

Nobuto Murata (nobuto) wrote :

echo %temp%
returns
C:\Users\テスト~1\AppData\Local\Temp

It came from windows configurations "%USERPROFILE%\AppData\Local\Temp".

Nobuto Murata (nobuto) on 2009-11-03
summary: - crash when there is no temp directory
+ crash when user name has Japanese-Katakana characters
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers