Wubi, Windows Ubuntu Installer

kne image plus persistence means that the iso size is too large I believe

Reported by Dave Morley on 2009-10-26
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Wubi
Medium
Unassigned

Bug Description

(08:56:46 AM) evand: I think our best bet is to release note this, tell users to use --force if on a usb disk, and fix it properly in lucid
(08:57:14 AM) xivulon: I agree this is not critical, and it will not justify a respin
(08:57:39 AM) xivulon: even if we had a proper patch, which we don't at the moment

Release note:
Users who wish to run Wubi from a USB disk that has persistent storage enabled will need to run it with the --force-wubi option from the Windows command line.

Original report follows:
The current kne size is +700 mb plus the default minimum persistence of 128mb and the install inside windows option is missing from the menu. However by switching off persistence this drops the iso size and install inside windows option becomes available again.

I believe this is to do with the option in wubi for max_iso_size (but could be horribly wrong)

Dave Morley (davmor2) on 2009-10-26
Changed in wubi:
assignee: nobody → Evan Dandrea (evand)
Agostino Russo (ago) wrote :

The check in /home/src/wubi/trunk/src/wubi/frontends/win32/cd_menu_page.py (line 63) is too restrictive, that was in place to discriminate against DVD. A quick fix is to remove the upper bound

if self.info.force_wubi or \
        self.info.cd_distro.min_iso_size < used:

DVDs will still be discriminated when the user is online since the MD5 check will fail, but DVDs will go through when offline and in this case the free space check is inappropriate as we check for regular ISO size. In short removing the upper bound is an issue if the user is using a DVD, offline, and with low disk space.

A proper DVD check would be a bit too invasive at this stage.

Agostino Russo (ago) wrote :

As a quick and dirty patch we could have: min_iso_size < used < DVD_size
Still inadequate but will provide some headroom without side effects.

Evan Dandrea (ev) on 2009-10-27
description: updated
Agostino Russo (ago) on 2009-10-28
Changed in wubi:
status: New → Confirmed
importance: Undecided → Medium
Steve Langasek (vorlon) wrote :

Documented at <https://wiki.ubuntu.com/KarmicKoala/ReleaseNotes#Wubi%20using%20persistent%20storage%20on%20a%20USB%20disk>:

Users who wish to run Wubi from a USB disk that has persistent storage enabled will need to run it with the {{{--force-wubi}}} option from the Windows command line. (Bug:461566)

Changed in ubuntu-release-notes:
status: New → Fix Released
tags: added: iso-testing
Evan Dandrea (ev) on 2011-02-08
Changed in wubi:
assignee: Evan Dandrea (ev) → nobody
bcbc (bcbc) on 2012-01-20
tags: added: precise
bcbc (bcbc) wrote :

This is still a problem. When you install Wubi from a USB, it copies the entire USB partition onto the hard drive (can easily be 8GB or 16GB these days). Then Wubi fails the ISO if it's larger than 900000000 bytes (~852MB). When you create an Ubuntu USB it states to have at least 2GB free space: http://www.ubuntu.com/download/ubuntu/download "Insert a USB stick with at least 2GB of free space".

Since the precise desktop ISO is supposed to be 750MB I suspect more people will be using USBs.

There are two major problems:
1. The install fails. obviously.
2. You could potentially full up someone's hard drive since there's no space check to prevent a 16GB ISO being copied.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers