Karmic: Wubi could not launch with Japanese-multibytes user names

Bug #452348 reported by Jun Kobayashi on 2009-10-15
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Wubi
High
Unassigned
Ubuntu
Undecided
Unassigned
Nominated for Karmic by Fumihito YOSHIDA

Bug Description

I've tested wubi with Karmic dailiy live 20091014.1 x86 Desktop CD image, and wubi crashed immediately and no dialogs up.
I'm using a user account named with Japanese characters. I created a user named only with acsii character, test wubi with it, and works fine.

How to reproduce:
1. Create a user named with Japanese caracters on Windows Vista Japanese Edition.
2. Insert Karmic Desktop CD.
3. A autorun dialog pops up, select "wubi.exeの実行" (means "run wubi.exe")
4. No dialog shows up.
5. You'll find a log file "wubi-9.10-rev156.log" in your temp folder including error message lines.

Expected results:
Wubi runs correctly with Japanese user names.

Related branches

Jun Kobayashi (jkbys) wrote :

log file

summary: - Wubi crashes immediately in the case of with Japanese user names
+ Wubi exits immediately in the case of with Japanese user names

On inquiry, the "unicode" function should take 'mbcs' for 2nd argument if 1st arg includes Japanese character, or aborts.
Additionaly, 1st arg of the "os.path.join" function should be converted to unicode, or it aborts if Japanese characters are given.

I'm attaching a diff file for the wubi source tree(rev158).
I'v compiled wubi with this patch and works fine on my Windows Vista Japanese Edition.
There are probably no ill effects if you use non-Japanese Windows.
I'll be pleased if wubi developers view this patch and comment.

Fumihito YOSHIDA (hito) on 2009-10-20
summary: - Wubi exits immediately in the case of with Japanese user names
+ Karmic: Wubi could not launch with Japanese-multibytes user names
Changed in wubi:
status: New → Confirmed
importance: Undecided → High
Arne Goetje (arnegoetje) wrote :

Just a side note: the login name, as well as password fields should never allow anything else than ASCII characters. Everything else would highly depend on the local keyboard layout at login time and could leave the user stranded without the possibility to log into the system. Especially East-Asian IMEs are not supported at login time.

Jun Kobayashi (jkbys) wrote :

Arne, Thank you for your note. Wubi will copy the login name from the one of Windows, but in the case of using a non-ASCII user name on Windows, it won't copy the name and leave the input feild blank. And we must input other login name for Ubuntu with ASCII characters or Wubi warns. So I think there's no problem at least about login names if using the above patch.

Agostino Russo (ago) wrote :

Jun, thanks for the patch, we will try to have it in for karmic, if it is not possible, I will make the patched version of wubi available on wubi-installer.org and ubuntu.com

Agostino Russo (ago) on 2009-10-24
Changed in wubi:
status: Confirmed → Fix Committed
Changed in ubuntu:
status: New → Invalid
Agostino Russo (ago) wrote :

Applied patch and tested with English username and could not see any regression. Needs further testing.

Evan (ev) wrote :

I've uploaded a fixed version to <http://people.canonical.com/~evand/wubi/karmic/wubi-r159.exe>. If we can get a few more tests using this version, I'll be happy to make sure it gets on the CD. Please reply in this bug report with the version of Windows you used, your internationalization settings, and whether or not the install was successful.

Thanks!

Evan (ev) wrote :

It's worth noting that my wubi r159 build bumped us to grub version 1.97~beta4-1ubuntu3.

Fumihito YOSHIDA (hito) wrote :

Evan:
 I tested with wubi r159 build within below 4 envs, it works for me.
 - Windows Vista Enterprise(SP2) / x64, Japanese
 - Windows Vista Ultimate(SP2) / x64, Japanese
 - Windows Vista Home Premium(SP2) / x86, Japanse
 - Windows XP Professional(SP3) / x86, Japanese

Shushi Kurose (kuromabo) wrote :

I also tested with wubi r159 on 4 envs below.
It works fine on all.

- Windows 7 Starter / x86, Japanese
- Windows 7 Home Premium / x86, Japanese
- Windows 7 Professional / x86, Japanese
- Windows 7 Professional / x64, Japanese

Evan (ev) wrote :

Okay, stable symlink changed. This will be on the next daily-live CD build.

Agostino Russo (ago) on 2009-10-26
Changed in wubi:
status: Fix Committed → Fix Released
Nobuto Murata (nobuto) wrote :

I tried wubi-r159.exe and wubi-r160.exe ( http://people.canonical.com/~evand/wubi/karmic/ ).
But Wubi still exits immediately.

Windows Vista SP2
Username = "テストアカウント2号"

There is no log file on C:\Users\USERNAME\AppData\Local\Temp.

Nobuto Murata (nobuto) wrote :

Sorry I forgot to tell Vista's edition.
Windows Vista Home Premium SP2.

Agostino Russo (ago) wrote :

Nobuto this might be due to a different bug. Try the official wubi release, there should be some wubi file in your user temp folder. You can also try to run wubi.exe from command line.

Nobuto Murata (nobuto) wrote :

I created new username for Windows Vista and tried another Wubi on http://wubi-installer.org/.
But also exits immediately.

In C:\Users\テストアカウント\AppData\Local\Temp directory,
there are "pyl*.tmp", "Low" and "WPDNSE" folders, which are empty.
"jusched.log", "wmsetup.log", "テストアカウント.bmp" also left.

And also tried from command line(cmd.exe)

C:\Users\テストアカウント>wubi.exe
appears UAC window and allow it.
Then resturn no message and show below line again.
C:\Users\テストアカウント>

After patch which Jun committed,
Kanji and Hiragana (types of Japanese multibyte character) became OK,
but Katakana (a type of Japanese multibyte character) is still have trouble.
http://en.wikipedia.org/wiki/Katakana

"テストアカウント" is consist of Katakana characters.

Nobuto Murata (nobuto) wrote :

> this might be due to a different bug.
Agostino, maybe yes.

I will report as a new bug and write a bug number on this thread later.

Nobuto Murata (nobuto) wrote :

I reported as Bug #472591.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers