Wubi now only shows memtest options in grub2

Bug #435153 reported by Dave Morley on 2009-09-23
56
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Wubi
Undecided
Unassigned
memtest86+ (Ubuntu)
Undecided
Unassigned
partman-auto-loop (Ubuntu)
Undecided
Unassigned

Bug Description

Wubi on Ubuntu now only displays the 2 memtest options in grub2 on ubuntu.
The memtest options don't actually do anything either as they point to, I'm assuming, where they would be either on the cd or first harddrive partition and not in the loop system of wubi.

20090922 iso was used for this report.

Colin Watson (cjwatson) wrote :

I've fixed the fact that only the memtest items are showing up, but not yet the fact that they're broken. It may be best to remove them for Karmic if we don't have time to fix them ...

lupin (0.24) karmic; urgency=low

  * Call update-grub on lupin-support installation. This is needed for fresh
    Wubi installs, since lupin-support is installed after grub-installer
    runs.

 -- Colin Watson <email address hidden> Tue, 22 Sep 2009 19:54:28 +0100

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package memtest86+ - 2.11-3ubuntu4

---------------
memtest86+ (2.11-3ubuntu4) karmic; urgency=low

  * Don't emit grub2 menu items if /boot is on a loop-mounted device (e.g.
    Wubi; LP: #435153).

 -- Colin Watson <email address hidden> Mon, 28 Sep 2009 10:01:25 +0100

Changed in memtest86+ (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto-loop - 0ubuntu18

---------------
partman-auto-loop (0ubuntu18) karmic; urgency=low

  * Bind-mount /host on /target/host during installation, to match the
    installed system after reboot (LP: #435153).

 -- Colin Watson <email address hidden> Tue, 29 Sep 2009 22:12:41 +0100

Changed in partman-auto-loop (Ubuntu):
status: New → Fix Released
Martin Pitt (pitti) on 2009-09-29
Changed in wubi:
status: New → Fix Released
status: Fix Released → Confirmed
Agostino Russo (ago) on 2009-10-03
Changed in wubi:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers