"Cannot download the metalink and therefore the ISO"

Bug #383752 reported by kaiZer on 2009-06-04
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Wubi
Medium
vinoth

Bug Description

I downloaded ISO image of Kubuntu 9.04 (and Ubuntu 9.04) and burned CD... When i try to install Kubuntu or Ubuntu from CD i get an error "Cannot download the metalink and therefore the ISO". Wubi creates folder "ubuntu", size 697 Mb.. I don't know what to do..

Agostino Russo (ago) wrote :

Can you please attach the log?
It is in the user temp folder?

Agostino Russo (ago) wrote :

This usually happen when the ISO cannot be extracted from the CD and/or the CD is corrupted, so that a new ISO download is attempted.

kaiZer (kaizer-am-i) wrote :

yeah, log-file creates in the user temp folder..

kaiZer (kaizer-am-i) wrote :

hmm.. i'll try to re-download the ISO but i think the problem not with the ISOs or CDs..

Norbert Schulze (n-schulze) wrote :

It is the same when i use the latest Version from http://wubi-installer.org/

System: Windows XP SP3

1. Download wubi.exe from http://releases.ubuntu.com/9.04/wubi.exe
2. Start wubi.exe
3. Select Kubuntu and fill the form
4. Click "Install" and error "Cannot download the metalink and therefore the ISO"

When i select Ubuntu or Xubuntu, it is OK.

mandymas (mandy-mas) wrote :

I have the exact same problem and error message. I have not been able to install, and also have Windows XP, SP2. I figure XP won´t let especifically the program dowload the metalink because I can open in my browser the metalink.

I decided to use wubi after I downloaded the install for CD but always had a diferent md5sum hash number.

How can I get around these problems?

If I download and burn in another computer, will I still have a problem installing on this computer?

Agostino Russo (ago) wrote :

@mandymas no need to burn a CD just to run wubi, download wubi.exe and put that in the same directory containing the ISO. By the way is the problem also with Kubuntu?

@Norbert, you did not provide a CD or an ISO, so it tries to download one (this is normal given the circumstances) but it fails to download the files, because the metalink URL for koubuntu should start with "http://", patch committed. Thanks for the log.

@kaiZer, the download of Kubuntu fails for the same reason as above, but I still do not understand why the copy of the CD fails. I assume that the ISO is extracted from the CD in the G drive, but after being extracted to E:\ubuntu\install\installation.iso, it looks like casper/filesystem.squashfs is no longer in the ISO. Can you check the md5 of the CD and of the extracted ISO?

06-04 23:59 DEBUG Distro: checking Kubuntu ISO E:\ubuntu\install\installation.iso
06-04 23:59 DEBUG Distro: does not contain casper\filesystem.squashfs

Changed in wubi:
assignee: nobody → Agostino Russo (ago)
importance: Undecided → Medium
status: New → Confirmed
Erasom (ezziddin105) wrote :

Umm, how long do bugs like these take to fix?

Erasom (ezziddin105) wrote :

And is there any way around it?

ghost005 (jonas-mahlkefelde) wrote :

Hello is there a way to work around it now? by the way as far as i see it, it is the same thing as in https://bugs.launchpad.net/wubi/+bug/371264 at least i got both errors together Thanks for the help.

Jerryrad (jerryrad) wrote :

Hi all, this is my first post to this site. Anyway, I had the same problem with the metalink. Of course the easiest solution would be to just burn the iso to a cd (as was already mentioned). However, I was determined to use wubi to install.

ANYWAY, this worked for me. Download the ISO to your desktop and extract wubi (only wubi nothing else) from the ISO using winrar. Run wubi. Presto.

Rapper_Hondureño (lito) wrote :

Hellooo...

This is my first post in this page, and I want to say that I am not good writing or speaking english, but I want to help...

I have this problem too, the same error in the log wen I tried to install from CD, then I download the Power ISO program and I mount the ISO file into a driver, so I have a virtual drive into my computer, then put out the cd and install from the virtual drive and everything was ok, so I hope this post can help to somebody...

my mail for questions or more information is: <email address hidden>

download power ISO for free: http://www.programas-gratis.net/css/descargar_pop.php?programa=power-iso

to mount a virtual drive: http://mx.answers.yahoo.com/question/index?qid=20070815083256AAcMLBb

Good Day... ahh I speak Sapanish, but I can make my best try :D

Agostino Russo (ago) wrote :

Is this still an issue in 9.10? Please try: http://people.canonical.com/~evand/wubi/karmic/wubi-r168.exe

Norbert Schulze (n-schulze) wrote :

With wubi-r168.exe the download of "kubuntu-9.10-desktop-i386.iso.torrent" starts! :-)

Agostino Russo (ago) on 2009-11-06
Changed in wubi:
status: Confirmed → Fix Committed

win xp with sp3 sytem. i have the same problem. tried wubi 170 no avail
any solutions

Download full text (251.9 KiB)

Tried Rapper_Hondureño's workaround but that did not work either.

my log file

11-04 07:12 INFO root: === wubi 9.10ubuntu1 rev160 ===
11-04 07:12 DEBUG root: Logfile is c:\docume~1\shree\locals~1\temp\wubi-9.10ubuntu1-rev160.log
11-04 07:12 DEBUG root: sys.argv = ['main.pyo', '--exefile="H:\\wubi.exe"', '--cdmenu']
11-04 07:12 DEBUG CommonBackend: data_dir=C:\DOCUME~1\shree\LOCALS~1\Temp\pyl118.tmp\data
11-04 07:12 DEBUG WindowsBackend: 7z=C:\DOCUME~1\shree\LOCALS~1\Temp\pyl118.tmp\bin\7z.exe
11-04 07:12 DEBUG CommonBackend: Fetching basic info...
11-04 07:12 DEBUG CommonBackend: original_exe=H:\wubi.exe
11-04 07:12 DEBUG CommonBackend: platform=win32
11-04 07:12 DEBUG CommonBackend: osname=nt
11-04 07:12 DEBUG CommonBackend: language=en_US
11-04 07:12 DEBUG CommonBackend: encoding=cp1252
11-04 07:12 DEBUG WindowsBackend: arch=amd64
11-04 07:12 DEBUG CommonBackend: Parsing isolist=C:\DOCUME~1\shree\LOCALS~1\Temp\pyl118.tmp\data\isolist.ini
11-04 07:12 DEBUG CommonBackend: Adding distro Xubuntu-i386
11-04 07:12 DEBUG CommonBackend: Adding distro Xubuntu-amd64
11-04 07:12 DEBUG CommonBackend: Adding distro Kubuntu-amd64
11-04 07:12 DEBUG CommonBackend: Adding distro Mythbuntu-i386
11-04 07:12 DEBUG CommonBackend: Adding distro Ubuntu-amd64
11-04 07:12 DEBUG CommonBackend: Adding distro Ubuntu-i386
11-04 07:12 DEBUG CommonBackend: Adding distro Mythbuntu-amd64
11-04 07:12 DEBUG CommonBackend: Adding distro Kubuntu-i386
11-04 07:12 DEBUG CommonBackend: Adding distro KubuntuNetbook-i386
11-04 07:12 DEBUG CommonBackend: Adding distro UbuntuNetbookRemix-i386
11-04 07:12 DEBUG WindowsBackend: Fetching host info...
11-04 07:12 DEBUG WindowsBackend: registry_key=Software\Microsoft\Windows\CurrentVersion\Uninstall\Wubi
11-04 07:12 DEBUG WindowsBackend: windows version=xp
11-04 07:12 DEBUG WindowsBackend: windows_version2=Microsoft Windows XP
11-04 07:12 DEBUG WindowsBackend: windows_sp=Service Pack 3
11-04 07:12 DEBUG WindowsBackend: windows_build=2600
11-04 07:12 DEBUG WindowsBackend: gmt=5
11-04 07:12 DEBUG WindowsBackend: country=US
11-04 07:12 DEBUG WindowsBackend: timezone=America/New_York
11-04 07:12 DEBUG WindowsBackend: windows_username=shree
11-04 07:12 DEBUG WindowsBackend: user_full_name=shree
11-04 07:12 DEBUG WindowsBackend: user_directory=C:\Documents and Settings\shree
11-04 07:12 DEBUG WindowsBackend: windows_language_code=1033
11-04 07:12 DEBUG WindowsBackend: windows_language=English
11-04 07:12 DEBUG WindowsBackend: processor_name=Intel(R) Pentium(R) Dual CPU E2180 @ 2.00GHz
11-04 07:12 DEBUG WindowsBackend: bootloader=xp
11-04 07:12 DEBUG WindowsBackend: system_drive=Drive(C: hd 12176.7734375 mb free ntfs)
11-04 07:12 DEBUG WindowsBackend: drive=Drive(C: hd 12176.7734375 mb free ntfs)
11-04 07:12 DEBUG WindowsBackend: drive=Drive(D: cd 0.0 mb free cdfs)
11-04 07:12 DEBUG WindowsBackend: drive=Drive(E: hd 18042.3164063 mb free ntfs)
11-04 07:12 DEBUG WindowsBackend: drive=Drive(F: hd 30439.8554688 mb free ntfs)
11-04 07:12 DEBUG WindowsBackend: drive=Drive(G: hd 997.30078125 mb free ntfs)
11-04 07:12 DEBUG WindowsBackend: drive=Drive(H: cd 0.0 mb free cdfs)
11-04 ...

Agostino Russo (ago) wrote :

madhuperiasamy I think yours is a different issue, probably you have the same problem as in bug #207137
A workaround is to use wubi.exe with the ISO directly, without a CD.
Put wubi.exe and the ISO in the same directory and then run wubi.exe.

Thanxs Agostino .
Shall try and get back

 Thank you Agostino,
That worked lik a charm.
Keep up the good work

Mark Essel (messel) wrote :

I had a similar problem trying to install Kubuntu.
Tried extracting the wubi.exe, and also the canonical wubi-r168.exe.
Neither worked, same meta link error.

Trying one more time from the web, if it dies this time I'm giving up on wubi/ubuntu.

I have work to do! (and was hoping having a linux install would help :( )

Agostino Russo (ago) wrote :

Mark, you might have a different problem, I would need the wubi log though to be more precise. That is in your user temp folder. Please use version 170.

Mike (mikeodu2011) wrote :

I'm having the same issue. Tried installing the latest wubi on my laptop and I get the same error. I'm downloading the 9.10.iso to see if it'll work.

I'm receiving this error as well.

I downloaded the latest 9.10 netbook remix, today, and am trying to install via USB to an ASUS EEE pc running windows XP SP3.

Rich S01 (richmsg) wrote :

what a big waste, to bad it can not just be fixed, in stead of so many talking about it.

So what else is new?

> Date: Thu, 10 Dec 2009 23:44:39 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 383752] Re: "Cannot download the metalink and therefore the ISO"
>
> I'm receiving this error as well.
>
> I downloaded the latest 9.10 netbook remix, today, and am trying to
> install via USB to an ASUS EEE pc running windows XP SP3.
>
> --
> "Cannot download the metalink and therefore the ISO"
> https://bugs.launchpad.net/bugs/383752
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Wubi, Windows Ubuntu Installer: Fix Committed
>
> Bug description:
> I downloaded ISO image of Kubuntu 9.04 (and Ubuntu 9.04) and burned CD... When i try to install Kubuntu or Ubuntu from CD i get an error "Cannot download the metalink and therefore the ISO". Wubi creates folder "ubuntu", size 697 Mb.. I don't know what to do..
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/wubi/+bug/383752/+subscribe

_________________________________________________________________
Windows 7: Unclutter your desktop. Learn more.
http://www.microsoft.com/windows/windows-7/videos-tours.aspx?h=7sec&slideid=1&media=aero-shake-7second&listid=1&stop=1&ocid=PID24727::T:WLMTAGL:ON:WL:en-US:WWL_WIN_7secdemo:122009

espo111 (frankesposito) wrote :

same issue here. exception error --see attached

Doyin (doyin) wrote :

This is my own problem. I am trying an offfline install. Here is my log file attached

Doyin (doyin) wrote :

Here is another log file attached.

ceder (cederadmin) wrote :

I struggled with the same problem and I just turned of the Firewall during the installation and everything worked perfect!!!!

lancemotown (dan-cloney) wrote :

Same problem as above with wubi. Turned off windows firewall and problem persisted.
Is there some other firewall that I may have to switch off? God I wish I knew more about computers.

suell (c-liang) wrote :

I have the same problem and I have tried everything above. but the problem still remains. Even I put the iso and the r168.exe files in the same directory the installer still can't find it. What else I can do?

Ekim Erdogan (ekimerdogan) wrote :

Agostino, your solution worked well on my netbook. Thank you very much.

Artty MI (1europe) wrote :

Ceder, i had outpost firewall pro; disactivated it (till next reboot) and everything went pe3rfect! Thanks for the tip. BTW I don't understand why though .. for example I have utorrent, and Free Download Manager, and all downloads work - wubi should just start a download of the Ubuntu package shouldn't it? Anyway, solved for me, good luck guys.

Manni (manni-di-sardari) wrote :

Hi there
Can anybody please help me ?
I have got an error in installing the ubuntu through wubi on windows 7.
Look i download the wubi installer from this ( http://wubi-installer.org/ ) site and then goes to run the .exe file thai is wubi.exe and then simply fills the requirements as i need. And then i don't know what gonna happen there to installation as it gives such an error like [ Please you can also see this ( http://www.7bucket.com/i/00000/spmog3vavgtw.png )one snapshot contains two windows one is downloading as it shows the remaining time and down to this is the error window ]. Please if anyone please help me as early as possible by you.

An error occurred:

Permission Denied

Fore more information, please see the log file:
C:\users\manni\appdata\local\wubi-9.10ubuntu1-rev160.log

THANKS YOU VERY MUCH

David (cougarcia) wrote :

Hi I had the same error message trying to install version 10.10 and couldn't find the solution on other posts. When I checked the log file it appeared that wubi was looking for 10.04.01 instead of 10.10 (and yes I had wubi and the ISO) in the same folder. The file on the Ubuntu website was incorrect, I managed to solve the problem by extracting wubi from the ISO.
Thanks

George (liatsos) wrote :

I have solved the problem by setting the Protection Level to my firewall to "Allow All" mode.

I guess by turning off the firewall temporarily to allow wubi to dowload the iso or setting a rule for wubi to your firewall might solve the problem and you won't get the error "Cannot download the metalink and therefore the ISO".

Regards,
George

joachim@hogvag.com (joachim-z) wrote :

Hi!

The problem is that the files and folders have changed on the server.
In my case Wubi looked for

http://cdimage.ubuntu.com/ubuntu-netbook/daily-live/current/natty-netbook-i386.metalink
That did not exist
The closest thing in the file structure was http://cdimage.ubuntu.com/ubuntu-netbook/ports/releases/10.10/
I did not manage to find any metalink files at all.

This should be changed in wubi.exe by the ubuntu team.

I downloaded wubi from ubuntu.com.

bcbc (bcbc) wrote :

Joachim, your problem is bug 772941 - there is no netbook edition anymore since the release of 11.04.

vinoth (vinoth-k239) on 2011-11-06
Changed in wubi:
assignee: Agostino Russo (ago) → vinoth (vinoth-k239)
status: Fix Committed → Incomplete
Radek U (ru-radec) wrote :

Hi everybody.

I found the solution, instead of using latest version of wubi 12-something I've downloaded only one version that worked for me, it's wubi 11.04. I hope it's gonna solve problem at least for some of you. :)

Ali A (alrshelby) wrote :

having my Drives as Olive color (Disk Management ), I did not have my hard drives on primary partition. ( Somehow they have become Dynamic volumes) so to fix that download a program called miniTool Partition wizard and change your drive partition to primary so you can run another operating system on it.
hope that works for you

Doug Duncan (dduncan54) wrote :

Try renaming the ISO to the version wubi.exe is looking for.

Doug Duncan (dduncan54) wrote :

I should also have mentioned don't change the file type, just version part of the file name. for example, wubi.exe states in the install log "Cannot download metalink file http://releases.ubuntu.com/14.04/ubuntu-14.04-desktop-amd64.metalink"

Rename the iso file from mythbuntu-14.04.2-desktop-amd64.iso to mythbuntu-14.04-desktop-amd64.iso

At least it worked for me, got me past that problem. Now I'm working on another....

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions