Wubi, Windows Ubuntu Installer

Wubi - "No root file system is defined" Error

Reported by David Balažic on 2008-08-19
78
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Wubi
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

I started the Ubuntu 8.04.1 amd64 CD in Windows and selected "Install inside Windows" option.
This problem occurs in many distributions of Linux when installing Wubi onto a Windows platform.
Then in the "Ubuntu Setup" dialog I left the default options (which were : "C:", "15", "Ubuntu", "English" and "administrator") , entered a password (twice of course) and clicked "Install".

After some copying it rebooted.
In the Boot menu I choose "Ubuntu". For a few seconds it displayed a warning*, then started loading.

After the desktop was loaded, an error dialog appeared, saying:

No root file system is defined.

Please correct this from the partitioning menu.

(see screenshot)

After clicking OK, the same dialog reappears. (many times)
So the installation is stuck at this point.

The existing OS is Windows 2008 Datacenter x64.
The harddrive is a Dynamic Disc, having one NTFS partition (C:).

* - the warning is :
Warning: Unrecognized Partition Table for Drive 80. Please rebuild it using
a Microsoft-compatible FDISK tool(err=114). Current C/H/S=16383/31/63
Press 'ESC' to enter the menu...

Feel free to ask for any other information.

David Balažic (xerces8) wrote :
Agostino Russo (ago) wrote :

Can you try with a clean installation after running chkdsk /r and defragmenting the disk?

Agostino Russo (ago) on 2008-09-18
Changed in wubi:
status: New → Incomplete
rock5 (jahlaniwest) wrote :

I have the same problem but I have a new hard drive. It won't give me the option to make a partition. Is there a way around this?

David Balažic (xerces8) wrote :

Agostino Russo wrote:
> Can you try with a clean installation after running chkdsk /r and defragmenting the disk?
I did.*
Same result.

* - I run chkdsk /f, not /r. It was in VMWare on a laptop* I use daily and I am confident it has no bad sectors.

* - note to myself: haldol

Changed in wubi:
status: Incomplete → New
David Balažic (xerces8) wrote :

Oh, this time I used Ubuntu 9.04 amd64 CD ISO.

David Balažic (xerces8) wrote :

To be exact, the .disk/info file says:
Ubuntu 9.04 "Jaunty Jackalope" - Release amd64 (20090420.1)

Agostino Russo (ago) wrote :

Please try with 9.10, at boot select verbose mode (press ESC at the countdown). If you have the same problem please attach the content of /var/log/syslog and /var/log/installer.

Agostino Russo (ago) on 2009-11-02
Changed in wubi:
status: New → Incomplete
Stefano Bragaglia (sbragaglia) wrote :

I've tried several Ubuntu flavors (Gnome, KDE and XCFE, both x86 and AMD) both 9.04 and 9.10 on Windows 7 RC (Ultimate) ITA and Windows 7 Professional ENG and I always get the aforementioned error (without experiencing the fdisk warning):

   No root file system is defined.
   Please correct this from the partitioning menu.

I tried several combination of "Run as admin", compatibility mode and language to install (since someone said Wubi was able to complete installation with these parameters) but I had no luck...

I also tried to set up a straight dual boot configuration but I always get the same error message as above...

I've read somewhere (sorry, I didn't bookmarked the source) that it depends on some minor changes on NTFS made by Microsoft... I don't know if this is true, but I noticed that even if I told the Windows Installer to create only one partition, it created two partitions instead where the first is hidden and is 100 Mb in size more or less (it actually depends on the size of the disk) and the second is the actual partition I was expecting... The first partition is used to store system file in case you need to recover the system in case of failure (on former versions of Windows you were supposed to use the Windows DVD instead)...
This is what you get by default unless you are installing on a disk with several already existing partitions or you bypass the standard procedure and you take control of the process...

So I came up with this idea: is the target partition hardcoded in Wubi?
I mean, is Wubi always trying to install Ubuntu on disk 0, partition 0, etc. by default?
If this is true and you have the hidden partition on your machine, then the Ubuntu installer called in second step by Wubi after reboot fails because it's performing its job on a partition different than the one expected...

I hope this helps, since I really need to install Ubuntu... In case my explanation was not clear enough (very likely) I can provide further details...

Thanks in advance,
     Stefano

MtMCooLBG (mad-man) wrote :

I have the same problem here, and like Stefano Bragaglia i think that this hidden partition is causing somehow the problem with wubi.
Stefano Bragaglia i dont think that wubi target partition is hardcoded, because before i used windows Vista, and allways installed wubi in D:\ and it's not the first partition.

I think that wubi get somehow the partition number from windows accesible partition.
I mean that for windows 7 the first accessible partition is C:\ and the secon is D:\ etc ...
and when you try to install in D:\ for example, it mark for installation the actual second partition wich in that case is C:\ (because the first is that system reserved), and the files for installation are in D:\, and then BUM -> that error.

My idea and my question here is, is there a way to manualy specify the target partition for the installation process(after reboot).
For now i checked the wubi/grub config files, but didnt found anything to use/change.

MtMCooLBG (mad-man) wrote :

Sorry for the second message. I wanned to post my output from #fdisk -l using Ubuntu 9.04 Live CD.

root@ubuntu:/home/ubuntu# fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xe380e380

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 13 102400 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 13 8534 68442112 7 HPFS/NTFS
/dev/sda3 8534 60802 419840000 7 HPFS/NTFS
root@ubuntu:/home/ubuntu#

Stefano Bragaglia (sbragaglia) wrote :

MtMCooLBG, thank you for sharing your opinion!

I had no problem installing Ubuntu with Wubi on the same machine when the O.S. was Vista...
That Vista installation was the one that shipped with the notebook: that installation had 2 partitions both visible...
One was the system, the other was the "dump" of the Vista's Setup DVD that shipped with the notebook...

Moreover, the Ubuntu version I installed succesfully on that machine were 8.10 and 9.04... I read that 9.10 uses a different partitioning system along with Grub 2 that is still in beta... It could be a possible cause of the problems we experience but I'm not so sure, since I had no luck installing 9.04 on the same hardware with Windows 7...

Consider also it could not be Wubi's fault at all, since I also had no luck with dual booting: the partition manager sees my hard drive as completely empty... Is it Ubiquity's fault then?

I also had a try on my desktop computer: it has Windows 7 RC x64, 2 SATA2 HD in RAID 0 and a common HD (both with NTFS)...
Wubi hanged after rebooting, not finding any drive... Ubiquity alone recognized all partitions and made me resize the normal drive to leave some space for the 2 usual linux partitions... Anyway, despite the install completed successfully, I was not able to bootstrap Linux (still trying a few tricks with EasyBCD I gathered on internet)...

I hope this will help someone to sort things out and solve the problem, thanks in advance,
     Stefano

thefons (fons-mobiel) wrote :

I have this also on my Vaio laptop. Ubuntu 9.10 , Wubi 9.10. Vista, 2 SATA2 HD in RAID 0, one C: NTFS partition and one vaio rescue partition. attaching requested logs

thefons (fons-mobiel) wrote :
thefons (fons-mobiel) wrote :
Bill Cassidy (cassid4) wrote :

I have tried to install Ubuntu 10.04 using WUBI from the CD while in windows XP, after it installs in windows Wubi asks to reboot. Booting into the Ubuntu option leads to the installation verification beginning and then the screen "No root file system", "No root file system is defined. Please correct this from the partitioning menu. [OK]".

Tais Plougmann Hansen (taisph) wrote :

I just got the same message after installing Kubuntu 10.04 using WUBI on Windows 7 Ultimate 64-bit.

Anirban (helloanirban) wrote :

for me also it's throwing the same error.

No root file system is defined.
Please correct this from the partitioning menu.

How to create partition. or where is the partition menu.

I am using ubuntu 10.04 and windows vista. Would anyone give some idea on this.

Hi folks,

I'm experiencing the same issue as well. After installing Windows 7 Professional x64, then attempting to install Wubi, the same issue occurs. The boot menu appears, I'd select "Ubuntu" from the list, the GUI would load, then a few setup dialogs would pop up (curiously at "271%"), followed by the "No root file system" error dialog, without the partitioning menu that the dialog says should be visible.

The same occurs when booting in text mode. A login prompt appears, when this error message is printed to the console infinitely in rapid succession. If there's any help I can offer in terms of logs or debug info, I'm happy to provide it.

I notice this issue's status is set to "Incomplete." Please let me know what you need to be able to consider it "Confirmed" and progressing toward resolution.

Regards,

- Scott

After downloading the latest version of Wubi for 10.10 and the latest 32-bit Ubuntu desktop release (10.10), I can verify that this issue still occurs. The above report refers to 10.04, but the behavior has not changed in the new release.

jahrra (jahrra) wrote :

Same problem here.

OS: Windows 7 64-Bit
Partitions: 1 System-reserved, 1 C:\, 1 D:\
Tested with: ubuntu-10.10-desktop-amd64.iso

After running the Wubi-Installer and rebooting, the setup-dialog stops at 271% and the error message pops up:
"No root file system is defined.
Please correct this from the partitioning menu"

So I booted the LiveCD and tried to run the installer from there. In the Live-Environment I can easily access the Windows-Partitions and GParted shows all the partitions, but when I start the installer, no hard drive appears in the "Allocate drive space"-dialog. Nevertheless I can choose "/dev/sda" to install the bootloader on. However when I click on "Install Now", the error message mentioned above occurs again (No root file system is defined ....).

fdisk provides additional information: It says that the "System-reserved"-Partition "does not end on cylinder boundary". (Screenshot attached)

I tried to access the Wubi-VirtualDisks from Windows to provide the requested logs using some ext2/ext3-drivers/explorers but without success. I can attach the logs from the LiveCD, if that helps.

Towards the end of the year I will reinstall Windows 7 and try to install without the "System-reserved"-Partition and see if that helps.

@thefons: afair Wubi does not support RAID

jahrra (jahrra) wrote :
jahrra (jahrra) wrote :
jahrra (jahrra) wrote :

same goes for me too.

i have windows xp installed on a 80 GB HDD that has two partitions C:\ and d:\ (c:\ is obviously the windows system drive). i have tried to install ubuntu 10.04 inside windows using wubi and also tried ubuntu 9.04 using wubi but to no avail...i just gives me the "no root file....." error (and the % is 271% too...donno what that means)

im new to ubuntu. i see this bug report started in 2008-08-19 (today=2010-11-05) thats like 2years+ and the bug is still in incomplete state. i want to know what the people who faced this problem did ---
 a) did you abandon ubuntu altogether?
 b) did you find a solution? if so what is that solution

Matt Warren (matt-warren) wrote :

I saw this error when trying to install Linux on my Windows 7 machine. Eventually I solved it.

My issue was that at some point the partition table had become corrupted - or mislabeled. The disk was labeled gpt but seemed to be actually using a standard mbr type layout. The tools fdisk, diskpart, gparted couldn't fix the problem for me.

I fixed it by booting into Linux Live USB, installing and using testdisk to analyse my hard drive and then re-write the partition table after confirming that it found all the partitions. Immediately after running this fix gparted could see the partitions on the disk.

TJ Rana (tjrana) wrote :

I'm getting this error when I try to install Ubuntu on my computer.

summary: - Wubi - "No root file system is defined" error
+ Wubi - "No root file system is defined" Error
TJ Rana (tjrana) wrote :

Why isn't this bug getting enough attention? This needs to be fixed!

Changed in wubi:
status: Incomplete → New
Changed in ubuntu:
status: Invalid → New
description: updated
Jeruvy (jeruvy) wrote :

I'm wondering if grub2/BCE isn't conflicting. Also I wonder i installing to a dynamic disk would be an issue?

astroshark (astroshark) wrote :

I think the main issue is that some of you are installing wubi on a RAID Array which is what I have so I decided to install on an external HDD through wubi and it worked.

Alessandro Avix (alex-avix) wrote :

I am installing 10.10 Desktop Amd64 on new machine bases on Nvidia chipset Mb Asus M3N78-EM with only one clean bard new disk Sata 320 Gb not in Raid mode connected in firs port Sata1. During installation I verified same error as others.

I tried to generate partitions with Gparted with boot flag and no improvement same result. Installer do not see any partition and give same error [No root file system is defined].

Appreciate further community investigation

Br Alessandro

bcbc (bcbc) wrote :

Installing Wubi on some raid setups seem to work fine. Others not. This is not likely a Wubi issue - maybe Ubiquity?
In some cases, there is raid metadata present even if there is no raid in use. This also seems to confuse things.
Another issue can be the mixture of GPT and MBR partition table data. Again, likely Ubiquity problem.

You cannot install on Windows 7 dynamic disks - because some of these are not in the partition table at all. Windows 7 actually rejects that within the Wubi install (Windows part) when you try and add a boot manager entry to BCD that refers to a dynamic disk. I believe it should work on any partition that is in the MBR (e.g. the partition for C:), but I would think it's dangerous to have C: mounted as a single partition in Ubuntu, whereas in Windows it's actually a number of separate dynamic partitions.

There are probably other causes of this error as well.

In general I recommend running the bootinfoscript ( http://bootinfoscript.sourceforge.net/ ) - see what it reports in terms of raid info, and it's fdisk output should show any leftover GPT information causing conflict.

But since these errors are being generated out of Ubiquity that's probably the project that needs to included. However since the bug is around since 2008 with no fix - and since there may be many separate problems with the same symptom, it's better to identify what your problem is and then create a new ubiquity bug for it.

Changed in ubuntu:
status: New → Incomplete
Changed in wubi:
status: New → Confirmed
Harvey Herman (hbherman) wrote :

I had the same problems that others described. The last thing I tried worked. As I made two changes, you pick the reason:
1. I put wubi.exe in c:\install Ubuntu
2. By accident I left the disk name instead of my choice.

There were lots of errors, but I continued on and rebooted, also with errors. The errors must self- correct, as now it works.
Of course, this method downloaded everything else from the Internet, so the problem could have been fixed there.
Windows 7 still works!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers