Country detection is wrong when country name is localized in the registry

Bug #223250 reported by Agostino Russo on 2008-04-27
12
Affects Status Importance Assigned to Milestone
Wubi
Medium
Agostino Russo

Bug Description

The country detection affects the timezone and locale. It reads sCountry from the registry but this string can be localized while the mapping expects English country names. Either add localized country names or use iCountry in the mapping.

Agostino Russo (ago) on 2008-04-27
Changed in wubi:
assignee: nobody → ago
importance: Undecided → Medium
status: New → Confirmed
Agostino Russo (ago) on 2008-04-28
Changed in wubi:
status: Confirmed → Fix Committed
  • unnamed Edit (1.3 KiB, text/html; charset=ISO-8859-1)

The preseed.cfg lists the following on line 138
d-i time/zone string America/St_Johns

I didn't reboot into the installer, but I'm pretty sure the time will
change.

On Mon, Apr 28, 2008 at 7:56 PM, Agostino Russo
agostino.russo-at-.........|launchpad| <
...> wrote:

> Please test http://wubi-installer.org/devel/minefield/Wubi-8.04-beta-
> rev503.exe<http://wubi-installer.org/devel/minefield/Wubi-8.04-beta-rev503.exe>
>
> --
> Country detection is wrong when country name is localized in the registry
> https://bugs.launchpad.net/bugs/223250
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Wubi, Windows Ubuntu Installer: Fix Committed
>
> Bug description:
> The country detection affects the timezone and locale. It reads sCountry
> from the registry but this string can be localized while the mapping expects
> English country names. Either add localized country names or use iCountry in
> the mapping.
>

Agostino Russo (ago) wrote :

Can you pls provide the wubi logs in your user temp folder (%temp%)

Agostino Russo (ago) wrote :

JcMarco, in your case I get

country=CA
GMT=-4

GMT comes from HKLM SYSTEM\CurrentControlSet\Control\TimeZoneInformation ActiveTimeBias
Canada with GMT of -4 gives me -4=America/St_Johns

Is the GMT incorrect in windows maybe? Use regedit to check the registry key above.

JcMaco (lqb5hzj02) wrote :

ActiveTimeBias is set to 0xf0
Bias is set to 0x12c
Daylight name is set to "Est (heure d'été)"
Standard name is set to "Est"

In normal time, GMT -4 does correspond to St_Johns, but during daylight savings it is EDT.

Agostino Russo (ago) on 2008-04-29
Changed in wubi:
milestone: none → 8.04.1
Agostino Russo (ago) wrote :

Maybe Bias should be used instead of ActiveTimeBias, that would set you to America/Montreal (GMT=-5)

Agostino Russo (ago) on 2008-05-02
Changed in wubi:
status: Fix Committed → Fix Released
Agostino Russo (ago) on 2008-05-04
Changed in wubi:
status: Fix Released → Fix Committed
Agostino Russo (ago) wrote :

Wubi rev503 should have fixed the issue, could you please test that and report here?

http://wubi-installer.org/devel/minefield/

Note that it requiries a new daily desktop 8.04.1 ISO.

Agostino Russo (ago) on 2008-06-27
Changed in wubi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers