install failed during "import document and setting" at 88% - French windows XP

Bug #222690 reported by verroitn on 2008-04-26
16
Affects Status Importance Assigned to Milestone
Wubi
High
Agostino Russo
migration-assistant (Ubuntu)
High
Evan
Hardy
Undecided
Unassigned
Intrepid
High
Evan

Bug Description

A bug in migration-assistant is preventing French users coming from Windows XP Home from installing Ubuntu via Wubi.

The problem occurs because migration-assistant is fed non-UTF data. The fix is to force the locale to C when using expr. There should be minimal to no possibility for regressions here, given the simplicity of the change.

TEST CASE:
Install Ubuntu using Wubi from a French copy of Windows XP Home Edition ("Windows XP Édition familiale"). The install will fail at the migration-assistant apply phase ("Import documents and settings" at 88%).

A patch for the uploaded change can be found here:
http://launchpadlibrarian.net/14796991/migration-assistant-0.6.1-0.6.3.debdiff

verroitn (nicolas-verroit) wrote :
verroitn (nicolas-verroit) wrote :
Arthur Schlomoff (arthur-sdp) wrote :

Same OS, with the "é"dition familiale, and same bug.

This bug seems to affect only french users, and then it might be connected with the "é" in the OS name.

Forum thread : http://ubuntuforums.org/showthread.php?t=767540

Arthur Schlomoff (arthur-sdp) wrote :
duanra (arnaud-debaize) wrote :

Exactly the same bug for me (using Wubi 8.04), trying to install Ubuntu 8.04 along with French-speaking "Windows XP Édition Familiale" (problem probably due to the É, since my user name doesn't contain any space or special character).

Here come the installation logs and the preseed.cfg file.

Agostino Russo (ago) on 2008-04-26
Changed in wubi:
assignee: nobody → ago
importance: Undecided → High
status: New → Confirmed
Evan (ev) on 2008-04-28
Changed in ubiquity:
assignee: nobody → evand
importance: Undecided → High
Evan (ev) wrote :

Could someone who is experiencing this problem please try the install again, switch to one of the virtual terminals when it is starting up (ctrl-alt-f2), run `sudo nano /usr/lib/ubiquity/migration-assistant/ma-apply` and stick set -x on the second line, then attach the logs as per usual when the installation fails.

Thanks very much!

Changed in ubiquity:
status: New → Incomplete
Evan (ev) wrote :

To clarify, you can switch to one of the VTs when you first see the installer window. You should have some time to do this as the code you're modifying executes after the file copy procedure, and that will take a little while.

duanra (arnaud-debaize) wrote :

I'd like to try your test, Evan, but I don't know how to resume the installation after I've "set -x" (until this point, all is OK). What command should I run ? Or do I have to restart the computer ? If yes, how ?

Duanra
PS : sorry if it seems "simple" questions, but I'm new to Ubuntu, and eager to learn more !

Zakhar (alainb06) wrote :

Duanra, nano is a small text editor.
I suppose Evan means adding "set -x" at the end of the second line, then save the file and exit the editor and you are done.
I do also suppose somewhere in the process (after copy) the ma-apply you modified is used to run the migration.

Anyway, I'll do the test in a while and let you know.

Zakhar (alainb06) wrote :

By the way 88% is for Ubuntu. Some report other percentages, and it's the same bug. For example with Kubuntu the bug happens at 83%, I suppose it depends on the amount of data you have to copy according to the distribution you choose !

Agostino Russo (ago) on 2008-04-29
Changed in wubi:
milestone: none → 8.04.1
Zakhar (alainb06) wrote :

Ok, so you said "stick set -x" on the second line, it's not very clear !

As we are French, could you use "Globish"... (eq very simple and not ambiguous words).

Stick, as I posted above, would have implied for me: add something to something existant, as when you stick a stamp on an enveloppe ;-)

So a little bit more details :
- first don't do the sudo nano immediately when the installer starts: I did it and got stuck in the middle of typing the command because the system apparently was doing some parallel task and output a startup instruction in the middle of the command line... then everything was blocked.

- so wait a moment before typing the command, I waited till the copy starts.

- open the file with nano
- HORROR !.. the second line appears to be completely blank. So following the instruction, I typed set -x on the second line of the file that was previously blank, that is

BEFORE
#! bash/.... (something I don't remember)

set -e

AFTER
#! bash/...
set -x
set -e

Ctrl O to save
Ctrl X to exit

Ctrl Alt F7 to go back to the installer (that I had to guess... and at the end got lucky after trying many combinations)

Wait for the bug.

Then here there is another bug, the message says the system will reboot once you click OK on the error message, but apparently it does not reboot.
So you have to power down manually the computer... and it appears sometimes the install-log.zip is not flushed to the NTFS partition and you got no log at all.

1st time = OK
2nd time = no log.

Reading the log I have the impression that it does not care with my set-x on the previously blank line (user.log)
I'll try a 3rd run with set -x on a new line after the line with set -e
And may be a fourth with a line:
set -e set -x

To avoid the "not flushing install-log" bug, the best thing I can think of is: wait for a moment after clicking OK on the error message... not very precise but I have no better idea !

Here is the first log

Zakhar (alainb06) wrote :

Nth try...

I NEVER have a log written !

But apparently I found a trick to get it written (I got on that randomly while typing on every key to switch to the installer).
Before going OK on the error message I do Ctrl Alt F1.
It writes "Loading please wait..." eventually it would try to boot to the system that is constructed and not succeed... but it writes the log !

This stuff must force some I/O on the disk and do the trick.

So that is the log with :

#!/bin/sh

set -e
set -x

Do you need another like let say :
#!/bin/sh

set -e -x

Or was one of the two logs what you expected ?

duanra (arnaud-debaize) wrote :

Here are the installation-logs you asked, Evan.

I made them by changing the sudo thing with :

(...)
set -x (this is the only line I added)
set -e

I well encountered the bug at 88%, restarted all right, and here are the logs.

I hope this is what you need.

Duanra

duanra (arnaud-debaize) wrote :

Here are the "modified" installation-logs for my other computer (desktop).

Modified with

#!/bin/sh
set -e
set -x

(...)

Now there is work to be done ;-)

Duanra

Evan (ev) wrote :

Terribly sorry about the ambiguous language. Thanks to everyone for your log files, I think I have this fixed in migration-assistant trunk and will propose it for Ubuntu 8.04.1.

Changed in migration-assistant:
status: Incomplete → Fix Committed
Agostino Russo (ago) wrote :

Marking as invalid for Wubi since the fix involves migration-assistant (and it is on its way :). Not much to do on the Wubi side.

Changed in wubi:
status: Confirmed → Invalid
Evan (ev) wrote :
description: updated
Evan (ev) on 2008-05-29
description: updated
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in migration-assistant:
status: New → Fix Committed
verroitn (nicolas-verroit) wrote :

Hello,

I'm available to test the fix but I don't know what to do with the file "migration-assistant-0.6.1-0.6.3.debdiff". Can you give me a more detailed explanation or a link to a methodology ? Thanks in advance

Evan (ev) wrote :

verroitn,

Please wait for the 8.04.1 candidate CDs to be generated. I do not have an estimate of when that will be.

Thanks!

hardy test CD images are now available which include the updated installer
components that address this bug:

  http://cdimage.ubuntu.com/hardy/daily/20080612.4/

Please test these images and report your results so we can verify whether
this bug is fixed.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

verroitn (nicolas-verroit) wrote :

I've just tested the latest version of wubi and the bug is corrected
  ==> http://wubi-installer.org/devel/minefield/Wubi-8.04.1-rev503.exe
  ==> wait for automatic download of the latest 8.04.1 ISO
  ==> restart
  ==> the installation goes to the end with no error message

thanks for the work.

Martin Pitt (pitti) wrote :

Thanks for testing!

Martin Pitt (pitti) wrote :

According to the changelog, this is fixed in Intrepid:

migration-assistant (0.6.2) intrepid; urgency=low

  * Several fixes from Olivier Blin of Mandriva:
    - Close file descriptors when they're no longer needed.
    - Move a closedir() call, it can free data returned by readdir() too
      early. It leads to path corruption in some cases.
    - Fix a segfault with files with no extension.
    - Remove a spurious directory creation, with uninitialized name.
    - Fix Windows 2000 migration, by not trying to import music if not
      present.
    - Fix detection of Windows-NT-like registry path in ma-search-users, by
      splitting and reusing WINNT code from utils.c
    - Reimplement copy using read/write (like cp) to handle large files,
      since we can't mmap() (twice) large files in memory.
    - fix segfault by zeroing buffers for strcat.
    - Improve WINNT patch to factorize user registry location as well.
    - Vista profile directories support. Get profiles directory from
      registry for ma-search-items and ma-import as well ("Documents and
      Settings" is not correct in Vista), this also allows us to read the
      user registries.
    - Vista users support. Filter Public and Default users for Vista (from
      registry keys). Filter "Default User" key in Vista (it is a junction
      to Default). Do not segfault if keys are missing.
  * More efficient and less error-prone device substring extraction.
  * Set the locale to C when using expr.

 -- Evan Dandrea < <email address hidden>> Tue, 27 May 2008 14:07:31 -0400

Changed in migration-assistant:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in migration-assistant:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers