Wubi does not support http proxy

Bug #135815 reported by freechelmi on 2007-08-30
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Wubi
Wishlist
Hampus Wessman

Bug Description

Wubi could detect IE/mozilla proxy setting and pass them to the metalink downloader ( if it supports http proxy ) .
- A quicker trick could be to give a dialog box to the user in case of failed downloading , so he can specify the http proxy.
- Another way could be to let Wubi use a copy of the alternate iso on the hard drive instead of trying to download it.

Changed in wubi:
status: New → Confirmed
freechelmi (michel-memeteau) wrote :

WorkAround : Download the alternate CD of your choice, launch Wubi which will fail to download, copy your ISO in C:\wubi\install , relaunch Wubi installer : it will verify the checksum of the iso file and start installing. Enjoy your Ubuntu easily at work !!

Hampus Wessman (hw-vox) wrote :

The download plugin should of course be able to detect proxy settings. I have no idea how to do that, so I'll have to find out first... The mentioned workaround is a good alternative until then! Thanks for reporting the bug!

Changed in wubi:
assignee: nobody → hw-vox
Agostino Russo (ago) wrote :

We should have an option --http-proxy= to pass to metadl

Changed in wubi:
importance: Undecided → Medium
Agostino Russo (ago) wrote :

I guess that is just as easy to pre-download the ISO than to use --proxy commandline argument. If you bumb into this simple grab the required DESKTOP ISO and put it in the same folder as Wubi.exe.

Changed in wubi:
importance: Medium → Wishlist
StSz (stsz) wrote :

Lookup the MSDN documentation for InternetGetProxyInfo from wininet. You need to load the JSProxy.dll dynamically. This will work starting from IE 5, and should also run with Win9x.

If you dump Win9x support, you can use the more advanced WinHTTP, look for WinHttpGetProxyForUrl or WinHttpGetIEProxyConfigForCurrentUser. The first is recommended since it handles WPAD scripts correctly.

Hampus Wessman (hw-vox) wrote :

Thanks, we'll do that!

petski (petski) wrote :

Meanwhile, it might be a good idea to add comment 1 of this bug (https://bugs.launchpad.net/wubi/+bug/135815/comments/1) to the FAQ (http://wubi-installer.org/faq.php)

petski (petski) wrote :

I actually needed a different approach compared to the suggestion in comment 1. When I used ubuntu-8.04-alternate-i386.iso, /ubuntu/install/boot/vmlinuz wasn't created (might be a bug?). After reboot, this resulted in a complaining grub (find --set-root --ignore-floppies /ubuntu/install/boot/vmlinuz)

Here's what I did: I've downloaded both Wubi-8.04.exe and ubuntu-8.04-desktop-i386.iso (desktop!) into the same directory, and executed Wubi-8.04.exe.

Ferk (ferkiwi) wrote :

It's been almost 5 years since the last comment, none of the approaches to workaround the issue work now.

Wubi.exe will now uninstall any previous trace of unfinished download, so it won't use the install folder where it downloads the iso to. And it doesn't seem to look for the iso when I put it in the same directory.

Any advice? There should be a way to install Ubuntu using wubi in a computer without internet or through proxy

Michel-Ekimia (michel.ekimia) wrote :

Anybody worked on this since 2008 ?

Michel-Ekimia (michel.ekimia) wrote :

Well I just tried with the lastest Wubi from ubuntu.com , and it detected and downloaded the needed components without a problem.

I think we could close this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers