Wubi should propose a hard install DualBoot mode

Bug #1296692 reported by Michel-Ekimia on 2014-03-24
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Wubi
Wishlist
Unassigned

Bug Description

Wubi is useful for installating in virtual NTFS/FAT32 files but in most cases a hard install with Windows partition resize is a better option.

Proposed solution:

- Propose a new mode "Hard disk DualBoot" where the user should choose how much space Ubuntu can use on his Harddisk ( default? leave 10 Go to windows)

- Download the iso or find it/select it.

- Boot the iso with NTLDR/grub4dos or UEFI in Toram mode so the windows partitions can be easily ( and automatically ) partitionned.

- Unmount manually the windows partition as in https://bugs.launchpad.net/ubuntu/+source/casper/+bug/684280

- Carry on the installation until the end

All this is already done by the win32 loader from debian with Success.

this feature is IMO essential to help people to migrate from Win7 to Ubuntu after the 14/01/20.

Changed in wubi:
status: New → Confirmed
varunendra (varunendra) wrote :

The idea strikes me, but my prime focus would be on protecting the existing (Windows) installation, preferably involving external boot/backup media. Perhaps such a thing can be a good replacement for WUBI, since it has become obsolete with Windows 8.

The number and nature of problem threads on UF regarding dual-boots clearly indicate that current installer is not as "idiot-proof" as it should be.

For now, I'm just quoting what I posted on the thread where this discussion started (http://ubuntuforums.org/showpost.php?p=12966322), I'd be interested to see if a developer shows interest, in which case I'd like to post more discrete points regarding the idea :

"my prime focus would be on -

- Ways to protect user's existing installation (Windows) and easy ways to revert back if something goes wrong or they otherwise need/want so.

- It should be something both easy (transparent if possible), reliable and effective.

- It should be designed while keeping in mind that most Windows users don't really read Warnings/Cautions. They always look for "Next" or "Ok" buttons, and that's the only thing they usually notice and use on a dialogue-box - most often without paying attention to Warnings/Notifications about consequences."

In fact, I think the above should be considered anyway, to improve the default installer if not to create something new (or modify WUBI itself).

It's an idea for a new feature.

Changed in wubi:
importance: Undecided → Wishlist

Since what you submitted is not really a bug, or a problem, but rather an idea to improve Ubuntu, you are invited to post your idea in Ubuntu Brainstorm at http://brainstorm.ubuntu.com/ where it can be discussed, voted by the community and reviewed by developers.

Changed in wubi:
status: Confirmed → Invalid
Michel-Ekimia (michel.ekimia) wrote :

@alberto :
ok For brainstorm but please don't flag this as invalid, launchpad should still be feature request system, and my feature relayy fills in well in Wubi

Colin Watson (cjwatson) wrote :

Um, brainstorm has been decommissioned. Continuing to refer people to it isn't terribly sensible.

Changed in wubi:
status: Invalid → Triaged
varunendra (varunendra) wrote :

I agree with the "Wishlist" part - that's what it is. But brainstorm never really served its purpose as far as I know. It was (is) like sending 'unwanted' people/ideas to a blackhole. :)

Michel-Ekimia (michel.ekimia) wrote :

Just a comment : the Debian team has successfully created a Windows installer that does a DualBoot in a few clicks.

https://wiki.debian.org/DebianInstaller/Loader

We could fork this tool to create the Ubuntu flavor or patch wubi, what do you think might be the quickest scenario ?

description: updated
tags: added: focal
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers