Wubi, Windows Ubuntu Installer

13.04 installer doesn't create user account

Reported by John McCourt on 2013-03-15
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Wubi
High
Unassigned

Bug Description

I've tried installing Ubuntu using the the Wubi.exe package that comes with the ISO for 13.04 (Curently at beta). After the install took place I rebooted my computer and Ubuntu started. However, I only had access to the guest account. The installer did not create my user. This was shown clearly when I did cat /etc/passwd and my user account did not appear on the list of users.

This may be because I'm using a test iso. Maybe when the final version is released it will work as expected?

I'm an experienced Ubuntu user and can add more information if requested.

Related branches

Could you attach /var/log/installer/syslog?

bcbc (bcbc) on 2013-03-16
Changed in wubi:
status: New → Confirmed
bcbc (bcbc) wrote :

I just reproduced this. There is no /var/log/installer directory (is that just for ubiquity - because this is a disk image install). I'll attach all the other logs. It complained "mount: can't read /proc/mounts: no such file or directory" on boot.

The C:\ubuntu\install\preseed.cfg file:
d-i clock-setup/utc boolean false
d-i time/zone string America/Vancouver
d-i passwd/user-fullname string Bcbc
d-i passwd/username string bcbc
d-i passwd/user-password-crypted password xxx
d-i user-setup/encrypt-home boolean false
d-i netcfg/get_hostname string ubuntu
d-i debian-installer/locale string en_US.UTF-8
d-i keyboard-configuration/layoutcode string us
d-i keyboard-configuration/variantcode string

bcbc (bcbc) wrote :

PS there is also no /boot/grub/grub.cfg file created. So it looks like none of the diskimage setup is happening.

The wubildr-disk.cfg file (looks normal):
loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
search --set=diskroot -f -n /ubuntu/disks/root.disk
probe --set=diskuuid -u $diskroot
linux /vmlinuz root=UUID=$diskuuid loop=/ubuntu/disks/root.disk preseed/file=/ubuntu/install/preseed.cfg wubi-diskimage ro quiet splash
initrd /initrd.img
boot

bcbc (bcbc) wrote :

PPS since it complained about /proc/mounts missing, I created it (loop mounted from another install). Then it said:
error: can't find / in /proc/mounts

Same result. (Not that I expected it to work). I also briefly compared the uncompressed disk image to a working install wubi root.disk and nothing really stood out as different - few things, but nothing that seemed to be an answer.

Changed in wubi:
importance: Undecided → High
Colin Watson (cjwatson) wrote :

Sorry, I'd forgotten about the diskimage installs. I think the Wubi log is in the Windows temporary directory - could you look there?

bcbc (bcbc) wrote :
bcbc (bcbc) wrote :

As a comparison, here are the logs for a 12.10 disk image install after first boot into Ubuntu (maybe there are some clues here if the Wubi log in Windows doesn't show anything of use).

Demortes (demortes) wrote :

Wanted to comment a "me too" with my log. Install happened 04/16/2013 @ 11:15pm. Attached is my log.

One thing to note, even though I launched it from the ISO, it had to download another file. It was mounted through Windows 8 mounting mechanism.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers