Wubi, Windows Ubuntu Installer

Install fails with error: "Extraction failed with code: 2" (update: seems ok after retrying)

Reported by Dandromb on 2012-07-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Wubi
Medium
Unassigned

Bug Description

*** Edit: I have tried again, and reached the "Reboot Now / Reboot Later" screen. That means all is going well this time. I can update later if this install fails. I may not update quickly, as I am going to check out Ubuntu for a while if it installs correctly. Thanks Wubi team for your work on the Wubi tool. I hope to get back to this bug post at a later time. ***

*** Confirming that my Ubuntu works as of second attempt. ***

I am trying to install Ubuntu on my windows Vista PC but after about 30 minutes, I get an error message:

"Extraction failed with code: 2", with a pointer to the log file.
Please find below the relevant extract from wubi-12.04-rev266.log.
thank you
DanD

07-29 16:28 DEBUG TaskList: ### Running download...
07-29 16:28 DEBUG downloader: downloading http://releases.ubuntu.com/12.04/ubuntu-12.04-wubi-amd64.tar.xz > C:\ubuntu\disks\ubuntu-12.04-wubi-amd64.tar.xz
07-29 16:28 DEBUG downloader: Download start filename=C:\ubuntu\disks\ubuntu-12.04-wubi-amd64.tar.xz, url=http://releases.ubuntu.com/12.04/ubuntu-12.04-wubi-amd64.tar.xz, basename=ubuntu-12.04-wubi-amd64.tar.xz, length=512730488, text=None
07-29 17:18 DEBUG downloader: download finished (read 380523926 bytes)
07-29 17:18 DEBUG TaskList: ### Finished download
07-29 17:18 DEBUG TaskList: ## Finished get_diskimage
07-29 17:18 DEBUG TaskList: ## Running extract_diskimage...
07-29 17:19 ERROR TaskList: Extraction failed with code: 2
Traceback (most recent call last):
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\win32\backend.py", line 450, in extract_diskimage
Exception: Extraction failed with code: 2
07-29 17:19 DEBUG TaskList: # Cancelling tasklist
07-29 17:19 DEBUG TaskList: # Finished tasklist

Dandromb (dandromb) wrote :
Dandromb (dandromb) on 2012-07-29
description: updated
summary: - Install fails with error: "Extraction failed with code: 2"
+ Install fails with error: "Extraction failed with code: 2" (update:
+ seems ok after retrying)
bcbc (bcbc) wrote :

It didn't download the preinstalled image properly. You should have 489MB not 362MB (380523926 byes). The installer should probably recognize this instead of trying to proceed.

So as a workaround, you could try again (probably some network error that stopped it fully downloading), or manually download the target file (see here for instructions how to use it: http://askubuntu.com/a/143478/14916 ), or download the desktop cd ISO instead (save in same folder as wubi.exe before running).

Changed in wubi:
status: New → Triaged
importance: Undecided → Medium
tags: added: precise
Dandromb (dandromb) on 2012-08-01
description: updated
Fabio Marconi (fabiomarconi) wrote :

16:22 DEBUG downloader: download finished (read 403720968 bytes)
03-31 16:22 DEBUG TaskList: ### Finished download
03-31 16:22 DEBUG TaskList: ## Finished get_diskimage
03-31 16:22 DEBUG TaskList: ## Running extract_diskimage...
03-31 16:23 ERROR TaskList: Extraction failed with code: 2
Traceback (most recent call last):
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\win32\backend.py", line 450, in extract_diskimage
Exception: Extraction failed with code: 2
03-31 16:23 DEBUG TaskList: # Cancelling tasklist
03-31 16:23 ERROR root: Extraction failed with code: 2
Traceback (most recent call last):
  File "\lib\wubi\application.py", line 58, in run
  File "\lib\wubi\application.py", line 132, in select_task
  File "\lib\wubi\application.py", line 158, in run_installer
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\win32\backend.py", line 450, in extract_diskimage
Exception: Extraction failed with code: 2

tags: added: raring
Fabio Marconi (fabiomarconi) wrote :

#3 ^^ is referred to wubi-13.04-rev275

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1030631

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers