Cubic-splines cause non-function progess graphs, use B-Spline instead

Bug #884706 reported by Julien
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Weight Tracker ODS
High
Jon Thysell

Bug Description

The progress chart of my weight log showed a measured weight curve that was not a function of the time, looping and backtracking. This is due to the automatic smoothing in the ProgressChart graph, which uses cubic-splines. See attached screenshot 1.

This behaviour is fixed by un-protecting the cell, right-clicking on the weight line, "Chart Type"/"Smooth Line Properties" and checking "B-spline" instead of "Cubic splines": B-splines are an approximation of a real-value function from R to R, hence respect the "no-backtrack on X-axis", while cubic-splines are an of a parametrized curve from R to R^2, not guaranteeing the "no-backtrack on X-axis".
See attached screenshot 2.

Dataset causing problem was having a whole 15 days of missing data due to holidays:
85.0
Empty
85.0
Empty
84.0
84.2
Empty
84.1
83.8
83.3
82.8
82.4
81.5
81.8
82.3
82.1
Then 16 Empty entries
83.1
81.6
82.0
81.9
81.7
81.4

Related branches

Revision history for this message
Julien (jucor) wrote :
Revision history for this message
Julien (jucor) wrote :

Additional precision: B-splines of order > 1 do not pass exactly by the points, on the countrary to the cubic spline approximation. Even so, I'd rather have a non-smoothed measured weight curve than a time-travelling curve, since the other curve gives the smoothed trend anyways.

Jon Thysell (jonthysell)
Changed in wtods:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Jon Thysell (jonthysell)
milestone: none → 2.2.3
status: Confirmed → Triaged
Jon Thysell (jonthysell)
Changed in wtods:
status: Triaged → Fix Committed
Jon Thysell (jonthysell)
Changed in wtods:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers