Woda, the Web Oriented DAtabase

no need to define ICONURL into cgiStyleDocsSample and wbError

Reported by Xavier Brochard on 2010-03-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Woda
Low
Unassigned

Bug Description

in cgiStyleDocsSample no need to hard coding ICONURL, it works perfectly without this line:
$ICONURL = "/icons/default"; # why is it hard encoded ?

in wbError ICONURL is further defined before call to printFoot()
    $ICONURL = $ICONURL || '/icons/default';

Related branches

lp:~xavier/woda/4.620
Merged into lp:woda at revision 136
Woda: Pending requested 2012-02-06

On 23/03/2010, at 4:02 AM, Xavier Brochard wrote:

> Public bug reported:
>
> in cgiStyleDocsSample no need to hard coding ICONURL, it works perfectly without this line:
> $ICONURL = "/icons/default"; # why is it hard encoded ?
>
> in wbError ICONURL is further defined before call to printFoot()
> $ICONURL = $ICONURL || '/icons/default';

This code only ever worked on rent-a-database.com. It's probably a quick-fix that was never cleaned up.

Malcolm

Xavier Brochard (xavier) wrote :

Le Lundi 22 Mars 2010 23:43:04, vous avez écrit :
> On 23/03/2010, at 4:02 AM, Xavier Brochard wrote:
> > Public bug reported:
> >
> > in cgiStyleDocsSample no need to hard coding ICONURL, it works perfectly
> > without this line: $ICONURL = "/icons/default"; # why is it hard encoded
> > ?
> >
> > in wbError ICONURL is further defined before call to printFoot()
> >
> > $ICONURL = $ICONURL || '/icons/default';
>
> This code only ever worked on rent-a-database.com. It's probably a
> quick-fix that was never cleaned up.

I'm not sure for wbError
because a few lines upon there is a commented call to mainDefaults() to fix
ICONURL. Can ICONURL be undefined sometimes ?

Xavier
<email address hidden> - 09 54 06 16 26

On 23/03/2010, at 10:32 AM, Xavier Brochard wrote:

> Le Lundi 22 Mars 2010 23:43:04, vous avez écrit :
>> On 23/03/2010, at 4:02 AM, Xavier Brochard wrote:
>>> Public bug reported:
>>>
>>> in cgiStyleDocsSample no need to hard coding ICONURL, it works perfectly
>>> without this line: $ICONURL = "/icons/default"; # why is it hard encoded
>>> ?
>>>
>>> in wbError ICONURL is further defined before call to printFoot()
>>>
>>> $ICONURL = $ICONURL || '/icons/default';
>>
>> This code only ever worked on rent-a-database.com. It's probably a
>> quick-fix that was never cleaned up.
>
> I'm not sure for wbError
> because a few lines upon there is a commented call to mainDefaults() to fix
> ICONURL. Can ICONURL be undefined sometimes ?

I remember a time when I saw an error message for ICONURL on my installations. It has been such a long time since I've seen it. mainDefaults() handles all that now.

Malcolm

Xavier Brochard (xavier) on 2012-01-04
Changed in woda:
importance: Undecided → Low
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers