Indicator Positioning Is Screwy

Bug #1084825 reported by Cassidy James Blaede
90
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Wingpanel
Fix Released
Medium
Victor Martinez

Bug Description

See http://youtu.be/Fbx1_a7lvVE, especially at 6 seconds in. Oftentimes indicators show up in the wrong position. This isn't just the arrows being a little off, this is the whole indicator being in the wrong spot.

Related branches

Changed in wingpanel:
milestone: none → luna-beta2
importance: Undecided → Medium
Revision history for this message
bwat47 (bwat47) wrote :

Yeah I see the bug at ~6 seconds in where the whole menu is in the wrong position very often

Revision history for this message
Danielle Foré (danrabbit) wrote :

Can anyone re-confirm? This may have been fixed recently.

Changed in wingpanel:
status: New → Confirmed
status: Confirmed → Incomplete
Changed in wingpanel:
milestone: luna-beta2 → luna-beta3
Revision history for this message
Matt Nelson (lemmnelson) wrote :

Not fixed for me yet, my indicators still show up in the wrong position.

Cody Garver (codygarver)
Changed in wingpanel:
status: Incomplete → Confirmed
Revision history for this message
Viktor Basso (viktor-basso) wrote :

For me the indicator offset starts after 5 icons starting from the right, from 6 and out the arrow is off center.

Revision history for this message
Cody Garver (codygarver) wrote :

To reproduce this:

start gtk-redshift
killall wingpanel
observe that the indicator order has changed

Changed in wingpanel:
assignee: nobody → Victor (victored)
Revision history for this message
Victor Martinez (victored) wrote :

The sorting function is not stable. Working on that.

Changed in wingpanel:
status: Confirmed → In Progress
Cody Garver (codygarver)
Changed in wingpanel:
status: In Progress → Fix Released
milestone: luna-beta3 → luna-beta2
Revision history for this message
bwat47 (bwat47) wrote :

I still see this issue on a fully updated beta 2 install. Happens extremely often with the battery indicator.

Revision history for this message
Harald Glatt (hachre) wrote :

I'm still seeing this issue as well, this is definitely not fixed or a regression.

Revision history for this message
bwat47 (bwat47) wrote :

There appears to be two totally different bugs being discussed in this report...

Cassidey's original report description, and the youtube video in the description clearly seem to be about the indicator MENUS showing in the "wrong position" (they often get offset to far to the right, so the indicator menu gets cut off on the right), and then the other comments seem to be discussing the order or the actual indicator icons themselves.

Is there an actual bug report for the long running indicator menu offset bug? If so there really should be, because that one is definitely not fixed (although the order of the indicator icons bug is).

Revision history for this message
Harald Glatt (hachre) wrote :

Ok, just to be clear: My comment was about the original bug that was discussed here and shown in the video (the menu offset bug)

Revision history for this message
Cody Garver (codygarver) wrote :

You guys are talking about bug #1007630.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers