Wine doesn't have a Tango icon

Bug #358645 reported by Pascal de Bruijn on 2009-04-09
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Wine
Fix Released
Wishlist
wine (Ubuntu)
Medium
Scott Ritchie

Bug Description

The current wine icon, is ugly, and not Tango compliant.

A replacement icon has already been made, which is _much_ better than the old one:

http://lists.freedesktop.org/archives/tango-artists/2006-March/000307.html
http://lists.freedesktop.org/archives/tango-artists/attachments/20060331/63117187/wine.png
http://lists.freedesktop.org/archives/tango-artists/attachments/20060331/63117187/wine.svg

Is there any chance the wine icon could be replaced with this one?

Nominating for 1.0.0. Quite a few built in tools aren't well known (control panel, winemine, etc) and would benefit from having an icon/shortcut to use them in the menu.

Might help to set the flag.

Created an attachment (id=10464)
wineconfig

Is this a decent icon for wineconfig?

Created an attachment (id=10465)
the svg

Incidentally, are icons for winemine, etc. supposed to be very simplistic (and have that weird green background)?

I would think they could be made to look more interesting.

In , Dan Kegel (dank) wrote :

Older than 90 days, no change in 30 days, seems difficult or unlikely to fix by 1.0 -> deferring to 1.2.

Many of the icons are done.

I will note, however, that most users shouldn't see these icons once we fix the UI with the improvements planned at Wineconf 08. The one possible exception is the notepad and wordpad icons.

Pascal de Bruijn (pmjdebruijn) wrote :

The current wine icon, is ugly, and not Tango compliant.

A replacement icon has already been made, which is _much_ better than the old one:

http://lists.freedesktop.org/archives/tango-artists/2006-March/000307.html
http://lists.freedesktop.org/archives/tango-artists/attachments/20060331/63117187/wine.png
http://lists.freedesktop.org/archives/tango-artists/attachments/20060331/63117187/wine.svg

Is there any chance the wine icon could be replaced with this one?

Scott Ritchie (scottritchie) wrote :

Thank you for reporting!

I've brought this up on the Wine mailing list. Personally, I'd like to see a red wine glass with a slightly narrower bowl ("bordeaux" style rather than "burgundy" style), but in any case the icon should be updated to be Tango compliant. I'll introduce this change (with whatever the icon ends up being) when I merge Wine 1.2 and the other Wine integration-projects in to Ubuntu.

Changed in wine (Ubuntu):
assignee: nobody → scottritchie
importance: Undecided → Medium
status: New → Triaged
Scott Ritchie (scottritchie) wrote :

So it seems like there's a complete set of high quality tango icons already in the ubuntustudio-icon-theme package. I wonder why no one ever told me about that before.

Anyway, I'll use those.

Changed in wine:
status: Unknown → Confirmed
Pascal de Bruijn (pmjdebruijn) wrote :

To be honest, the I don't very much like the new upstream icons for Wine, they're only slightly better than the old upstream icons, and aren't Tango compliant.

Scott Ritchie (scottritchie) wrote :

Pascal, what do you think of the ubuntustudio icons? I'm pretty sure they're Tango compliant and would fit in very well. From my talk on wine-devel, I believe they'll have a good chance going upstream as well (excepting a possible LGPL vs CC-by-SA licensing issue)

Pascal de Bruijn (pmjdebruijn) wrote :

The UbuntuStudio aren't are pretty nice, and as far as I can see, it's a complete set, provider icons for the utilities as well.

It's definitely a welcome change!

Pascal de Bruijn (pmjdebruijn) wrote :

(Forgot to check what I'd written before posting)

The UbuntuStudio icons are pretty nice, and as far as I can see, it's a complete set, providing icons for the wine utilities as well.

It's definitely a welcome change!

wine version 1.1.32. Still no icons...

Savvas Radevic (medigeek) wrote :

Hm.. the logo in the "About" dialog of "winecfg" seems to be the old version. I found the new one here:
http://www.airwebreathe.org.uk/wine-icon/idb_wine.png

old one:
http://www.airwebreathe.org.uk/wine-icon/idb_wine-orig.png

Is this forgotten or just not updated?

Savvas Radevic (medigeek) wrote :

> Is this forgotten or just not updated?
I mean... I don't know if the about logo is in the source code or not. :)

wine 1.2-rc4, there are icons for winecfg, wine software uninstaller, wine worpad, wine help, wine file regedit, and notepad.

missing icons:
Wine OLE View
Wine Boot

if there is no intention to provide icon for these menu items, you can close this bug.

Does this issue occur in newest WINE?

Thank you for reporting this bug.

Does this occur in newest WINE?

(In reply to comment #10)
> Does this issue occur in newest WINE?

please read my previous comment, because i answerd this question long before you asked your question.
nothing has changed with the icons from wine 1.2-rc4, as you can tell by the commit log.

Changed in wine:
importance: Unknown → Wishlist

Removing deprecated 'All' Platform.

Changed in wine (Ubuntu):
status: Triaged → Fix Released

There's no reason to have icons for wineboot or oleview, they aren't meant for users.

In , Elad-p (elad-p) wrote :

(In reply to comment #13)
> There's no reason to have icons for wineboot or oleview, they aren't meant for
> users.
I agree, in this case, this bug should be closed.

In related (although of topic for this specific bugzilla) note, Andreas, please remove the wineboot and oleview desktop files from the Fedora packages.

Closing bugs fixed in 1.5.0.

Really closing bugs fixed in 1.5.0.

Changed in wine:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.