Image Writer for Windows

Error 121: The semaphore timeout period has expired

Reported by Kevin on 2012-12-06
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Image Writer
Undecided
Unassigned

Bug Description

When attempting to backup an existing SDcard I get this error:

http://i.imgur.com/HWD5w.png

This happens all the time...and is on images that I have successfully written to from the same machine to the same card. I just need to now be able to backup what is on the card to restore later if needed.

Win32 version 0.6
Win7 Pro 64bit
Images are Raspbian OS images

I have tried other versions of Win32imagewriter with same effects. I have even tried reading the image using a SDCard full card in the same computers SDcard slot.

Tobin Davis (gruemaster) wrote :

I need more information.

What type of memory device are you reading from (SD, USB, etc)?
Size?
If SD;
     what class (I highly recommend class 6 or better)?
     what type of reader (USB, Built-in)?
     model of the system you are using (I can usually discover the specs on the SD reader from this)?

Changed in win32-image-writer:
status: New → Incomplete
Jeff B (skydiver38) wrote :

This: http://www.sevenforums.com/crashes-debugging/197480-error-0x80070079-semaphore-timeout-period-has-expired-2.html

(last comment in thread)

indicates running chkdsk as admin cleared up the problem for them.

same idea here: http://www.tomshardware.com/forum/279437-32-hard-drive-error-semaphore-timeout-period-expired

Another link: http://social.technet.microsoft.com/Forums/en-US/itprovistanetworking/thread/c3fc9f5d-c073-4a9f-bb3d-b7bb8f893f78

indicates that motherboard updates fixed it for some people, and also mentions the chkdsk fix (IIRC). (Look towards the bottom for recent comments) - one of the ideas being that drivers are out of date (in your case, the USB drivers).

Are you running as admin when you see the problem?

Jeff B (skydiver38) wrote :

At any rate, I don't think it's a Win32DiskImager problem - it's a systemic thing.

Changed in win32-image-writer:
status: Incomplete → Opinion
status: Opinion → Invalid
Kaare Mai (kmai) wrote :

I don't see how chkdsk can help in this situation. The SD card is formatted with a linux file system that windows is unable to read.

I have the exact same problem.

Im using a class 4 SD card which i wrote with win32diskimager. But if i try to read it i get the error semaphore error. I'm running win32diskimager as admin.

Kaare Mai (kmai) wrote :

I can confirm that this is a system problem and not a problem with win32diskimager in itself. I just tried reading the card with dd for windows and got the exact same error.

What can be the cause for this?

Tobin Davis (gruemaster) wrote :

That is a confusing problem. Not sure, but I found a program for reinitializing SD cards. https://www.sdcard.org/downloads/formatter_3/

Might give that a try and see if it fixes the problem. Other than that, maybe google for the error and see what else pops up.

Who knows, maybe we've uncovered a new Windows bug.

Kaare Mai (kmai) wrote :

Just found out that it works when using a class 10 SD card. If i use my class 4 SD card i get the error.

Tobin Davis (gruemaster) wrote :

That is very interesting. I have tested this program on a multitude of usb drives and SD/uSD cards (from 128M no class to 16G Class 10 SDHC) and never saw this issue. Of course, I only have one card reader (Sony MRW62E if you are interested).

Good to know that it was a card speed issue. Will test again on one of my 4G Class 4 cards to see if I can reproduce this, just in case.

Jeff B (skydiver38) wrote :

One of the things mentioned in the links I posted was that bad sectors can cause windows to hang, which induces a timeout. But, once things started pointing to it being systemic, and not an issue with imagewriter, I didn't delve too much deeper.

Lukas (lukas-spiess) wrote :

I just got this error when trying to write a FreeNAS image on to an 16GB USB 3.0 Stick which was plugged into a USB 2 port on my Windows PC.
Did you make any progress investigating this issue since the last post here or can I be of any assistance in providing further information?

Jeff B (skydiver38) wrote :

I can't speak for Tobin, but I haven't looked at it since it was determined to be an OS issue rather than an application issue.

You're seeing the issue during a write to a device, versus a read from a device?

Lukas (lukas-spiess) wrote :

Yes, I saw this during writing to the flash drive. My first suspicion was that it might have something to do with the thing of using a USB 3 device on a USB 2 port but I really don't know enough about USB to make that a valid assumption.
Also, I tried copying the image to the flash drive using dd on a Mac but my home server wasn't able to boot from it, whereas this process worked completely fine on a "normal" USB 2 flash drive using the same dd command.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers