an error occurred when attempting to write data from handle, error 23

Bug #1032031 reported by Dave on 2012-08-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Image Writer
Undecided
Unassigned

Bug Description

Win7x64, Asus laptop, WIn32DiskImager 0.6, Image from 2012-07-15-wheezy-raspbian.zip

Can't get Win32DiskImager to run; am trying to write Raspverry PI image to 32G SD card

I plug in the SD card & windows recognizes it; shows up as K:
When I start Win32DiskImager, I get the error about querying properties

If I eject K:, then Win32DiskImager does not see the SD card

After ignoring the query error, I select K: and the .img file. I then get:

An error occurred when attempting to write data from handle
Error 23: Data error (cyclic redundance check)

If I run "as administrator", I get:
An error occurred when attempting to lock the volume
Error 5: Access is denied

Looks like I need to Google for another app to write the image to the SD card

Tobin Davis (gruemaster) wrote :

This is a new one on me, but it could possibly be related to the newer SD support in Vista/7 and newer systems. I'll see if I can reproduce this on a work system.

Changed in win32-image-writer:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Tobin Davis (gruemaster)
Tobin Davis (gruemaster) wrote :

The program should always run as administrator, as it is working with raw devices. I have seen the error 5 issue, but that is (I believe) related to Windows having another process accessing the device (even a windows subsystem app). Removing and re-inserting the device has worked for me in this case.

The Error 23 is a new one on me. Will see if I can reproduce on a system w/o admin rights.

Tobin Davis (gruemaster) wrote :

I have not made any more progress on this. Wish I had better news.

I am working on a new release that should be out soon (before end of January - Promise). Keep your eyes open for it.

jcloth (bashtard) wrote :

I'm getting the same error.

It writes a little bit then you get Error 23 then Windows marks the drive as bad. If you reinsert the SD card you can see that the image file has partitioned the SD card.

Hopefully this helps because I'm trying to get Gentoo running on my Pi w/ and image file.

jcloth (bashtard) wrote :

I forgot... I tried a different tool and got error 23 from that program as well.

Tobin Davis (gruemaster) wrote :

I have not been able to reproduce this at all in my testing. Seeing the same error reproduced with a different tool indicates that this is not a Win32Image Writer issue. I'm going to let this bug close unless someone can give me detailed info on how they are producing this and that it doesn't happen with other apps.

Please feel free to reopen this, but please add detailed comments if you do, thanks.

Changed in win32-image-writer:
status: Triaged → Incomplete
assignee: Tobin Davis (gruemaster) → nobody
importance: Low → Undecided
Launchpad Janitor (janitor) wrote :

[Expired for Image Writer because there has been no activity for 60 days.]

Changed in win32-image-writer:
status: Incomplete → Expired
tony hammer (tonytigrr-98) wrote :

Simply, you need to format the SD card to get rid of the error code 5

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers