can't add wikia search to firefox

Bug #307475 reported by Jimbo Wales on 2008-12-12
4
Affects Status Importance Assigned to Milestone
Wikia Search UI
Medium
David Pean

Bug Description

Right now the homepage offers to me to download the toolbar. Maybe I don't want to do that. Maybe I only want to add wikia search to my firefox choice of search engines.

This used to be on the page. I heard once that it is just commented out in the code somewhere.

Please bring it back. Some users may want to commit to us in a lighter weight way than downloading the toolbar.

Jimbo Wales (jwales) on 2008-12-12
Changed in wikia-search:
importance: Undecided → Medium
David Pean (david-pean) on 2008-12-12
Changed in wikia-search:
assignee: nobody → david-pean
David Pean (david-pean) on 2008-12-15
Changed in wikia-search:
status: New → Fix Released
Jimbo Wales (jwales) wrote :

1. Unfortunately this points to re.search.wikia.com instead of search.wikia.com

2. Please change the text to say "Click to add to your browser" rather than "Click to make us your default browser search". It doesn't actually make it the default unless people check the box, and I think many more people will be willing to add us to their firefox even if they are not yet ready to make us their default. (Ideally we would A/B test these to see which performs better but it isn't really worth the effort right now.)

Jimbo Wales (jwales) wrote :

Just switching it back to "in progress" from "Fix released" pending the minor changes

Changed in wikia-search:
status: Fix Released → In Progress
markie (markie.ws) wrote :

should now be fixed in rev 681

Changed in wikia-search:
status: In Progress → Fix Committed
David Pean (david-pean) wrote :

thanks Markie..I also had to update wikiasearch.xml in r682 because that is where it loaded the baseurl for searching

markie (markie.ws) wrote :

hmmm the fix seems to have caused 2 boxes on the home page, doesnt occur on local copy though....

Yeah for FF3 there are now two boxes - one for the default search add, and
another for the toolbar

On Tue, Dec 16, 2008 at 2:10 PM, markie <email address hidden> wrote:

> hmmm the fix seems to have caused 2 boxes on the home page, doesnt occur
> on local copy though....
>
> --
> can't add wikia search to firefox
> https://bugs.launchpad.net/bugs/307475
> You received this bug notification because you are a bug assignee.
>
> Status in Wikia Search UI: Fix Committed
>
> Bug description:
> Right now the homepage offers to me to download the toolbar. Maybe I don't
> want to do that. Maybe I only want to add wikia search to my firefox choice
> of search engines.
>
> This used to be on the page. I heard once that it is just commented out in
> the code somewhere.
>
> Please bring it back. Some users may want to commit to us in a lighter
> weight way than downloading the toolbar.
>

markie (markie.ws) wrote :

not really sure why its doing it atm, think it could be something to do with internationalisation of strings/spans as it gives an error with sitelang locally, which only shows one box. not sure why the recent changes have caused it to start making 2 boxes though....

markie (markie.ws) wrote :

well i think ive found the cause of this. index.html has writeAddOnMessage() in the body onloads, which means the addon tab is being called twice. this code isnt in the svn and therefore doesnt occur locally, needs a serverside kicking.

David Pean (david-pean) wrote :

I updated the index.html in the svn....it should now be calling two seperate
functions for FF3 -- one to link to the toolbar download, the other to add
wikia search to your browser search options...you are seeing two add-on
boxes?

On Wed, Dec 17, 2008 at 12:58 PM, markie <email address hidden> wrote:

> well i think ive found the cause of this. index.html has
> writeAddOnMessage() in the body onloads, which means the addon tab is
> being called twice. this code isnt in the svn and therefore doesnt
> occur locally, needs a serverside kicking.
>
> --
> can't add wikia search to firefox
> https://bugs.launchpad.net/bugs/307475
> You received this bug notification because you are a bug assignee.
>
> Status in Wikia Search UI: Fix Committed
>
> Bug description:
> Right now the homepage offers to me to download the toolbar. Maybe I don't
> want to do that. Maybe I only want to add wikia search to my firefox choice
> of search engines.
>
> This used to be on the page. I heard once that it is just commented out in
> the code somewhere.
>
> Please bring it back. Some users may want to commit to us in a lighter
> weight way than downloading the toolbar.
>

markie (markie.ws) wrote :

hahah ahh dear...... yeah my bad.......

think we may need to change the messages a bit though so the two look more clearly different otherwise they may confuse others in the same way it confused me :(

David Pean (david-pean) wrote :

:). Yeah I'm all for that...Maybe we can just combine them into one for FF3
only...since the 'add to search engine' thing will show up for IE and
FF2..and the toolbar is only FF3
On Thu, Dec 18, 2008 at 9:42 AM, markie <email address hidden> wrote:

> hahah ahh dear...... yeah my bad.......
>
> think we may need to change the messages a bit though so the two look
> more clearly different otherwise they may confuse others in the same way
> it confused me :(
>
> --
> can't add wikia search to firefox
> https://bugs.launchpad.net/bugs/307475
> You received this bug notification because you are a bug assignee.
>
> Status in Wikia Search UI: Fix Committed
>
> Bug description:
> Right now the homepage offers to me to download the toolbar. Maybe I don't
> want to do that. Maybe I only want to add wikia search to my firefox choice
> of search engines.
>
> This used to be on the page. I heard once that it is just commented out in
> the code somewhere.
>
> Please bring it back. Some users may want to commit to us in a lighter
> weight way than downloading the toolbar.
>

Shaved Wookie (shavedwookie) wrote :

Any progress on this? I've been desperately looking for a way to just add wikia as my default search, without having a toolbar suck up extra screen real estate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers